LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 10-13-2012, 03:00 AM   #1
getanshub4u
LQ Newbie
 
Registered: Oct 2012
Posts: 19

Rep: Reputation: Disabled
mpc configure fails lfs 7.1 ch 6.16


I had successfully installed mpfr.
make check on mpfr gave following output
Code:
====================
All 160 tests passed
(1 test was not run)
====================
I get the following error when i run configure in mpc.
Code:
checking for MPFR... no
configure: error: libmpfr not found or uses a different ABI.
Please help.
 
Old 10-13-2012, 03:06 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Quote:
Originally Posted by getanshub4u View Post
I had successfully installed mpfr.
make check on mpfr gave following output
Code:
====================
All 160 tests passed
(1 test was not run)
====================
That looks ok.

Quote:
I get the following error when i run configure in mpc.
Code:
checking for MPFR... no
configure: error: libmpfr not found or uses a different ABI.
You need to give us more information to work with. Please post more of the error that is shown (or post the complete config.log file). Have a look here: Help - 1.5.2 + 1.5.3
 
Old 10-13-2012, 03:09 AM   #3
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Centos6.3/Debain
Posts: 1,762
Blog Entries: 1

Rep: Reputation: 245Reputation: 245Reputation: 245
Hi

Have a look in /usr/lib for file libmpfr
 
Old 10-13-2012, 03:28 AM   #4
getanshub4u
LQ Newbie
 
Registered: Oct 2012
Posts: 19

Original Poster
Rep: Reputation: Disabled
solved!
i had used the abi=32 flag while installing gmp.
reinstalling subsequently from gmp without using the abi flag solved this.
 
  


Reply

Tags
lfs, mpc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Patching fails in LFS 6.5 ReyJavikVI Linux From Scratch 3 12-23-2009 10:44 AM
lfs 6.4 chroot fails jason87x Linux From Scratch 5 08-06-2009 10:38 PM
lfs 6.4 chroot fails jason87x Linux - Software 1 07-01-2009 10:50 PM
./configure fails with: libz... configure: error: not found. erpe Linux - Software 17 10-11-2006 06:56 PM
make configure-host for binutils-2.16.1 fails under 7.0-cross-lfs-20051019-x86_64 Basel Linux From Scratch 2 10-25-2005 12:07 AM


All times are GMT -5. The time now is 07:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration