LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   mpc configure fails lfs 7.1 ch 6.16 (http://www.linuxquestions.org/questions/linux-from-scratch-13/mpc-configure-fails-lfs-7-1-ch-6-16-a-4175431969/)

getanshub4u 10-13-2012 02:00 AM

mpc configure fails lfs 7.1 ch 6.16
 
I had successfully installed mpfr.
make check on mpfr gave following output
Code:

====================
All 160 tests passed
(1 test was not run)
====================

I get the following error when i run configure in mpc.
Code:

checking for MPFR... no
configure: error: libmpfr not found or uses a different ABI.

Please help.

druuna 10-13-2012 02:06 AM

Quote:

Originally Posted by getanshub4u (Post 4804485)
I had successfully installed mpfr.
make check on mpfr gave following output
Code:

====================
All 160 tests passed
(1 test was not run)
====================


That looks ok.

Quote:

I get the following error when i run configure in mpc.
Code:

checking for MPFR... no
configure: error: libmpfr not found or uses a different ABI.


You need to give us more information to work with. Please post more of the error that is shown (or post the complete config.log file). Have a look here: Help - 1.5.2 + 1.5.3

spiky0011 10-13-2012 02:09 AM

Hi

Have a look in /usr/lib for file libmpfr

getanshub4u 10-13-2012 02:28 AM

solved!
i had used the abi=32 flag while installing gmp.
reinstalling subsequently from gmp without using the abi flag solved this.


All times are GMT -5. The time now is 12:00 AM.