LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
LinkBack Search this Thread
Old 12-20-2005, 08:41 PM   #1
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Rep: Reputation: 15
mount: command not found


Ok, I've gotten to the point after chrooting and I need to mount the tmpfs...but it doesn't know what the mount command is. I have chrooted, created the passwd and group file, then logged in as root. Any idea why it doesn't know what mount is?

EDIT:: It also doesn't know what the less command is eather.

Last edited by Cirdan; 12-20-2005 at 09:28 PM.
 
Old 12-20-2005, 09:55 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,506

Rep: Reputation: 116Reputation: 116
Is there a mount within the chroot? For example, if your chroot is "/chroot", you'd need a "/chroot/bin/mount".
 
Old 12-20-2005, 10:02 PM   #3
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Original Poster
Rep: Reputation: 15
my chroot is /mnt/lfs

And there is no /mnt/lfs/bin/mount

what package do I need to re-install to get the mount,unmount, and less commands from?
 
Old 12-20-2005, 10:19 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,506

Rep: Reputation: 116Reputation: 116
Mount is part of the util-linux package.
 
Old 12-20-2005, 10:31 PM   #5
Cirdan
Member
 
Registered: Nov 2005
Distribution: Arch Linux
Posts: 84

Original Poster
Rep: Reputation: 15
Ok, I reinstalled util-linux, I went to mnt/lfs/tools/bin and the mount command is there, but I get this error...

bash: /tools/bin/mount no such file or directory

but I"m in that exact directory, and I did ls and mount is in fact there. I did try re-chrooting...that didn't do anything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot mount CDROM - No Medium Found rksanders Debian 25 02-15-2011 04:04 PM
bash: <command name> command not found smash Programming 5 03-13-2006 08:48 AM
mount : No medium found Alwyn Linux - Newbie 3 01-11-2005 12:24 AM
du: command not found Wyk3d Mandriva 2 10-30-2004 03:50 PM
mount hdd but not filesys found? JsCAMRY Linux - Hardware 3 06-27-2004 01:57 PM


All times are GMT -5. The time now is 08:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration