LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 07-22-2008, 04:27 PM   #1
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Rep: Reputation: 35
Make error while compiling gcc-4.2.3 (LFS-SVN)


I know it might be out of place to report an error from a development version of the book, but still I hope somebody kind enough will try and help me here. I'm on Chapter 5.4 (GCC first pass), and I get this error while compiling
Code:
 make[3]: Leaving directory '/home/lfs/gcc-build'
Comparing stages 2 and 3
warning: ./cc1-checksum.o differs
Bootstrap comparison failure!
./insn-attrtab.o differs
make[2]: *** [compare] Error 1
make[2]: Leaving directory '/home/lfs/gcc-build'
make[1]: *** [stage3-bubble] Error 2
make[1]: Leaving directory '/home/lfs/build'
make: *** [all] Error 2
I read somewhere that this was reported in a 4.3.x build of gcc, but I'm using 4.2.3, as suggested. I'm on a Slackware 12.0 host (if that's any help).
 
Old 07-24-2008, 12:46 AM   #2
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
I'm on a Slackware 12.0 host (if that's any help).
Try to replicate with a LFS liveCD as the host. Custom CFLAGS and the like that some distros run will interfere with LFS.
 
Old 07-24-2008, 08:50 AM   #3
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Original Poster
Rep: Reputation: 35
Thanks rocket. I did as you said and gcc compiled fine. But I have another problem now. I'm in Chapter 5.7 (Adjusting the toolchain), and am trying to dump gcc's specs file. But it seems that there isn't any specs file in /tools/lib/gcc/<target-triplet>/<gcc-version>/. I did a clean build again and installed gcc, but the problem persists. It doesn't seem to be producing the specs file, or if it is, then it's not being installed. I followed procedures as mentioned in the book. Please advise.
 
Old 07-24-2008, 10:45 AM   #4
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
I'm in Chapter 5.7 (Adjusting the toolchain), and am trying to dump gcc's specs file. But it seems that there isn't any specs file in /tools/lib/gcc/<target-triplet>/<gcc-version>/.
What's the output of:

Code:
$ gcc -dumpspecs

Last edited by rocket357; 07-24-2008 at 10:50 AM.
 
Old 07-24-2008, 01:13 PM   #5
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Original Poster
Rep: Reputation: 35
Output of "gcc -dumpspecs"
Code:
*asm:
%{v:-V} %{Qy:} %{!Qn:-Qy} %{n} %{T} %{Ym,*} %{Yd,*} %{Wa,*:%*}

*asm_debug:
%{gstabs*:--gstabs}%{!gstabs*:%{g*:--gdwarf2}}

*asm_final:


*asm_options:
%a %Y %{c:%W{o*}%{!o*:-o %w%b%O}}%{!c:-o %d%w%u%O}

*invoke_as:
%{!S:-o %|.s |
 as %(asm_options) %|.s %A }

*cpp:
%{posix:-D_POSIX_SOURCE} %{pthread:-D_REENTRANT}

*cpp_options:
%(cpp_unique_options) %1 %{m*} %{std*&ansi&trigraphs} %{W*&pedantic*} %{w} %{f*} %{g*:%{!g0:%{!fno-working-directory:-fworking-directory}}} %{O*} %{undef}

*cpp_debug_options:
%{d*}

*cpp_unique_options:
%{C|CC:%{!E:%eGCC does not support -C or -CC without -E}} %{!Q:-quiet} %{nostdinc*} %{C} %{CC} %{v} %{I*&F*} %{P} %I %{MD:-MD %{!o:%b.d}%{o*:%.d%*}} %{MMD:

*trad_capable_cpp:
cc1 -E %{traditional|ftraditional|traditional-cpp:-traditional-cpp}

*cc1:
%(cc1_cpu) %{profile:-p}

*cc1_options:
%{pg:%{fomit-frame-pointer:%e-pg and -fomit-frame-pointer are incompatible}} %1 %{!Q:-quiet} -dumpbase %B %{d*} %{m*} %{a*} %{c|S:%{o*:-auxbase-strip %*}%{

*cc1plus:


*link_gcc_c_sequence:
%{static:--start-group} %G %L %{static:--end-group}%{!static:%G}

*link_ssp:
%{fstack-protector:}

*endfile:
%{ffast-math|funsafe-math-optimizations:crtfastmath.o%s}    %{shared|pie:crtendS.o%s;:crtend.o%s} crtn.o%s

*link:
%{!static:--eh-frame-hdr} -m %(link_emulation) %{shared:-shared}   %{!shared:     %{!ibcs:       %{!static:     %{rdynamic:-export-dynamic}     %{!dynamic-

*lib:
%{pthread:-lpthread}    %{shared:-lc}    %{!shared:%{mieee-fp:-lieee} %{profile:-lc_p}%{!profile:-lc}}

*mfwrap:
 %{static: %{fmudflap|fmudflapth:  --wrap=malloc --wrap=free --wrap=calloc --wrap=realloc --wrap=mmap --wrap=munmap --wrap=alloca} %{fmudflapth: --wrap=pth

*mflib:
%{fmudflap|fmudflapth: -export-dynamic}

*link_gomp:


*libgcc:
%{static|static-libgcc:-lgcc -lgcc_eh}%{!static:%{!static-libgcc:%{!shared-libgcc:-lgcc --as-needed -lgcc_s --no-as-needed}%{shared-libgcc:-lgcc_s%{!shared

*startfile:
%{!shared: %{pg|p|profile:gcrt1.o%s;pie:Scrt1.o%s;:crt1.o%s}}    crti.o%s %{static:crtbeginT.o%s;shared|pie:crtbeginS.o%s;:crtbegin.o%s}

*switches_need_spaces:


*cross_compile:
0
 
*version:
4.2.3

*multilib:
. ;
   
*multilib_defaults:


*multilib_extra:


*multilib_matches:


*multilib_exclusions:


*multilib_options:


*linker:
collect2

*link_libgcc:
%D
  
*md_exec_prefix:


*md_startfile_prefix:


*md_startfile_prefix_1:


*startfile_prefix_spec:


*sysroot_spec:
--sysroot=%R  

*sysroot_suffix_spec:


*sysroot_hdrs_suffix_spec:


*cc1_cpu:
%{!mtune*: %{m386:mtune=i386 %n`-m386' is deprecated. Use `-march=i386' or `-mtune=i386' instead.
} %{m486:-mtune=i486 %n`-m486' is deprecated. Use `-march=i486' or `-mtune=i486' instead.
} %{mpentium:-mtune=pentium %n`-mpentium' is deprecated. Use `-march=pentium' or `-mtune=pentium' instead.
} %{mpentiumpro:-mtune=pentiumpro %n`-mpentiumpro' is deprecated. Use `-march=pentiumpro' or `-mtune=pentiumpro' instead.
} %{mcpu=*:-mtune=%* %n`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
}} %<mcpu=* %{mintel-syntax:-masm=intel %n`-mintel-syntax' is deprecated. Use `-masm=intel' instead.
} %{mno-intel-syntax:-masm=att %n`-mno-intel-syntax' is deprecated. Use `-masm=att' instead.
}%{march=native:%<march=native %:local_cpu_detect(arch)   %{!mtune=*:%<mtune=native %:local_cpu_detect(tune)}} %{mtune=native:%<mtune=native %:local_cpu_de

*link_emulation:
elf_i386

*dynamic_linker:
%{muclibc:%{mglibc:%e-mglibc and -muclibc used together}/lib/ld-uClibc.so.0;:/lib/ld-linux.so.2}

*link_command:
%{!fsyntax-only:%{!c:%{!M:%{!MM:%{!E:%{!S:    %(linker) %l %{pie:-pie} %X %{o*} %{A} %{d} %{e*} %{m} %{N} %{n} %{r}    %{s} %{t} %{u*} %{x} %{z} %{Z} %{!A:
As you can see, the version is ok, but I don't know where the file is residing. I did a grep and locate, but couldn't find it. What other possible location can it be at?
 
Old 07-24-2008, 01:38 PM   #6
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
As you can see, the version is ok, but I don't know where the file is residing. I did a grep and locate, but couldn't find it. What other possible location can it be at?
You have to create the file...

Code:
gcc -dumpspecs | sed 's@/lib/ld-linux.so.2@/tools&@g' > `dirname $(gcc -print-libgcc-file-name)`/specs
will pipe the modified output of 'gcc -dumpspecs' to the specs subdir.

Did you run this before?
 
Old 07-24-2008, 02:16 PM   #7
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Original Poster
Rep: Reputation: 35
Ah...Thank you so much, rocket. Syntactic error had most probably pushed me down the cliff before. I had forgotten to pipe the -dumpspecs to it's proper location. I apologize for being so thick. Thanks once again.
 
Old 07-24-2008, 04:17 PM   #8
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
Ah...Thank you so much, rocket. Syntactic error had most probably pushed me down the cliff before. I had forgotten to pipe the -dumpspecs to it's proper location. I apologize for being so thick. Thanks once again.
Happens to the best of us...glad I could help!
 
Old 07-25-2008, 03:54 AM   #9
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Original Poster
Rep: Reputation: 35
C compiler error

In spite of all the help from rocket, there seems to be a truckload of hell in store for me. After I passed the specs file amendment, I'm getting this new error whil trying to build the binutils Pass 2 (Chapter 5.12):
Code:
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
This is the output of config.log:
Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ../binutils-2.18/configure --prefix=/tools --disable-nls --with-lib-path=/t

## --------- ##
## Platform. ##
## --------- ##

hostname = angband
uname -m = i686
uname -r = 2.6.21.5-smp
uname -s = Linux
uname -v = #2 SMP Tue Jun 19 14:58:11 CDT 2007

/usr/bin/uname -p = Intel(R) Pentium(R) 4 CPU 2.00GHz
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /tools/bin
PATH: /bin
PATH: /usr/bin
PATH: .


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1501: checking build system type
configure:1519: result: i686-pc-linux-gnu
configure:1554: checking host system type
configure:1568: result: i686-pc-linux-gnu
configure:1576: checking target system type
configure:1590: result: i686-pc-linux-gnu
configure:1633: checking for a BSD-compatible install
configure:1688: result: /bin/ginstall -c
configure:1699: checking whether ln works
configure:1721: result: yes
configure:1725: checking whether ln -s works
configure:1729: result: yes
configure:2820: checking for gcc
configure:2836: found /tools/bin/gcc
configure:2846: result: gcc
configure:3090: checking for C compiler version
configure:3093: gcc --version </dev/null >&5   
gcc (GCC) 4.2.4
Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3096: $? = 0
configure:3098: gcc -v </dev/null >&5
Reading specs from /mnt/lfs/tools/bin/../lib/gcc/i686-pc-linux-gnu/4.2.4/specs
Target: i686-pc-linux-gnu
Configured with: ../gcc-4.2.4/configure --prefix=/tools --with-local-prefix=/to
Thread model: posix
gcc version 4.2.4  
configure:3101: $? = 0
configure:3103: gcc -V </dev/null >&5
gcc: '-V' option must have argument  
configure:3106: $? = 1
configure:3129: checking for C compiler default output file name
configure:3132: gcc    conftest.c  >&5
configure:3135: $? = 0
configure:3181: result: a.out
configure:3186: checking whether the C compiler works
configure:3192: ./a.out
../binutils-2.18/configure: line 3193: ./a.out: No such file or directory
configure:3195: $? = 127
configure:3204: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnu
ac_cv_build_alias=i686-pc-linux-gnu
ac_cv_env_AR_FOR_TARGET_set=
ac_cv_env_AR_FOR_TARGET_value=
ac_cv_env_AR_set=
ac_cv_env_AR_value=
ac_cv_env_AS_FOR_TARGET_set=
ac_cv_env_AS_FOR_TARGET_value=
ac_cv_env_AS_set=
ac_cv_env_AS_value=
ac_cv_env_CC_FOR_TARGET_set=
ac_cv_env_CC_FOR_TARGET_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CXXFLAGS_set=  
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_FOR_TARGET_set=
ac_cv_env_CXX_FOR_TARGET_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_DLLTOOL_FOR_TARGET_set=
ac_cv_env_DLLTOOL_FOR_TARGET_value=
ac_cv_env_DLLTOOL_set=
ac_cv_env_DLLTOOL_value=
ac_cv_env_GCC_FOR_TARGET_set=
ac_cv_env_GCC_FOR_TARGET_value=
ac_cv_env_GCJ_FOR_TARGET_set=  
ac_cv_env_GCJ_FOR_TARGET_value=
ac_cv_env_GFORTRAN_FOR_TARGET_set=
ac_cv_env_GFORTRAN_FOR_TARGET_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LD_FOR_TARGET_set=
ac_cv_env_LD_FOR_TARGET_value=
ac_cv_env_LD_set=
ac_cv_env_LD_value=
ac_cv_env_LIPO_FOR_TARGET_set=
ac_cv_env_LIPO_FOR_TARGET_value=
ac_cv_env_LIPO_set=
ac_cv_env_LIPO_value=
ac_cv_env_NM_FOR_TARGET_set=
ac_cv_env_NM_FOR_TARGET_value=
ac_cv_env_NM_set=
ac_cv_env_NM_value=
ac_cv_env_OBJCOPY_set=
ac_cv_env_OBJCOPY_value=
ac_cv_env_OBJDUMP_FOR_TARGET_set=
ac_cv_env_OBJDUMP_FOR_TARGET_value=
ac_cv_env_OBJDUMP_set=
ac_cv_env_OBJDUMP_value=
ac_cv_env_RANLIB_FOR_TARGET_set=
ac_cv_env_RANLIB_FOR_TARGET_value=
ac_cv_env_RANLIB_set=
ac_cv_env_RANLIB_value=
ac_cv_env_STRIP_FOR_TARGET_set=
ac_cv_env_STRIP_FOR_TARGET_value=
ac_cv_env_STRIP_set=
ac_cv_env_STRIP_value=
ac_cv_env_WINDMC_FOR_TARGET_set=
ac_cv_env_WINDMC_FOR_TARGET_value=
ac_cv_env_WINDMC_set=
ac_cv_env_WINDMC_value=
ac_cv_env_WINDRES_FOR_TARGET_set=
ac_cv_env_WINDRES_FOR_TARGET_value=
ac_cv_env_WINDRES_set=
ac_cv_env_WINDRES_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=   
ac_cv_env_host_alias_value= 
ac_cv_env_target_alias_set= 
ac_cv_env_target_alias_value=
ac_cv_exeext=
ac_cv_host=i686-pc-linux-gnu
ac_cv_host_alias=i686-pc-linux-gnu
ac_cv_path_install='/bin/ginstall -c'
ac_cv_prog_ac_ct_CC=gcc
ac_cv_target=i686-pc-linux-gnu
ac_cv_target_alias=i686-pc-linux-gnu
acx_cv_prog_LN=ln

## ----------------- ##
## Output variables. ##
## ----------------- ##

AR=''
AR_FOR_TARGET=''
AS=''
AS_FOR_TARGET=''
BISON=''
CC='gcc'
CC_FOR_BUILD='$(CC)'
CC_FOR_TARGET=''
CFLAGS=''
CFLAGS_FOR_BUILD=''
COMPILER_AS_FOR_TARGET=''
COMPILER_LD_FOR_TARGET=''
COMPILER_NM_FOR_TARGET=''
CONFIGURE_GDB_TK=''
CPPFLAGS=''
CXX=''
CXXFLAGS=''
CXX_FOR_TARGET=''
DEFS=''
DLLTOOL=''
DLLTOOL_FOR_TARGET=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''  
EXEEXT=''  
EXPECT=''  
FLAGS_FOR_TARGET=''
FLEX=''
GCC_FOR_TARGET=''
GCJ_FOR_TARGET=''
GDB_TK=''
GFORTRAN_FOR_TARGET=''
GNATBIND=''
GNATMAKE=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_GDB_TK=''
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}' 
LD=''
LDFLAGS=''
LD_FOR_TARGET=''
LEX=''
LIBOBJS=''
LIBS=''   
LIPO=''   
LIPO_FOR_TARGET=''
LN='ln'
LN_S='ln -s'
LTLIBOBJS=''
M4=''
MAINT=''
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE='' 
MAKEINFO=''
NM=''
NM_FOR_TARGET=''
OBJCOPY=''
OBJDUMP=''
OBJDUMP_FOR_TARGET=''
OBJEXT=''
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
RANLIB=''
RANLIB_FOR_TARGET=''
RAW_CXX_FOR_TARGET=''
RPATH_ENVVAR=''
RUNTEST=''
SHELL='/bin/sh'
STRIP=''
STRIP_FOR_TARGET=''
SYSROOT_CFLAGS_FOR_TARGET=''
TOPLEVEL_CONFIGURE_ARGUMENTS='../binutils-2.18/configure --prefix=/tools --disa
WINDMC=''
WINDMC_FOR_TARGET=''
WINDRES=''
WINDRES_FOR_TARGET=''
YACC=''
ac_ct_CC='gcc'
ac_ct_CXX=''  
ac_ct_GNATBIND=''
ac_ct_GNATMAKE=''
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'  
build_alias=''
build_configargs=''
build_configdirs='build-libiberty build-texinfo build-byacc build-flex build-bi
build_cpu='i686'
build_libsubdir='build-i686-pc-linux-gnu'
build_noncanonical='i686-pc-linux-gnu'   
build_os='linux-gnu'
build_subdir='build-i686-pc-linux-gnu'
build_tooldir=''
build_vendor='pc'
config_shell='/bin/sh'
configdirs='intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib
datadir='${prefix}/share'
datarootdir=''
do_compare='' 
docdir=''
exec_prefix='NONE'
gmpinc=''
gmplibs=''
host='i686-pc-linux-gnu'
host_alias=''
host_configargs=''
host_cpu='i686'   
host_noncanonical='i686-pc-linux-gnu'
host_os='linux-gnu'
host_subdir='.'
host_vendor='pc'
htmldir=''
includedir='${prefix}/include'
infodir='${prefix}/info'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
oldincludedir='/usr/include'
pdfdir=''
prefix='/tools'
program_transform_name='s,y,y,'
sbindir='${exec_prefix}/sbin'  
sharedstatedir='${prefix}/com' 
stage1_cflags=''
stage1_checking=''
stage1_languages=''
stage2_werror_flag=''
sysconfdir='${prefix}/etc'
target='i686-pc-linux-gnu'
target_alias=''
target_configargs=''
target_cpu='i686'   
target_noncanonical='i686-pc-linux-gnu'
target_os='linux-gnu'
target_subdir='i686-pc-linux-gnu'
target_vendor='pc'
tooldir=''

## ------------- ##
## Output files. ##
## ------------- ##

alphaieee_frag=''
host_makefile_frag='config/mh-x86omitfp'
ospace_frag=''
serialization_dependencies=''
target_makefile_frag=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""

configure: exit 1
What can be the problem here? I have encountered this error in the past, but that was due to the partition not being mounted executable. That's not the case now. I got this error after i performed the specs file amend. Could it be that configure is not able to find gcc in the PATH? But why now, all of a sudden? Please advise.
 
Old 07-25-2008, 04:46 AM   #10
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
binutils pass 2 is not chapter 5.12
it is 6.11
Have you mixed up where in the process you where?

Last edited by jomen; 07-25-2008 at 04:47 AM.
 
Old 07-25-2008, 10:07 AM   #11
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Original Poster
Rep: Reputation: 35
Well, Jomen, I'm pretty sure that "Binutils-2.18 - Pass 2" is the title of Chapter 5.12. Yes, 6.11 also deals with Binutils, but that is when you have started with the actual building and installation of the LFS system. That chapter is simply titled as "binutils-2.18". Right now I'm at the stage where I'm setting up the temp system. 5.12 is next after you're done with "GCC - Pass 2". Has the reinstallation of gcc caused this problem? I'm following procedures strictly as mentioned in the book, with no customizations.
 
Old 07-25-2008, 10:18 AM   #12
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
This is the output of config.log:
[CODE]Configured with: ../gcc-4.2.4/configure --prefix=/tools --with-local-prefix=/to
Ummm, --with-local-prefix=/to?

Post your specs file that you generated...

Edit - nevermind, noticed that you must've copied and pasted from a term that truncates long lines.

Last edited by rocket357; 07-25-2008 at 10:20 AM.
 
Old 07-25-2008, 10:26 AM   #13
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
This is the output of config.log:
Code:
configure:2820: checking for gcc
configure:2836: found /tools/bin/gcc
configure:2846: result: gcc
configure:3090: checking for C compiler version
configure:3093: gcc --version </dev/null >&5   
gcc (GCC) 4.2.4
Could it be that configure is not able to find gcc in the PATH?
Nope...gcc is found on the PATH just fine. Sounds like something is wrong with the specs file and/or gcc. Please post the specs, and run a test...

Code:
echo 'main(){}' > dummy.c
cc dummy.c
readelf -l a.out | grep ': /tools'
and post the output of the test as well (especially any errors after the second command).
 
Old 07-25-2008, 10:30 AM   #14
rocket357
Member
 
Registered: Mar 2007
Location: 127.0.0.1
Distribution: OpenBSD-CURRENT
Posts: 476
Blog Entries: 107

Rep: Reputation: 74
Quote:
Originally Posted by corbis_demon View Post
Code:
configure:3093: gcc --version </dev/null >&5   
gcc (GCC) 4.2.4
Wait, wait, wait...aren't you compiling 4.2.3?!?

Sounds like you might've generated a specs file for the host's gcc? Are you using Slackware on this?
 
Old 07-25-2008, 10:58 AM   #15
corbis_demon
Member
 
Registered: Jun 2004
Location: India
Distribution: Slack 13
Posts: 494

Original Poster
Rep: Reputation: 35
I have absolutely no idea as to how the specs file showed the version as 4.2.4. So I wiped out everything and started again. I got thru the 2nd GCC pass and again while building binutils, the aforementioned error popped up. Here's the specs file dump:
Code:
*asm:
%{v:-V} %{Qy:} %{!Qn:-Qy} %{n} %{T} %{Ym,*} %{Yd,*} %{Wa,*:%*}

*asm_debug:
%{gstabs*:--gstabs}%{!gstabs*:%{g*:--gdwarf2}}

*asm_final:


*asm_options: 
%a %Y %{c:%W{o*}%{!o*:-o %w%b%O}}%{!c:-o %d%w%u%O}

*invoke_as:
%{!S:-o %|.s |
 as %(asm_options) %|.s %A }

*cpp:
%{posix:-D_POSIX_SOURCE} %{pthread:-D_REENTRANT}

*cpp_options:
%(cpp_unique_options) %1 %{m*} %{std*&ansi&trigraphs} %{W*&pedantic*} %{w} %{f*

*cpp_debug_options:
%{d*}

*cpp_unique_options:
%{C|CC:%{!E:%eGCC does not support -C or -CC without -E}} %{!Q:-quiet} %{nostdi

*trad_capable_cpp:
cc1 -E %{traditional|ftraditional|traditional-cpp:-traditional-cpp}

*cc1:
%(cc1_cpu) %{profile:-p}

*cc1_options:
%{pg:%{fomit-frame-pointer:%e-pg and -fomit-frame-pointer are incompatible}} %1

*cc1plus:


*link_gcc_c_sequence:
%{static:--start-group} %G %L %{static:--end-group}%{!static:%G}

*link_ssp:
%{fstack-protector:}

*endfile:
%{ffast-math|funsafe-math-optimizations:crtfastmath.o%s}    %{shared|pie:crtend

*link:
%{!static:--eh-frame-hdr} -m %(link_emulation) %{shared:-shared}   %{!shared:

*lib:
%{pthread:-lpthread}    %{shared:-lc}    %{!shared:%{mieee-fp:-lieee} %{profile

*mfwrap:
 %{static: %{fmudflap|fmudflapth:  --wrap=malloc --wrap=free --wrap=calloc --wr

*mflib:
%{fmudflap|fmudflapth: -export-dynamic}

*link_gomp:


*libgcc:
%{static|static-libgcc:-lgcc -lgcc_eh}%{!static:%{!static-libgcc:%{!shared-libg

*startfile:
%{!shared: %{pg|p|profile:gcrt1.o%s;pie:Scrt1.o%s;:crt1.o%s}}    crti.o%s %{sta

*switches_need_spaces:


*cross_compile:
0
 
*version:
4.2.3

*multilib:
. ;
   
*multilib_defaults:


*multilib_extra:


*multilib_matches:


*multilib_exclusions:


*multilib_options:


*linker:
collect2

*link_libgcc:
%D
  
*md_exec_prefix:


*md_startfile_prefix:


*md_startfile_prefix_1:


*startfile_prefix_spec:


*sysroot_spec:
--sysroot=%R  

*sysroot_suffix_spec:


*sysroot_hdrs_suffix_spec:


*cc1_cpu:
%{!mtune*: %{m386:mtune=i386 %n`-m386' is deprecated. Use `-march=i386' or `-mt
} %{m486:-mtune=i486 %n`-m486' is deprecated. Use `-march=i486' or `-mtune=i486
} %{mpentium:-mtune=pentium %n`-mpentium' is deprecated. Use `-march=pentium' o
} %{mpentiumpro:-mtune=pentiumpro %n`-mpentiumpro' is deprecated. Use `-march=p
} %{mcpu=*:-mtune=%* %n`-mcpu=' is deprecated. Use `-mtune=' or '-march=' inste
}} %<mcpu=* %{mintel-syntax:-masm=intel %n`-mintel-syntax' is deprecated. Use `
} %{mno-intel-syntax:-masm=att %n`-mno-intel-syntax' is deprecated. Use `-masm=
}%{march=native:%<march=native %:local_cpu_detect(arch)   %{!mtune=*:%<mtune=na

*link_emulation:
elf_i386

*dynamic_linker:
%{muclibc:%{mglibc:%e-mglibc and -muclibc used together}/tools/lib/ld-uClibc.so

*link_command:
%{!fsyntax-only:%{!c:%{!M:%{!MM:%{!E:%{!S:    %(linker) %l %{pie:-pie} %X %{o*}
This is the output of the test:
Code:
bash-3.1$ readelf -l a.out | grep ': /tools'
      [Requesting program interpreter: /tools/tools/lib/ld-linux.so.2]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error using lfs while compiling lfs book's 6.12 (gcc-4.1.2) section aditya_gpch Linux From Scratch 3 04-24-2008 04:23 PM
error while compiling gcc in lfs 6.12 aditya_gpch Linux - Newbie 3 04-19-2008 05:54 AM
error while compiling gcc in lfs 6.12 aditya_gpch Linux - Software 1 04-19-2008 04:37 AM
GCC error when compiling it for LFS safrout Linux From Scratch 1 06-14-2003 06:16 AM


All times are GMT -5. The time now is 04:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration