LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
LinkBack Search this Thread
Old 12-09-2011, 04:34 AM   #1
devilboy09
Member
 
Registered: Nov 2011
Location: Iran
Distribution: Debian, CentOS, LFS
Posts: 351

Rep: Reputation: 7
libbonobo dependency problem


according to the book the dependencied for this package are :

D-Bus GLib Bindings-0.88
intltool-0.41.1
libxml2-2.7.8
ORBit2-2.14.19
popt-1.16

i installed this packages, but when i want to make libbonobo package i'm getting this dependency error :
Code:
No packages 'libgnomecanvas-2.0' found
No package 'libbonobo-2.0' found
No package 'libgnome-2.0' found
No package 'bonobo-activation-2.0' found
No package 'gconf-2.0' found
No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variable BONOBOUI_CFLAGS and BONOBOUI_LIBS to avoid the need to call pkg-config.
BTW : i'm installing gnome in /usr directory
 
Old 12-09-2011, 11:45 AM   #2
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,611
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
Dis you setup the pre installation
http://www.linuxfromscratch.org/blfs...ll-config.html
 
Old 12-09-2011, 12:55 PM   #3
devilboy09
Member
 
Registered: Nov 2011
Location: Iran
Distribution: Debian, CentOS, LFS
Posts: 351

Original Poster
Rep: Reputation: 7
i just executed the first command( export GNOME_PREFIX=/usr ). because i want to install it, not try it
 
Old 12-09-2011, 03:40 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

It seems you are using the libbonoboui-2.24.3 package and are using the libbonobo-2.24.3 chapter to build it......
Quote:
No packages 'libgnomecanvas-2.0' found
No package 'libbonobo-2.0' found
No package 'libgnome-2.0' found
No package 'bonobo-activation-2.0' found
No package 'gconf-2.0' found
No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variable BONOBOUI_CFLAGS and BONOBOUI_LIBS to avoid the need to call pkg-config.
Also look at the packages that aren't found, all (indirect) dependencies for libbonoboui and not libbonobo.

Hope this helps.
 
Old 12-09-2011, 04:04 PM   #5
devilboy09
Member
 
Registered: Nov 2011
Location: Iran
Distribution: Debian, CentOS, LFS
Posts: 351

Original Poster
Rep: Reputation: 7
the download link in book was wrong !!!
thank u, guys
 
Old 12-09-2011, 04:16 PM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,
Quote:
Originally Posted by devilboy09 View Post
the download link in book was wrong !!!
Links for both packages work for me (using the BLFS online book: libbonobo and libbonoboui)

Quote:
thank u, guys
Glad to see you got this solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] apt-get problem (Problem parsing dependency Depends) feeblebrain Debian 9 01-10-2012 02:53 PM
libbonobo-2.14.0, no working gthread-2.0 found... accp-james Linux From Scratch 0 04-27-2007 09:03 AM
dependency problem black_man Debian 3 12-04-2005 07:55 PM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
Can't compile libbonobo-2.6.0! xonner Linux - Software 1 05-24-2004 08:35 AM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration