LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
LinkBack Search this Thread
Old 04-27-2007, 09:03 AM   #1
accp-james
LQ Newbie
 
Registered: Apr 2007
Posts: 6

Rep: Reputation: 0
libbonobo-2.14.0, no working gthread-2.0 found...


I successfully built LFS svn04202007, I state successfully because everything seems to work and up until this package I've had no build errors.

I'm using the BLFS 6.2 release instructions for building GNOME as suggested by the current SVN document.

The precise error I receive is when using ./configure, either with customized options or using the cut-and-paste version from the book:

Code:
configure: error: No working gthread-2.0 support found, using --disae-threads IS DISCOURAGED
Here's what I know: If I unset PKG_CONFIG_PATH then I receive messages indicating that ORBit and glib are not installed, so I can be fairly certain that pkgconfig is doing its job.

glib builds with no errors, and make check generates no warnings.

GTK and other items with glib as a requisite build successfully. (It's worth noting that glib is not listed as a requirement for libbonobo in the BLFS book!)

I have no real idea how to test the functionality of libgthread or what else to look at in terms of diagnosing this issue, but uh.. it's kind of a build breaker so if anyone can make a suggestion I'd appreciate it.

For reference I'm using glib-2.10.3, the version used in the 6.2 BLFS release and the SVN BLFS I'm using for everything but GNOME.

Edit to add info:

I went ahead and started tearing in to the configure script to see what I could come up with... During the test for gthread-2.0 the script has the following:
Code:
#include <glib/gthread.h>
                       int main (void) {
                               if (!g_thread_supported()) g_thread_init(NULL);
                               return NULL == g_mutex_new(); }
When I look in /usr/include, however, I find no 'glib' directory. I find a glib-2.0 directory with a 'glib' directory located inside it... Are my headers perhaps in the wrong place?

Last edited by accp-james; 04-27-2007 at 11:01 PM.
 
  


Reply

Tags
blfs, glib, gnome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GThread-ERROR **:Glib thread support is disabled pankaj99 Linux - General 0 06-03-2006 08:01 PM
MPlayer Plugin missing gthread package jonasan Linux - Software 1 05-25-2006 11:01 AM
gthread example santhosh.linux Programming 1 02-13-2006 04:02 PM
gtkm-2.0 pc, and gthread-2.0pc paul62 Linux - Software 0 10-05-2004 03:26 PM
Can't compile libbonobo-2.6.0! xonner Linux - Software 1 05-24-2004 08:35 AM


All times are GMT -5. The time now is 02:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration