Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 04-19-2005, 03:36 PM   #1
Registered: Jan 2004
Distribution: LFS
Posts: 91

Rep: Reputation: 15
LFS6.0 Glibc compile problem Chapter5.8 Pass1


Having started my LFS6.0 build, I have found myself stuck with the first compilation of Glibc. (It would be a package with an 11SBU build time !!)

Anyway, configure works ok, but when I do the make, it chuggs away for ages before reaching the following error:-

/mnt/lfs/sources/glibc-build/debug/libsegfault_pic.a(segfault.os)(.text+ox878): In function 'catch_segfault':
../sysdeps/generic/segfault.c:167: undefined reference to '__backtrace_symbols_fd'
collect2:ld returned 1 exit status
make[2]: *** [/mnt/lfs/sources/glibc-build/debug/] Error 1
make[2]: Leaving directory '/mnt/lfs/sources/glibc-2.3.4-20040701/debug'
make[1]: *** [debug/others] Error 2
make [1]: Leaving directory '/mnt/lfs/sources/glibc-2.3.4-20040701'
make: *** [all] Error 2
Can anyone help with this? I'm trying to get my new homeserver up and running, the current one is on its last legs (running LFS 5).


Old 04-19-2005, 04:50 PM   #2
Senior Member
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
hard to answer since you didn't state your host ( I'm not sure if the 5.5 is the host or you mean 5.5 is on a different machine), but it's a problem with your hosts system glibc. glibc installs /lib/ and that is where the symbol you need resides.

Last edited by __J; 04-19-2005 at 04:52 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 04:22 PM
glibc pass1--configure error keyur Linux From Scratch 5 01-30-2009 06:05 AM
strange Glibc compile problem Blaza Linux - Software 1 09-01-2004 02:50 PM
Does anyone know how to re-compile glibc ? oskernel Programming 1 10-18-2003 04:29 AM
glibc v2.2.5 compile problem mavx Linux - Software 2 06-12-2002 12:11 PM

All times are GMT -5. The time now is 05:18 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration