LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 09-17-2008, 07:00 PM   #1
klearview
Member
 
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Rep: Reputation: 75
LFS: How To Configure Linux Console For UK Keyboard


Having set up LFS for servers a few times before, I am now trying to build a viable, fully functional desktop OS with it on my new laptop.

First hurdle (never had to bother about it on servers) - how to properly set Linux Console in /etc/sysconfig/console for UK keyboard (LFS 6.3, paragraph 7.6). Googling didn't produce that much but Gentoo wiki suggests this configuration:

KEYMAP="uk"

CONSOLEFONT="default8x16"

Anyone knows if this is correct?

P.S. Actually 'CONSOLEFONT' would most likely be incorrect as LFS says it's 'FONT=<something> -m <something>'

Last edited by klearview; 09-17-2008 at 07:24 PM. Reason: P.S. added
 
Old 09-17-2008, 10:58 PM   #2
klearview
Member
 
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Original Poster
Rep: Reputation: 75
[UPDATE - SEMI-SOLVED]

Looking through documentation told me that setting for keymap would indeed be:

KEYMAP="uk"

With regards to setting for FONT= , I'm still unsure but I'll just leave it out for now.
 
Old 09-19-2008, 05:11 AM   #3
just.srad
Member
 
Registered: Apr 2008
Location: Singapore
Distribution: Slackware 14.0
Posts: 126

Rep: Reputation: 15
i have the keyboard layout issue. i cannot get the US keyboard layout.


I happen to find out that we need a corresponding file that to be called by KEYMAP.
The directory that the file resides would be "/lib/kbd/keymaps/i386/azerty/ ".

Right now.. i do not know where should i find the keymap file.

Anyone out here got any idea? Thanks lot for any kind pointer.
 
Old 09-21-2008, 08:33 AM   #4
just.srad
Member
 
Registered: Apr 2008
Location: Singapore
Distribution: Slackware 14.0
Posts: 126

Rep: Reputation: 15
i removed the /etc/sysconfig/console or you may just rename it.

Do a reboot and bingo! . You should able to use the keyboard as expected.
 
Old 11-10-2008, 03:47 PM   #5
flusteredpie
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by klearview View Post
[UPDATE - SEMI-SOLVED]

Looking through documentation told me that setting for keymap would indeed be:

KEYMAP="uk"

With regards to setting for FONT= , I'm still unsure but I'll just leave it out for now.
Just booted into my LFS system for the first time and that tidbit of information was very helpful. Thanks!
 
  


Reply

Tags
console, keyboard, lfs, uk


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure serial console on LIVE linux box? TotalDefiance Linux - Software 2 05-01-2006 12:11 PM
Keyboard (any) doesn work on LFS 6.1.1 nistur Linux From Scratch 5 04-12-2006 05:02 AM
Keyboard and moust not working in linux after configure sound card 012633023 Linux - Newbie 11 01-25-2005 09:57 AM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration