LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   LFS GCC - first pass install error (http://www.linuxquestions.org/questions/linux-from-scratch-13/lfs-gcc-first-pass-install-error-512218/)

arnuld 12-20-2006 07:27 AM

LFS GCC - first pass install error
 
i am trying to install Glibc first pass & i typed this command as suggested by LFS chapter 5:

../glibc-2.3.6/configure --prefix=/tools
--disable-profile --enable-add-ons
--enable-kernel=2.6.0 --with-binutils=/tools/bin
--without-gd --with-headers=/tools/include
--without-selinux

i get an error something like:

"almost all of the time glibc on gnu/linux is commpiled with "linuxthreads" add-ons. If you dont do this feature then you will have compatibility problems with gnu/linux. if you are sure you dont want this add-on use --disable-sanity-checking"

after this, of course, the configuration stops :-(

well, i used /--enable-addons/, still it is saying as if i am disabling them. what is wrong? how to correct it so that i can proceed?

i have one more trouble. LFS book says build directory needs to be different from source directory but it does not explain where should i create my "build" directories. while current directory is "$LFS/sources" it says:

"mkdir -v ../glibc-build"

which of course raises an error:

"can not create directory: permission denied"

it is right as i am building as USER not as ROOT who owns "/". as "lfs USER" i own "$LFS/sources" & "$LFS/tools" but not "/".

what do ".." mean? "." represents current-directory. from error i guess 2 dots dont mean anything. right now i am making build-directories in "$LFS/sources/".

any help?

druuna 12-20-2006 08:27 AM

Hi,

The command given is incorrect, there should be backslashes behind the lines if they are spread over more then one line.

I.e.:

../glibc-2.3.6/configure --prefix=/tools --disable-profile --enable-add-ons --enable-kernel=2.6.0 --with-binutils=/tools/bin --without-gd --with-headers=/tools/include --without-selinux

or

../glibc-2.3.6/configure --prefix=/tools \
--disable-profile --enable-add-ons \
--enable-kernel=2.6.0 --with-binutils=/tools/bin \
--without-gd --with-headers=/tools/include \
--without-selinux

The first one is one (!) line.

The other question you have I've already answered several times: Take a look here (second post).

Hope this helps.

arnuld 12-20-2006 08:59 AM

Quote:

Originally Posted by druuna
Hi,

The command given is incorrect, there should be backslashes behind the lines if they are spread over more then one line.

I.e.:

../glibc-2.3.6/configure --prefix=/tools --disable-profile --enable-add-ons --enable-kernel=2.6.0 --with-binutils=/tools/bin --without-gd --with-headers=/tools/include --without-selinux

or

../glibc-2.3.6/configure --prefix=/tools \
--disable-profile --enable-add-ons \
--enable-kernel=2.6.0 --with-binutils=/tools/bin \
--without-gd --with-headers=/tools/include \
--without-selinux

The first one is one (!) line.

it WAS on one line as i did not press "enter" while writing the command on terminal.

Quote:

Originally Posted by druuna
The other question you have I've already answered several times: Take a look here (second post).

ok i will read it, i am on cyber-cafe. i will go home check it on my slow broad band :-(


All times are GMT -5. The time now is 06:55 AM.