LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   LFS: "eth0 does not exist" w/ multiple interfaces. Also, system will not shutdown. (http://www.linuxquestions.org/questions/linux-from-scratch-13/lfs-eth0-does-not-exist-w-multiple-interfaces-also-system-will-not-shutdown-885219/)

TwoGuesses 06-08-2011 10:08 AM

LFS: "eth0 does not exist" w/ multiple interfaces. Also, system will not shutdown.
 
Hello!

I've recently completed my first LFS build, and I've run into several problems, regardless of the general success.

First off, when I boot my system, everything goes as normal. (BIOS splash -> Grub -> LFS kernel booting) However, towards the end of when the kernel boots, I get the following lines:

Quote:

Starting system log daemon... [ OK ]
Starting kernel log daemon... [ OK ]
Bringing up the eth0 interface...
Interface eth0 doesn't exist. [WARN]
Bringing up the eth1 interface...
[ 17.602604] eth1: no link during initialization.
[ 17.603847] ADDRCONF(NETDEV_UP): eth1 link is not ready
Adding IPv4 address 192.168.1.1 to the eth1 interface.
Followed by the login prompt. I also get the Interface eth0 doesn't exist. [WARN] line at (attempted) shutdown.
In my configuration, I have the integrated ethernet port in my motherboard, while also a standard 10/100 Linksys PCI card. (My full setup should be in my sig)

I'm not all the clear with networking, but what I'm trying to do is set up the linksys card (eth0) with a router for Internet access, and have the integrated one set up for future use. I was trying to see if I could get eth0 to at least connect to the router so the router would detect it's hostname and I could add it to the router's DCHP reservation, but do I need to set up the DHCP client in LFS before any kind of connection with the router?

Here is some configuration information that will hopefully aid aid:

ip link output:
Quote:

1: lo: <lookback, up, lower_up> mtu 16436 gdisc noqueue state UNKNOWN
2: eth1: <NO-CARRIER, BROADCAST, MULTICAST, UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
link/ether xx:xx:xx:xx:xx:xx
3: sit0: <NOARP> mtu 1480 qdisc noop state DOWN
link/sit 0.0.0.0 brd 0.0.0.0
The "xx:xx:xx:xx:xx:xx" is the MAC address of the integrated ethernet port.

For the sake of this post, I will say the hostname is actually "hostname".

Here's my /etc/hosts:
Quote:

# Begin /etc/hosts (network card version)

127.0.0.1 localhost
192.168.1.x hostname

# End /etc/hosts (network card version)
"x" being the static IP I set up on the router for hostname

here is my /etc/udev/rules.d/70-persistent-net.rules:
Quote:

# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x1317:0x0985 (tulip) This is the PCI card, Linksys
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="yy:yy:yy:yy:yy:yy", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10de:0x0760 (forcedeth) This is the integrated Nvidia Nforce Network Controller
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"


On another note, my system will not shutdown after the "shutdown -h now" command is issued. It goes through the whole process of killing process, etc, but when the computer would normally shut off, it simply turns back on as though I had rebooted it.
I've read the FAQ on this, and know that it is probably something with the kernel, however, I don't know where to look. I know AHCI is enabled.

Thanks, any help is appreciated!
My system should be in the sig within a few minutes after the post.



Hopefully this is enough information.. Help is appreciated!

druuna 06-08-2011 10:56 AM

Hi,
Quote:

Originally Posted by TwoGuesses (Post 4379983)
Bringing up the eth0 interface...
Interface eth0 doesn't exist. [WARN]
Bringing up the eth1 interface...
[ 17.602604] eth1: no link during initialization.
[ 17.603847] ADDRCONF(NETDEV_UP): eth1 link is not ready
Adding IPv4 address 192.168.1.1 to the eth1 interface.

This points to a missing network driver in the kernel (I'm talking about eth0). Select the correct driver for this network card.

Quote:

Followed by the login prompt. I also get the Interface eth0 doesn't exist. [WARN] line at (attempted) shutdown.
If eth0 wasn't brought up correctly it cannot be brought down correctly. This will disappear after you solved the network driver problem.

Check your log files to figure out which network card is detected. Lspci isn't installed yet so you cannot use that to check the other card, you might want to check the log files of another linux distro running on that machine (or if you used the LFS liveCD, use the lspci command that is present).

Quote:

I'm not all the clear with networking, but what I'm trying to do is set up the linksys card (eth0) with a router for Internet access, and have the integrated one set up for future use. I was trying to see if I could get eth0 to at least connect to the router so the router would detect it's hostname and I could add it to the router's DCHP reservation, but do I need to set up the DHCP client in LFS before any kind of connection with the router?
DHCP isn't part of LFS, have a look at the BLFS book and follow the steps to set up DHCP (client).

But you first need to solve the network card issue. Everything else will probably fall into place once that is resolved.

Hope this helps.

TwoGuesses 06-12-2011 10:26 PM

Thanks, I found the correct Tulip driver and it worked.
... I apologize for the obviousness (and delay) of the question.

druuna 06-13-2011 03:00 AM

Hi,
Quote:

Originally Posted by TwoGuesses (Post 4383768)
Thanks, I found the correct Tulip driver and it worked.

I'm glad you've got this solved :)

Quote:

... I apologize for the obviousness (and delay) of the question.
No need to apologize ;)


All times are GMT -5. The time now is 11:04 PM.