LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 11-07-2012, 10:30 AM   #1
Lancelot1
Member
 
Registered: Dec 2007
Location: Amsterdam
Distribution: (K)Ubuntu
Posts: 102

Rep: Reputation: 15
LFS chap 6.9 error building glibc


when building glibc getting the following error:

error: ‘__EI___isnanf’ aliased to external symbol ‘__GI___isnanf’
make[2]: *** [/media/_/sources/glibc-build/math/s_isnanf.os] Error 1
make[2]: Leaving directory `/media/_/sources/glibc-2.16.0/math'
make[1]: *** [math/subdir_lib] Error 2
make[1]: Leaving directory `/media/_/sources/glibc-2.16.0'
make: *** [all] Error 2

Any idea how to fix it??
 
Old 11-07-2012, 08:09 PM   #2
stoat
Member
 
Registered: May 2007
Distribution: LFS
Posts: 458

Rep: Reputation: 133Reputation: 133
Well no, I don't have an idea to fix that. Sorry. But it's been all day and nobody else posted anything. So I would try going back up to the /source directory, delete the build directory, untar the tarball again, and run through the steps again. That page has a several seds and a patch. Maybe something was skipped. Anyway, it can't make it worse to try.
 
Old 11-08-2012, 12:08 AM   #3
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,026

Rep: Reputation: 441Reputation: 441Reputation: 441Reputation: 441Reputation: 441
You are only including the end of make file you most likey have an exact error showing during the compilation. Another thing I noticed is maybe you're not chrooted into lfs as noted by /media/_/sources. I would assume /media/_/sources to be /media/some_bignumber/sources.

Last edited by EDDY1; 11-08-2012 at 07:04 AM.
 
Old 11-08-2012, 01:54 AM   #4
Lancelot1
Member
 
Registered: Dec 2007
Location: Amsterdam
Distribution: (K)Ubuntu
Posts: 102

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stoat View Post
Well no, I don't have an idea to fix that. Sorry. But it's been all day and nobody else posted anything. So I would try going back up to the /source directory, delete the build directory, untar the tarball again, and run through the steps again. That page has a several seds and a patch. Maybe something was skipped. Anyway, it can't make it worse to try.
will do but I don't think it will help
 
Old 11-08-2012, 01:55 AM   #5
Lancelot1
Member
 
Registered: Dec 2007
Location: Amsterdam
Distribution: (K)Ubuntu
Posts: 102

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by EDDY1 View Post
You are only including yje end of make file you most likey have an exact error showing during the compilation. Another thing I noticed is maybe you're not chrooted into lfs as noted by /media/_/sources. I would assume /media/_/sources to be /media/some_bignumber/sources.

?? don't understand what you mean? I will run the make again and try to find the exact error and post it
 
Old 11-08-2012, 03:34 AM   #6
Lancelot1
Member
 
Registered: Dec 2007
Location: Amsterdam
Distribution: (K)Ubuntu
Posts: 102

Original Poster
Rep: Reputation: 15
you are right Eddy. It was a chroot error. Fixed it now, working ok
 
Old 11-08-2012, 07:00 AM   #7
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,026

Rep: Reputation: 441Reputation: 441Reputation: 441Reputation: 441Reputation: 441
Congrats, glad you figured it out.

Last edited by EDDY1; 11-08-2012 at 07:02 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS 7.0 - Chapter 6.9 building glibc jimmy_page_89 Linux From Scratch 5 11-27-2011 05:31 AM
LFS 6.5 error in building glibc-2.10.1 bucovaina78 Linux From Scratch 2 01-11-2011 09:02 AM
LFS 6.5 - Chap 5 - Why build GCC before Glibc kamleshk1 Linux From Scratch 2 06-01-2010 10:07 AM
[SOLVED] [LFS 6.6] Chap 5.7 - Glibc-2.11.1 configure WARNING igor012 Linux From Scratch 7 04-06-2010 03:06 PM
building lfs 6.1.1 ,compile glibc error godsad Linux From Scratch 3 03-19-2009 09:54 AM


All times are GMT -5. The time now is 01:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration