LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 03-15-2012, 04:28 AM   #16
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374

Hi again,

Each chapter assumes you unpacked the package and are standing in the newly created directory. As explained here: 5.3 - Last Important box.
 
Old 03-15-2012, 04:48 AM   #17
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
So, in chapter 5 it presumes you are in $LFS/mnt/lfs/sources?

If I understand you correctly.
 
Old 03-15-2012, 05:40 AM   #18
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

No, you need to be in $LFS/sources (which expands to /mnt/lfs/sources) to unpack the appropriate package.
 
Old 03-15-2012, 07:41 AM   #19
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Moved: This thread is more suitable in Linux From Scratch forum and has been moved accordingly to help your question get the exposure it deserves.
 
Old 03-15-2012, 10:54 AM   #20
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
Alright, I'm in mnt/lfs/sources
but, when I use this code:

../binutils-2.22/configure \
--target=$LFS_TGT --prefix=/tools \
--disable-nls --disable-werror

It says, there's no directory.

and when I cd to
../binutils-2.22/configure it says the same.
 
Old 03-15-2012, 11:26 AM   #21
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
Ok, found an tutorial for tarballs, so i've used this code: tar -vfx binutils ....
but now in my sources folder are all the files of binutils, like 50 files.

How can I undo/delete them all and what's the right way to do it.

Is there someone who can give support via MSN or something? It would be very nice.
 
Old 03-15-2012, 12:14 PM   #22
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Quote:
Originally Posted by Sjors-rw View Post
Alright, I'm in mnt/lfs/sources
but, when I use this code:

../binutils-2.22/configure \
--target=$LFS_TGT --prefix=/tools \
--disable-nls --disable-werror

It says, there's no directory.

and when I cd to
../binutils-2.22/configure it says the same.
See post #16

Quote:
Originally Posted by Sjors-rw View Post
Ok, found an tutorial for tarballs, so i've used this code: tar -vfx binutils ....
but now in my sources folder are all the files of binutils, like 50 files.

How can I undo/delete them all and what's the right way to do it.
See post #11.........

Last edited by druuna; 03-15-2012 at 12:16 PM.
 
Old 03-18-2012, 09:00 AM   #23
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
Now I've started again. In chapter 5 where do I have to be? with LFS user there's permission denied, en which directory do I have to stand? $LFS/sources?
 
Old 03-18-2012, 09:30 AM   #24
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Centos6.3/Debain
Posts: 1,742
Blog Entries: 1

Rep: Reputation: 244Reputation: 244Reputation: 244
Hi

You should be in /mnt/lfs/sources
Where you have the tarball then untar the tarball into sources dir then cd into the directory created from the untar.

Which package are you on

Last edited by spiky0011; 03-20-2012 at 03:03 PM.
 
Old 03-18-2012, 09:48 AM   #25
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,
Quote:
Originally Posted by Sjors-rw View Post
In chapter 5 where do I have to be? with LFS user there's permission denied, en which directory do I have to stand? $LFS/sources?
About the permission denied: What's denied? cd-ing into a directory? Untarring a file? Details please.
In general: Did you re-check all the commands? Especially those in 4.3, the chown commands for example. Are the packages in $LFS/sources (at least) readable for user lfs?


About the directory you need to be standing in: Really?

When you finished chapter 4 you are user lfs and standing in your home directory (/home/lfs).

In chapter 5.3 this pops up:
Quote:
Important

To re-emphasize the build process:

Place all the sources and patches in a directory that will be accessible from the chroot environment such as /mnt/lfs/sources/. Do not put sources in /mnt/lfs/tools/.

Change to the sources directory.

For each package:
- Using the tar program, extract the package to be built. In Chapter 5, ensure you are the lfs user when extracting the package.
- Change to the directory created when the package was extracted.
- Follow the book's instructions for building the package.
- Change back to the sources directory.
- Delete the extracted source directory and any <package>-build directories that were created in the build process unless instructed otherwise.
This would put you in $LFS/sources

In 5.4 you have to build Binutils. Untar, from where you are standing ($LFS/sources), the binutils package and cd into it (steps one and two from the For each package: part.

Hope this helps.

@spiky0011: That should be /mnt/lfs/sources!

Last edited by druuna; 03-18-2012 at 10:24 AM. Reason: Removed double text.
 
Old 03-18-2012, 11:02 AM   #26
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
alright, 5.4 succeeded. Now I'm in chapter 5.5 but it says:

tar -jxf ../mpfr-3.1.0.tar.bz2
mv -v mpfr-3.1.0 mpfr
tar -Jxf ../gmp-5.0.4.tar.xz
mv -v gmp-5.0.4 gmp
tar -zxf ../mpc-0.9.tar.gz
mv -v mpc-0.9 mpc

and:
tar -jxf ../mpfr-3.1.0.tar.bz2
refers to one directory "up" but I'm in /sources and the file itself is in sources too. Do I have to just remove the ".." or do I have to be in an other directory?
 
Old 03-18-2012, 11:09 AM   #27
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

I told you this three times already (Posts #16, #22 and #25).

Again:
Quote:
Change to the sources directory.

For each package:
- Using the tar program, extract the package to be built. In Chapter 5, ensure you are the lfs user when extracting the package.
- Change to the directory created when the package was extracted.
- Follow the book's instructions for building the package.
- Change back to the sources directory.
- Delete the extracted source directory and any <package>-build directories that were created in the build process unless instructed otherwise.
 
Old 03-20-2012, 02:38 PM   #28
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
Started again, me getting better with linux, I'm now stuck at 5.7 for glibc compilation. I get the warning: warning you should not compile gnu libc without versioning

And underneath that error: You need a recent version of Binutils, 2.8 or higher, but for LFS we use 2.22. So how to solve this problem?

Thanks again for helping,
 
Old 03-20-2012, 03:01 PM   #29
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Centos6.3/Debain
Posts: 1,742
Blog Entries: 1

Rep: Reputation: 244Reputation: 244Reputation: 244
Hi

Can you post the error you are getting plz
 
Old 03-20-2012, 03:03 PM   #30
Sjors-rw
Member
 
Registered: Mar 2012
Posts: 32

Original Poster
Rep: Reputation: Disabled
I've managed to continue, but now I don't know what to do. First off all from the beginning after install each pakage there are numerous errors, the whole time with [1] Error , that structure. I don't did anything with it and keep getting further, now a few pakages wont install, getting errors with config files etc.. What am I doing wrong? any ideas?
 
  


Reply

Tags
lfs, packages, patches


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to apply patches in lfs 7.0? Atharv Patil Linux From Scratch 5 01-23-2012 12:17 PM
*** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2. arubin Slackware 6 09-24-2008 04:31 AM
patches in LFS saritha Linux From Scratch 1 02-13-2008 04:39 AM
LFS-5.0:Chapter 6:autoconf-2.57 Dumper.pm missing jazernorth Linux From Scratch 12 11-12-2005 11:11 AM
URGENT glibc 2.3.3 - lfs -5.1 --> bug in autoconf geiser Linux From Scratch 1 08-18-2004 04:48 PM


All times are GMT -5. The time now is 05:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration