LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   LFS-7.2: mpfr-3.1.1, error: gmp.h can't be found, or is unusable. (http://www.linuxquestions.org/questions/linux-from-scratch-13/lfs-7-2-mpfr-3-1-1-error-gmp-h-cant-be-found-or-is-unusable-4175444957/)

McZ 01-10-2013 04:22 AM

LFS-7.2: mpfr-3.1.1, error: gmp.h can't be found, or is unusable.
 
I just tried to install my LFS-7.2 using scripts on my laptop. But I can't build mpfr-3.1.1 all I get is "error: gmp.h can't be found, or is unusable."

I don't understand why I get this error, I have built LFS-7.2 using the same scripts without problem in VirtualBox.

EDIT: Forgot to say that gmp.h is in /mnt/lfs/usr/include (that is /usr/include when in chroot) and a diff /usr/include/gmp.h /mnt/lfs/usr/include/gmp.h gives no difference. I'm running on my own LFS cd i built in VirtualBox using my LFS-7.2 I built in VirtualBox using the exact same scripts..

EDIT-2: I have now solved my problem, found a tiny bug in my adjusting-toolchain script so it was never adjusted.


All times are GMT -5. The time now is 01:18 AM.