LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 06-14-2012, 05:03 AM   #1
igor012
Member
 
Registered: Feb 2010
Posts: 87

Rep: Reputation: 2
LFS 7.1 - Kernel Panic


Hello,
After rebooting on LFS system I got :

Code:
Kernel Panic
No file system could mount root

VFS: Unable to mount rootfs on unknown block (8.18)
I am not using grub from the book but the one already packaged with my distribution (OpenSUSE 12.1)

My HD configuration is :

sda1 /boot
sda2 / ->Opensuse
sda3 swap
sdb1 /data
sdb2 / -> LFS

here is my grub menu.lst
Code:
# Modified by YaST2. Last modification on Fri Jun  8 18:14:38 CEST 2012
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 - 3.1.10-1.9
    root (hd0,0)
    kernel /vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-Maxtor_6Y160M0_Y47RLKNE-part2 resume=/dev/disk/by-id/ata-Maxtor_6Y160M0_Y47RLKNE-part3 splash=silent quiet nomodeset showopts vga=0x31a
    initrd /initrd-3.1.10-1.9-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1 - 3.1.10-1.9
    root (hd0,0)
    kernel /vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-Maxtor_6Y160M0_Y47RLKNE-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31a
    initrd /initrd-3.1.10-1.9-desktop

title LFS 7.1
    root (hd0,0)
    kernel /boot/vmlinuz-3.2.6-lfs-7.1 root=/dev/sdb2 rootdelay=10 ro
Any idea?

Thanks

Fab
 
Old 06-14-2012, 08:11 AM   #2
stoat
Member
 
Registered: May 2007
Distribution: LFS
Posts: 493

Rep: Reputation: 133Reputation: 133
If you have your LFS kernel in that boot partition, then try removing /boot from the path in the kernel menu command. If the LFS kernel is not there, then the root menu command is wrong.

Last edited by stoat; 06-14-2012 at 08:28 AM.
 
Old 06-14-2012, 10:54 AM   #3
igor012
Member
 
Registered: Feb 2010
Posts: 87

Original Poster
Rep: Reputation: 2
The kernel is located in the /boot partition
I modified menu.lst :
Code:
title LFS 7.1
    root (hd0,0)
    kernel /vmlinuz-3.2.6-lfs-7.1 root=/dev/sdb2 rootdelay=10 ro

There is no changes. It's still displaying the same errors.

I was thinking it may come from the ext4 support in the kernel. I am recompiling it with ext4 support.

Last edited by igor012; 06-14-2012 at 11:17 AM.
 
Old 06-14-2012, 11:17 AM   #4
stoat
Member
 
Registered: May 2007
Distribution: LFS
Posts: 493

Rep: Reputation: 133Reputation: 133
Get rid of that rootdelay thing and try again.

Next, make sure that you built into the kernel the appropriate filesystem drivers. Without an initrd file, that kind of stuff has to be built in to be available.

Last edited by stoat; 06-14-2012 at 03:26 PM.
 
Old 06-14-2012, 11:54 AM   #5
igor012
Member
 
Registered: Feb 2010
Posts: 87

Original Poster
Rep: Reputation: 2
It was built as a module.

I will recompile it as a part of the kernel.

Code:
cat boot/old/config-3.2.6 | grep EXT4
CONFIG_EXT4_FS=m
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXT4_FS_XATTR=y
CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_EXT4_FS_SECURITY=y
CONFIG_EXT4_DEBUG=y
Thanks

Last edited by igor012; 06-14-2012 at 12:05 PM.
 
Old 06-14-2012, 06:18 PM   #6
CincinnatiKid
Member
 
Registered: Jul 2010
Distribution: Mageia-3
Posts: 399

Rep: Reputation: 33
Did you configure this option in your Kernel?

Code:
Device Drivers  --->
  Generic Driver Options  --->
     Maintain a devtmpfs filesystem to mount at /dev
 
Old 06-15-2012, 06:25 AM   #7
igor012
Member
 
Registered: Feb 2010
Posts: 87

Original Poster
Rep: Reputation: 2
Perfect !!! It's working

Thank you
 
Old 06-15-2012, 09:30 AM   #8
CincinnatiKid
Member
 
Registered: Jul 2010
Distribution: Mageia-3
Posts: 399

Rep: Reputation: 33
Which suggestion fixed your issue?
 
Old 06-16-2012, 04:09 AM   #9
igor012
Member
 
Registered: Feb 2010
Posts: 87

Original Poster
Rep: Reputation: 2
Thumbs up

Some features were missing in the kernel.
The ext4 support was built as a module and the devtmpfs options were not built at all.

Thanks a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't boot LFS ( kernel panic - not syncing ) LFS 6.6 Lyle Linux From Scratch 14 05-15-2010 04:22 AM
LFS will not boot: kernel panic Bliepo Linux From Scratch 2 06-16-2009 04:30 PM
Kernel panic on first boot -- LFS 6.2 on i686 PC. creativename Linux From Scratch 3 06-16-2007 04:32 AM
Kernel Panic lfs LFS gbiyer Linux From Scratch 8 05-07-2006 04:48 AM
kernel panic LFS 6.0 vmlinuz101 Linux From Scratch 1 04-15-2005 10:17 AM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration