LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   LFS 7.1 - Kernel Panic (http://www.linuxquestions.org/questions/linux-from-scratch-13/lfs-7-1-kernel-panic-4175411383/)

igor012 06-14-2012 04:03 AM

LFS 7.1 - Kernel Panic
 
Hello,
After rebooting on LFS system I got :

Code:

Kernel Panic
No file system could mount root

VFS: Unable to mount rootfs on unknown block (8.18)

I am not using grub from the book but the one already packaged with my distribution (OpenSUSE 12.1)

My HD configuration is :

sda1 /boot
sda2 / ->Opensuse
sda3 swap
sdb1 /data
sdb2 / -> LFS

here is my grub menu.lst
Code:

# Modified by YaST2. Last modification on Fri Jun  8 18:14:38 CEST 2012
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 - 3.1.10-1.9
    root (hd0,0)
    kernel /vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-Maxtor_6Y160M0_Y47RLKNE-part2 resume=/dev/disk/by-id/ata-Maxtor_6Y160M0_Y47RLKNE-part3 splash=silent quiet nomodeset showopts vga=0x31a
    initrd /initrd-3.1.10-1.9-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1 - 3.1.10-1.9
    root (hd0,0)
    kernel /vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-Maxtor_6Y160M0_Y47RLKNE-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31a
    initrd /initrd-3.1.10-1.9-desktop

title LFS 7.1
    root (hd0,0)
    kernel /boot/vmlinuz-3.2.6-lfs-7.1 root=/dev/sdb2 rootdelay=10 ro

Any idea?

Thanks

Fab

stoat 06-14-2012 07:11 AM

If you have your LFS kernel in that boot partition, then try removing /boot from the path in the kernel menu command. If the LFS kernel is not there, then the root menu command is wrong.

igor012 06-14-2012 09:54 AM

The kernel is located in the /boot partition
I modified menu.lst :
Code:

title LFS 7.1
    root (hd0,0)
    kernel /vmlinuz-3.2.6-lfs-7.1 root=/dev/sdb2 rootdelay=10 ro


There is no changes. It's still displaying the same errors.

I was thinking it may come from the ext4 support in the kernel. I am recompiling it with ext4 support.

stoat 06-14-2012 10:17 AM

Get rid of that rootdelay thing and try again.

Next, make sure that you built into the kernel the appropriate filesystem drivers. Without an initrd file, that kind of stuff has to be built in to be available.

igor012 06-14-2012 10:54 AM

It was built as a module.

I will recompile it as a part of the kernel.

Code:

cat boot/old/config-3.2.6 | grep EXT4
CONFIG_EXT4_FS=m
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXT4_FS_XATTR=y
CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_EXT4_FS_SECURITY=y
CONFIG_EXT4_DEBUG=y

Thanks

CincinnatiKid 06-14-2012 05:18 PM

Did you configure this option in your Kernel?

Code:

Device Drivers  --->
  Generic Driver Options  --->
    Maintain a devtmpfs filesystem to mount at /dev


igor012 06-15-2012 05:25 AM

Perfect !!! It's working

Thank you

CincinnatiKid 06-15-2012 08:30 AM

Which suggestion fixed your issue?

igor012 06-16-2012 03:09 AM

Some features were missing in the kernel.
The ext4 support was built as a module and the devtmpfs options were not built at all.

Thanks a lot


All times are GMT -5. The time now is 11:42 AM.