LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 01-29-2011, 07:56 PM   #1
tomw2005
LQ Newbie
 
Registered: Jan 2011
Posts: 2

Rep: Reputation: 0
LFS 6.7 - Chapter 6.59 - Udev-161 tests completely fail (can't exec tree)


When running the Udev-161 test suite (make check) I receive 140 errors all of which state "Can't exec "tree": No such file or directory at ./test/udev-test.pl line 1685"

So far all other installs appear to have gone ok so I'm wondering why I've become stuck at this point.

Tom W
 
Old 01-30-2011, 01:05 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Hi,

Haven't seen this one before....

Did you by any change forget to unpack the udev-161-testfiles package (in the correct place)?

Not much to go on, but maybe it helps.
 
Old 01-30-2011, 05:46 AM   #3
tomw2005
LQ Newbie
 
Registered: Jan 2011
Posts: 2

Original Poster
Rep: Reputation: 0
Hi,

Thanks for your reply. I had another look this morning and I forgot to use the --strip-components=1 line when unpacking the test suite. Problem solved.

Tom W
 
Old 01-30-2011, 11:38 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Glad to see you got it solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SASL Auth Tests Fail on Mail Server carlosinfl Linux - Server 3 11-24-2009 01:04 PM
LFS 6.3, messed up somewhere prior to chapter 6.12 (gcc), how to restart chapter 6? Funkster Linux From Scratch 2 12-24-2008 06:30 AM
LFS Book Chapter 6 - 1st step (chroot to /mnt/lfs) doens't work bauld Linux From Scratch 11 03-15-2006 12:31 AM
-exec {} won't do copy completely??? Help taiwf Linux - General 2 10-05-2005 12:23 AM
ERROR IN??: lfs 6.0 chapter 5.35. Udev-030 jobesd Linux From Scratch 4 01-31-2005 05:05 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration