LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   LFS 6.5 Glibc 2.10.1 --> error when running make (http://www.linuxquestions.org/questions/linux-from-scratch-13/lfs-6-5-glibc-2-10-1-error-when-running-make-782741/)

Soulman 01-17-2010 04:40 AM

LFS 6.5 Glibc 2.10.1 --> error when running make
 
Hi everyone !

i'm rather new to linux and i'm trying to learn by using the LFS guide,

i've browsed/searched this forum to see if someone else has got the same error as me , and so far i haven't seen any thread with this error:

here is the string i believe "shows" the fault:
Quote:

mawk: scripts/gen-sorted.awk: line 19: regular expression compile failed (bad class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /, "", subd ...

make[1]: *** No rule to make target `/mnt/lfs/sources/glibc-build/Versions.all', needed by `/mnt/lfs/sources/glibc-build/abi-versions.h'. Stop.
make[1]: Leaving directory `/mnt/lfs/sources/glibc-2.10.1'
make: *** [all] Error 2
hope you guys can help/point me in the right direction so i can get past this :)

druuna 01-17-2010 04:54 AM

Hi,

mawk is not supported when building LFS, which you should have known if you read this chapter in the LFS book: iv. Host System Requirements.

Do read the whole book and do not deviate from what is in it (as long as you are not familiar with the material).

Hope this helps.


All times are GMT -5. The time now is 12:23 PM.