LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 11-03-2011, 11:31 AM   #1
liajeava
LQ Newbie
 
Registered: Oct 2011
Posts: 13

Rep: Reputation: Disabled
Question Keyboard messup - LFS 7.0 rc2


I have followed LFS 7.0rc2 and am able boot into the OS.
But, at the bash prompt, the keyboard keys are mixed up.
The alphabets & number are printed properly.
But, the symbols are messed up.
Like if i press '\' i get '-', '[' gives 'u with two dots above', ']' gives '+'
some symbols are working like '.' ','

Please, help to fix this.
Thanks!
 
Old 11-03-2011, 11:45 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

This sounds like a wrong keyboard layout setting.

What type of keyboard do you have? Default US, or German or ?????

Re-visit chapters 7.10. Configuring the Linux Console and 7.13. The Bash Shell Startup Files.

I would advise to remove the /etc/sysconfig/console script and the export LANG=<ll>_<CC>.<charmap><@modifiers> entry from your /etc/profile. Reboot and check if the keyboard layout is ok. It should be if you have a "normal" keyboard.

If this works, don't bother with the console script. You might want to add an appropriate export LANG=.... in /etc/profile (might also not be needed, but that depends on your wishes/needs).

Hope this helps.
 
1 members found this post helpful.
Old 11-03-2011, 12:20 PM   #3
liajeava
LQ Newbie
 
Registered: Oct 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
The problem was with /etc/sysconfig/console.

I had created it with this addition
Code:
The following example illustrates keymap autoconversion from ISO-8859-15 to UTF-8 and enabling dead keys in Unicode mode:

cat > /etc/sysconfig/console << "EOF"
# Begin /etc/sysconfig/console

UNICODE="1"
KEYMAP="de-latin1"
KEYMAP_CORRECTIONS="euro2"
LEGACY_CHARSET="iso-8859-15"
FONT="LatArCyrHeb-16 -m 8859-15"

# End /etc/sysconfig/console
EOF
As it was mentioned somewhere there might be issues with UTF8, i thought the above will be helpful. Looks like it set default keyboard to de-latin1 format.
I have commented all that, and its working fine now. (/etc/profile is as it was)

Thank-you!
 
Old 11-03-2011, 03:02 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

This KEYMAP="de-latin1" points to a German (de) keyboard. Which you probably do not have (I do recall you mentioning a en_US entry in /etc/profile).

BTW: You're welcome
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS 6.8 first boot keyboard map is not ok bucovaina78 Linux From Scratch 1 08-05-2011 08:01 AM
MPFR-2.4.1 Check Failures in LFS 6.5 RC2 GuyWhoKilledBear Linux From Scratch 1 08-12-2009 07:53 PM
Keyboard (any) doesn work on LFS 6.1.1 nistur Linux From Scratch 5 04-12-2006 06:02 AM
Serious messup MylesCLin Linux - Newbie 3 12-17-2004 01:44 PM
LFS-3.2-rc2 released lfslinux Linux From Scratch 0 02-27-2002 11:06 AM


All times are GMT -5. The time now is 01:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration