LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Interface eth0 doesn't exist (http://www.linuxquestions.org/questions/linux-from-scratch-13/interface-eth0-doesnt-exist-399662/)

garbo73 01-04-2006 10:05 PM

Interface eth0 doesn't exist
 
I built LFS 6.1.1 using Slackware 10.0 and it's experimental 2.6 kernel. According to Slackware I am running a ADMteck Comet rev 17 network card. However when I boot into LFS while the system is adding mods then when it gets to the network card setup I get the following error:

Interface eth0 doesn't exist [WARN]

I am not sure which files you need me to post so that you can look at them, but I would appreciate any help, I installed Lynx so that I could continue building my system with BLFS, unfortunately because it can't find my network card I can't get anywhere.

aus9 01-05-2006 05:36 AM

according to the web the driver is now apart of the tulip range found here
http://www.scyld.com/tulip.html

Yerp 01-05-2006 02:42 PM

Okay, lets start here, run the following command and copy the contents:
Code:

lspci
you can actually force that to a file by running the following command:
Code:

lspci | tee lspci.txt
This will let us know if your hardware is being recongized.
Also, how is your kernel compiled, I might recommend going into the network options and building every single network card as modular. This way you can change the network card at any time and your udev/hotplug system should auto-detect the correct hardware.

the network devices can be found in the following location in the kernel config:
Device Drivers --> Network Device Support --> Ethernet (10 or 100MBit)
In there you can build all the cards and make sure they have <M>.
You might also look into the 1000MBit and the 10,000MBit cards.
Also modularize the Wireless LAN (non-hamradio), the space used for this is normally negligable and usually worth any costs (very portable).

Also, the Tulip drivers are slighty out of place, or not as obvious as others for some reason, look into:
Device Drivers --> Network Device Support --> Ethernet (10 or 100MBIT) --> Tulip family network device support

garbo73 01-06-2006 09:07 AM

Last night I reconfigured and compiled my kernel to use tulip before I got your response Yerp. Once I did the system gave me an ok for eth0. Unfortunately now, Lynx won't connect to remote server. I tried to run the:

lspci | tee lspci.txt

command, but the system gave me and error that it didn't recognize the command.

breekbot 02-01-2006 11:57 PM

pciutils
 
He garbo73,

Try installing pciutils that contains lspci and some other useful stuff!

It can be downloaded from:

ftp.kernel.org/pub/software/utils/pciutils/

Good luck ,breekbot :)

mr_demilord 02-02-2006 07:45 AM

add
Code:

alias eth0 driver_module
to
Code:

/etc/modprobe.conf


All times are GMT -5. The time now is 02:24 AM.