LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 12-15-2009, 02:05 PM   #1
NtP
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
Interface eth0 doesn't exist


Hello together,

I copied my fresh LFS 6.5 from the desktop-pc where it was created to my laptop (IBM Thinkpad T30), but when I'm booting it, it says: "Warning: Interface eth0 doesn't exist".
First I thought I had to recompile my kernel (2.6.30.2) 'cause the network-driver isn't included, but I read e100 is included by default. So, where's the failure?
I know this problem isn't very unique, but I'm searching for an answer for a week now and it's still not solved.
Thanks to everyone who's gonna help me,

NtP
 
Old 12-15-2009, 03:11 PM   #2
ProtoformX
Member
 
Registered: Feb 2004
Location: Canada
Distribution: LFS SVN
Posts: 334

Rep: Reputation: 33
Quote:
Originally Posted by NtP View Post
Hello together,

I copied my fresh LFS 6.5 from the desktop-pc where it was created to my laptop (IBM Thinkpad T30), but when I'm booting it, it says: "Warning: Interface eth0 doesn't exist".
First I thought I had to recompile my kernel (2.6.30.2) 'cause the network-driver isn't included, but I read e100 is included by default. So, where's the failure?
I know this problem isn't very unique, but I'm searching for an answer for a week now and it's still not solved.
Thanks to everyone who's gonna help me,

NtP
Anytime you move a linux system to another machine with different hardware, you have to recompile the kernel, are you sure your notebook has an e100? look at lspci -vv and if its an intel e100 then try deselecting the module and reselecting it as a module, at boot up modprobe the module and then (I use ifconfig) to bring up the wireless/wired network interface
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
network interface eth0 does not exist jrodia Gentoo 7 10-14-2009 01:08 AM
ERROR: The interface does not exist (UBUNTU) interface eth0 not configured anshulbhatt Linux - Networking 2 11-20-2008 12:23 PM
Interface eth0 doesn't exist [WARN] saurabh.jain162 Linux - Software 2 11-05-2008 10:22 AM
Interface eth0 doesn't exist garbo73 Linux From Scratch 5 02-02-2006 07:45 AM
Reboot LFS6.1:Interface eth0 doesn't exist! ukyo Linux From Scratch 4 09-07-2005 06:04 AM


All times are GMT -5. The time now is 10:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration