LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 10-16-2005, 07:32 PM   #1
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Rep: Reputation: 15
Installation of Linux-Libc-Headers problems


when i put in the comand
cp -R include/asm-i386 /tools/include/asm
i get
cp: cannot stat `include/asm-i386': No such file or directory
so what do i need to do to fix that?
 
Old 10-16-2005, 11:42 PM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Are you sure you're in the right directory? This works for me (assuming your tarball is located in ${TARBALLS}):
Code:
$ tar xvjf ${TARBALLS}/linux-libc-headers-2.6.11.2.tar.bz2
<lots of output omitted>
$ cd linux-libc-headers-2.6.11.2
$ cp -R include/asm-i386 /tools/include/asm
 
Old 10-17-2005, 10:41 PM   #3
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Original Poster
Rep: Reputation: 15
never mind i found out what the problem was when i read what you posted and after a some time away from working on this. i was untaring and unzipping the wrong file.
sorry but thanks for the help
 
Old 10-18-2005, 10:34 PM   #4
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Original Poster
Rep: Reputation: 15
where should TCLPATH point?

because i keep geting the message

checking for Tcl private headers... checking for tclInt.h... no
configure: error: Can't find Tcl private headers

when i put in

./configure --prefix=/tools --with-tcl=/tools/lib \ --with-tclinclude=$TCLPATH --with-x=no
 
Old 10-18-2005, 11:38 PM   #5
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Which section/package are you working on?
 
Old 10-19-2005, 12:30 AM   #6
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Ok... I'm assuming you're working on Expect-5.43.0 (section 5.9).

$TCLPATH is supposed to be replaced with the path to the tcl source extracted earlier. So, you can either set an environment variable and use the command as written, or just replace $TCLPATH manually.

The configure script is looking to locate the file named tclInt.h. It looks for it in the directory specified by $TCLPATH and it also looks at $TCLPATH/generic

It needs to find that header file in one of those locations, or it will bomb out. So check your untar'ed TCL source directory for that file, and give the appropriate path to let the configure script find that file.

Last edited by Dark_Helmet; 10-19-2005 at 12:35 AM.
 
Old 10-20-2005, 10:11 PM   #7
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Original Poster
Rep: Reputation: 15
OK i a'm now on the second pass of gcc. i am being told to make a new directory called gcc-build but i still have the first one. do i delete the first one? do i make it in a different directory ?

i want to thank you for all the help Dark_Helmet
 
Old 10-21-2005, 12:31 AM   #8
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
You can safely assume that a directory can be deleted when the instructions tell you to reuse that directory.

If you don't feel comfortable deleting the directory without the book explicitly telling you to, the scan back over the sections. There is likely to be a footnote or a short sentence that tells you the gcc-build directory is no longer needed. If you can't find it and are still hesitant to delete the directory, you have two options:

1. Create a different directory. Instead of gcc-build, name it gcc-build2, gcc-build-second-pass, or whatever you like. Just adjust the command in the book appropriately (which amounts to little more than the mkdir and cd command)

2. Rename the old directory. Just do a "mv gcc-build gcc-build-first-pass" or something similar. Then you can use the book's commands exactly as written.

And you are more than welcome for the help
 
Old 10-23-2005, 05:08 PM   #9
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Original Poster
Rep: Reputation: 15
just to be sure in section 6.9.1. Installation of Linux-Libc-Headers i need to copy and install Linux-Libc-Headers-2.6.11.2 in the /usr/include/asm directory before i cp -R include/asm-i386 /usr/include/asm corect?
 
Old 10-23-2005, 05:47 PM   #10
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
I'm not entirely sure if I understand your question.

At that point in the book, you've chrooted into a new, empty environment. The first command the book gives in that section is:
Code:
cp -R include/asm-i386 /usr/include/asm
That's saying to copy the include/asm-i386 directory to /usr/include, but rename it to "asm". In other words, there should not be any "asm" directory inside /usr/include at this point. The command above creates that directory.
 
Old 10-23-2005, 08:44 PM   #11
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Original Poster
Rep: Reputation: 15
when i intered the cp -R include/asm-i386 /usr/include/asm command i got
cp: cannot stat `include/asm-i386': No such file or directory. so i am wondering what to do about that. and that is my question
 
Old 10-23-2005, 10:40 PM   #12
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Well, this command sequence works for me:
Code:
$ tar xvjf ${SRC_DIR}/linux-libc-headers-2.6.11.2.tar.bz2
<lots of output omitted>
$ cd linux-libc-headers-2.6.11.2/ 
$ cp -R include/asm-i386 /usr/include/asm
Have you double-checked you're in the right directory? The right tarball extracted?
 
Old 10-29-2005, 11:09 AM   #13
Damon Spector
Member
 
Registered: Nov 2004
Distribution: Fedora Core 4
Posts: 61

Original Poster
Rep: Reputation: 15
ok i copyed my tools/libc-headers-build/linux-libc-headers-2.6.11.2/include/asm-i386/ to /usr/include/asm and want to know if that will work? and befor i get to far into building my perminat system i would like to know if there any "offical placses" i should be instaling to? i don't know the linux file system as well as i should. just enough to get where i want to go. and i would like to apolige for taking so long getting back to you this week has just been busy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
about linux-libc-headers-2.6.12... ParticleHunter Linux From Scratch 3 09-05-2005 10:23 AM
cp linux-libc-headers to ??? joirnange Linux - Newbie 11 01-16-2005 04:11 AM
linux-libc-headers-2.6.8.1 trouble obsidianblackha Linux From Scratch 1 12-03-2004 07:30 PM
libc.so.6(GLIBC_2.3), libc.so.6(GLIBC_2.3.2) needed for Linux 7.3.1 vivek_thampy Linux - Software 1 08-09-2004 05:12 PM
GNU libc installation to setup cross compiler env - kernel header file TOO OLD !! tanch00 Linux - Software 1 02-06-2002 03:33 AM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration