LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Install MPD on a (B)LFS system: GLib problem (http://www.linuxquestions.org/questions/linux-from-scratch-13/install-mpd-on-a-b-lfs-system-glib-problem-887605/)

lich000king 06-21-2011 04:01 PM

Install MPD on a (B)LFS system: GLib problem
 
Hi

When trying to configure the git version of MPD, I get:

Code:

checking for GLIB... no
configure: error: GLib 2.12 is required

I have installed GLib-1.2.10 and GLib-2.24.2 from BLFS (svn).
Pkg-config-0.25 was already installed in LFS (v 6.8).

Googling reveals this problem can often be solved by installing the (debian) package libglib2.0-dev. But this should be included in the above glib packages?

What should I try?

Cheers
Oliver

knudfl 06-21-2011 04:23 PM

grep -in "checking for GLIB" mpd/*

Example :
Code:

mpd/config.log:688:configure:6615: checking for GLIB
mpd/configure:6615:{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GLIB" >&5
mpd/configure:6616:$as_echo_n "checking for GLIB... " >&6; }

.. Meaning that you can look into the 'configure' script about line 6615 and read
that mpd uses PKG_CONFIG. Checks for for : /usr/lib/pkgconfig/glib-2.0.pc


Also says: "pkg_cv_GLIB_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.12"
I.e. : glib 2.12 or later : GLIB 2.24 is OK.

..

lich000king 06-22-2011 01:42 AM

Well, I reinstalled GLib 2.24. That solved it. I don't understand what went wrong, but MPD is running now.

Thank you very much for your help.


All times are GMT -5. The time now is 09:45 AM.