Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 11-30-2006, 07:20 PM   #1
Vitalie Ciubotaru
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Rep: Reputation: 30
Help configure a winmodem

Well, I don't like to open new threads when there are lots of "similar" threads around, but ...
I have an internal Conexant modem [winmodem]. I installed a driver for it in both my FC3 and my LFS. I am able to dial-up from my FC3 [no questions - it's just perfect], which means the modem is ok and its driver is ok.
Now step by step:
I know I have a module device in /dev - it's ttyHSFS0.
I know kernel modules for my modem get loaded.
I know I have all necessary software compiled and installed - since I could install "wvdial", it has all dependencies.
I can make wvdial dial my ISP, but after username and password check it says "authentification failed".
Wvdial info/man files say after it dials the ISP, it hands it to "pppd".
"pppstats" returns "no ppp devices found".
I think I could solve this by "imitating" my FC3, but
I don't know how FC3 dials up.
I'd be very greatful if there is someone to tell me what to do [or even better - where/what to search].

Old 12-01-2006, 10:35 AM   #2
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
well since you don't say what model modem try
Old 12-02-2006, 07:46 AM   #3
Vitalie Ciubotaru
Registered: Dec 2005
Location: Osaka, Japan
Distribution: Ubuntu Trinity
Posts: 153

Original Poster
Rep: Reputation: 30
I do know what modem I am using:
I have an internal Conexant modem [winmodem]
Actually, its a "Conexant HSF Churchill Data/Fax" modem (PCI card). The driver I am using is "hsfmodem-".
Old 12-02-2006, 08:53 AM   #4
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
Since you said you got the "authentification failed" message, that makes me wonder ¿which protocol are you using to connect? and ¿is that protocol (chap / pap / plain text password) you have selected, _supported_ by your ISP? If you show your config and connection logs you can get a better answer. Anyway, sometimes you have to comment out some line in /etc/ppp/options, to look like "#lock", or change "auth" by "noauth" in some other cases.
Old 12-03-2006, 10:27 AM   #5
Registered: Jul 2003
Location: NY
Distribution: None (src & compile)
Posts: 261

Rep: Reputation: 36
I have a Conexant, but I don't use it. I'm currently using my 536ep. I never could get wvdial to do its thing either. Maybe it was just me. Try pppd/chat combo. It's not hard, and there's even a setup script for the whole thing:

and download pppsetup. If nothing else that will give you handy ppp-on, ppp-off script to link up the interface with. I like it because it only uses pppd and chat. You might want to symlink your modem device to /dev/modem if you didn't do that already, most things look there.

The setup scripts just fill out your /etc/ppp/options file for pppd, and make a chat script in /etc/ppp/. Looks like this running:

/usr/sbin/pppd -detach connect /usr/sbin/chat -v -f /etc/ppp/pppscript

When you want the link, you just do "ppp-on". "ppp-off" downs it again.

>ip addr show

20: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,10000> mtu 1500 qdisc pfifo_fast qlen 3 link/ppp inet peer scope global ppp0
On that same server there's a bunch of other ppp programs too. Probably what is happening is your ISP is using a method of auth you're not prepared for or using. Could be chap, pap, mschap, etc. Mine was pap.

# General configuration options for PPPD:
# speed 9600 +19200 38400 *57600 (nope -> )76800 (not supported? ->) 96000
# Uncomment the line below for more verbose error reporting:
# This may NOT work 9-15 is valid
#deflate 10
# If you have a default route already, pppd may require the other side
# to authenticate itself, which most ISPs will not do.  To work around this,
# uncomment the line below.  Note that this may have negative side effects
# on system security if you allow PPP dialins.  See the docs in /usr/doc/ppp*
# for more information.
asyncmap 0
name "my-login-name"


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure fails with: libz... configure: error: not found. erpe Linux - Software 17 10-11-2006 05:56 PM
[root@Linuxboy magicolor2430DL-1.1.0]# ./configure ./configure: No such file or ... anseK Mandriva 7 01-02-2006 04:21 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM
how do i configure my winmodem steve981 Linux - Newbie 1 05-27-2004 03:37 PM
Winmodem Ric_doamaro Linux - Newbie 2 01-23-2002 02:06 PM

All times are GMT -5. The time now is 04:56 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration