LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 11-02-2002, 03:45 PM   #1
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Rep: Reputation: 30
glibc configure prob : file too large ???


I had too many problems happening with my LFS; so, I decided to start over. I am in Chapter Six and installing glibc-2.2.5. I have unpacked the patch, the file, and then unpacked the linuxthreads file in the glibc-2.2.5 directory. Cut and paste the command from the book to my xterm, and I get the following:

<snip>
checking size of long double... 0
running configure fragment for ,,.glibc-2.2.5/linuxthreads/sysdeps/unix/sysv/linux
../glibc-2.2.5/configure: .: ../glibc-2.2.5/linuxthreads/sysdeps/unix/sysv/linux/configure: file is too large

continues on with the following as being "too large":

../glibc-2.2.5/sysdeps/unix/sysv/linux/configure
../glibc-2.2.5/sysdeps/unix/common/configure
../glibc-2.2.5/sysdeps/unix/configure
../glibc-2.2.5/sysdeps/generic/configure

Is this error OK to continue with? It doesn't stop the configuration, but I get down to "creating ./config.status" and it seems like it hangs. The first time I tried this (today), I let it run for about one hour and it was still creating ./config.status. How long should I let it run with a PII-350 ??

TIA
 
Old 11-02-2002, 04:07 PM   #2
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Rep: Reputation: 30
try doing this on your $LFS partition:

df -h $LFS

maybe you don't have enough room?

also, there is another thread around here where somebody had file size restrictions running on their base system.

EDIT:

hehe... I just looked at the thread for the commands, and it was YOU! I guess you know what to do w/ that subject :-)

I don't know.... The only problem's I've had was with the linux threads, and it just gave me a warning after ./configure. try that df command and see if anything is funny

Last edited by adam_boz; 11-02-2002 at 04:10 PM.
 
Old 11-02-2002, 05:06 PM   #3
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
Adam,

Thanks for the reply. You're right. I was the one with the file size restrictions. But, I disabled that program (Bastille). I did the df command and on my LFS partition (which is 5Gb) I have only used 15% of it. Any other thoughts, anyone?

TIA
 
Old 11-08-2002, 08:24 PM   #4
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
I'm still having this problem. Partition is NOT full. File sizes are as follows (in bytes) in red:

/glibc-2.2.5/linuxthreads/sysdeps/unix/sysv/linux/configure 94
/glibc-2.2.5/sysdeps/unix/sysv/linux/configure 8155
/glibc-2.2.5/sysdeps/unix/common/configure 2940
/glibc-2.2.5/sysdeps/unix/configure 1718
/glibc-2.2.5/sysdeps/generic/configure 1667

This is exactly what I get when I type in command for glibc-2.2.5:

<snip>
checking for assembler .weak directive... yes
checking for ld --no-whole-archive... yes
checking for gcc -fexceptions... yes
checking for DWARF2 unwind info support... static
checking for __builtin_expect... yes
checking for local label subtraction... yes
checking for libgd... no
checking size of long double... 0
running configure fragment for ../glibc-2.2.5/linuxthreads/sysdeps/unix/sysv/linux
../glibc-2.2.5/configure: .: ../glibc-2.2.5/linuxthreads/sysdeps/unix/sysv/linux/configure: file is too large
running configure fragment for ../glibc-2.2.5/sysdeps/unix/sysv/linux
../glibc-2.2.5/configure: .: ../glibc-2.2.5/sysdeps/unix/sysv/linux/configure: file is too large
running configure fragment for ../glibc-2.2.5/sysdeps/unix/common
../glibc-2.2.5/configure: .: ../glibc-2.2.5/sysdeps/unix/common/configure: file is too large
running configure fragment for ../glibc-2.2.5/sysdeps/unix
../glibc-2.2.5/configure: .: ../glibc-2.2.5/sysdeps/unix/configure: file is too large
running configure fragment for ../glibc-2.2.5/sysdeps/generic
../glibc-2.2.5/configure: .: ../glibc-2.2.5/sysdeps/generic/configure: file is too large
checking stdio selection... stdio
checking for old glibc 2.0.x headers... no
checking whether -fPIC is default... no
updating cache ./config.cache
creating ./config.status


And then it hangs right there. Can anybody tell me what I'm doing wrong?

TIA
 
Old 12-10-2002, 04:05 PM   #5
esherrouse
LQ Newbie
 
Registered: Dec 2002
Posts: 9

Rep: Reputation: 0
I am in about the same place as you are, Peeples, but I am having another issue. I am attempting to run the installation as instructed in Chapter 6 for Glibc, however I seem to start getting this error:
checking for assembler global-symbol directive... UNKNOWN
configure: error: cannot determine asm global directive
right after running this:
../glibc-2.2.5/configure --prefix=/usr --disable-profile \
--enable-add-ons --libexecdir=/usr/bin &&

I ran each line of the one listed on the LFS site in an attempt to narrow down the problem. Everything seems to work until that point and then it starts coughing, so to speak.
Has anyone seen this? Is it an error that is overlookable?


Thanks,

esh
 
Old 12-10-2002, 05:10 PM   #6
esherrouse
LQ Newbie
 
Registered: Dec 2002
Posts: 9

Rep: Reputation: 0
I got passed that last post, but now I am having issues with GCC installing...
I am not sure that it is not correctly installed however, because the error says this :
Configuring for a i686-pc-linux-gnulibc1 host.
*** This configuration is not supported in the following subdirectories:
target-libf2c target-libffi target-boehm-gc target-zlib target-libjava zlib fastjar target-libobjc
(Any other directories should still work fine.)
Created "Makefile" in /static/src/lfs-packages-4.0/gcc-build using "mh-frag" and "mt-frag"
/static/lib/gcc-lib/i686-pc-linux-gnu/3.2/../../../../i686-pc-linux-gnu/bin/ld: cannot open crt1.o: No such file or directory
collect2: ld returned 1 exit status
*** The command 'gcc -o conftest -g -O2 conftest.c' failed.
*** You must set the environment variable CC to a working compiler.


I am not sure if I need to keep going or figure out what is wrong here. Any thoughts?

esh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't ./configure glibc-2.3.2 michelbehr Linux - Newbie 12 01-28-2005 08:23 AM
prob a stupid question on glibc Notyou Linux - Newbie 3 08-17-2004 04:52 PM
glibc error with ./configure speel Linux - Distributions 1 08-07-2004 08:57 PM
Prob multibooting large floppy images...heh... minion01 Linux - Software 0 06-30-2004 12:53 PM
Large tar file taking huge disk space in ext3 file system pcwulf Linux - General 2 10-20-2003 08:45 AM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration