LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Glibc 2.16 pass 1 (http://www.linuxquestions.org/questions/linux-from-scratch-13/glibc-2-16-pass-1-a-4175422123/)

Refractor 08-14-2012 11:07 PM

Glibc 2.16 pass 1
 
Greetings!
I have the following problem when trying to compile glibc pass 1 with the temporary tools:
Code:

make[2]: Entering directory `/home/axtroz/source/Smartix/builds/glibc-2.16.0/iconv'
x86_64-smartix-linux-gcc -nostdlib -nostartfiles -o /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconvconfig  -Wl,-dynamic-linker=/home/axtroz/source/Smartix/sysroot/usr/lib/ld-linux-x86-64.so.2  -Wl,-z,combreloc -Wl,-z,relro -Wl,--hash-style=both /home/axtroz/source/Smartix/builds/glibc-build/csu/crt1.o /home/axtroz/source/Smartix/builds/glibc-build/csu/crti.o `x86_64-smartix-linux-gcc  --print-file-name=crtbegin.o` /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconvconfig.o /home/axtroz/source/Smartix/builds/glibc-build/iconv/strtab.o /home/axtroz/source/Smartix/builds/glibc-build/iconv/xmalloc.o /home/axtroz/source/Smartix/builds/glibc-build/iconv/hash-string.o  -Wl,-rpath-link=/home/axtroz/source/Smartix/builds/glibc-build:/home/axtroz/source/Smartix/builds/glibc-build/math:/home/axtroz/source/Smartix/builds/glibc-build/elf:/home/axtroz/source/Smartix/builds/glibc-build/dlfcn:/home/axtroz/source/Smartix/builds/glibc-build/nss:/home/axtroz/source/Smartix/builds/glibc-build/nis:/home/axtroz/source/Smartix/builds/glibc-build/rt:/home/axtroz/source/Smartix/builds/glibc-build/resolv:/home/axtroz/source/Smartix/builds/glibc-build/crypt:/home/axtroz/source/Smartix/builds/glibc-build/nptl /home/axtroz/source/Smartix/builds/glibc-build/libc.so.6 /home/axtroz/source/Smartix/builds/glibc-build/libc_nonshared.a -Wl,--as-needed /home/axtroz/source/Smartix/builds/glibc-build/elf/ld.so -Wl,--no-as-needed -Wl,--as-needed _s  -Wl,--no-as-needed `x86_64-smartix-linux-gcc  --print-file-name=crtend.o` /home/axtroz/source/Smartix/builds/glibc-build/csu/crtn.o
x86_64-smartix-linux-gcc iconv_prog.c -c -std=gnu99 -fgnu89-inline  -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -frounding-math -g -Wstrict-prototypes  -I../locale/programs      -I../include -I/home/axtroz/source/Smartix/builds/glibc-build/iconv -I/home/axtroz/source/Smartix/builds/glibc-build -I../sysdeps/unix/sysv/linux/x86_64/64/nptl -I../sysdeps/unix/sysv/linux/x86_64/64 -I../nptl/sysdeps/unix/sysv/linux/x86_64 -I../nptl/sysdeps/unix/sysv/linux/x86 -I../sysdeps/unix/sysv/linux/x86 -I../sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/x86_64 -I../nptl/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../nptl/sysdeps/x86_64/64 -I../sysdeps/x86_64/64 -I../sysdeps/x86_64/fpu/multiarch -I../sysdeps/x86_64/fpu -I../sysdeps/x86/fpu -I../sysdeps/x86_64/multiarch -I../nptl/sysdeps/x86_64 -I../sysdeps/x86_64 -I../sysdeps/x86 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64/wordsize-64 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/wordsize-64 -I../sysdeps/ieee754 -I../sysdeps/generic -I../nptl  -I.. -I../libio -I. -nostdinc -isystem /home/axtroz/source/Smartix/sysroot/usr/lib/gcc/x86_64-smartix-linux/4.7.1/include -isystem /home/axtroz/source/Smartix/sysroot/usr/lib/gcc/x86_64-smartix-linux/4.7.1/include-fixed -isystem /home/axtroz/source/Smartix/sysroot/usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DNOT_IN_libc=1  -DNOT_IN_libc -o /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconv_prog.o -MD -MP -MF /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconv_prog.o.dt -MT /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconv_prog.o
x86_64-smartix-linux-gcc: error: _s: No such file or directory
make[2]: *** [/home/axtroz/source/Smartix/builds/glibc-build/iconv/iconvconfig] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/home/axtroz/source/Smartix/builds/glibc-2.16.0/iconv'
make[1]: *** [iconv/others] Error 2                                                                                                                                   
make[1]: Leaving directory `/home/axtroz/source/Smartix/builds/glibc-2.16.0'                                                                                           
make: *** [all] Error 2

Couldn't find any info about this on google, perhaps because it doesn't really tolerate the "_" character in searches.
The configure switch:
Code:


      ../glibc-2.16.0/configure                      \
      --prefix=$PREFIX                                \
      --host=$TARGET                                  \
      --build=$(../glibc-2.16.0/scripts/config.guess) \
      --disable-profile                              \
      --enable-add-ons                                \
      --enable-kernel=3.4.0                          \
      --with-headers=$PREFIX/include                  \
      libc_cv_forced_unwind=yes                      \
      libc_cv_ctors_header=yes                        \
      libc_cv_c_cleanup=yes

Thanks!

druuna 08-15-2012 01:59 AM

Quote:

Originally Posted by Refractor (Post 4754350)
I have the following problem when trying to compile glibc pass 1 with the temporary tools:

I'm assuming this is LFS 7.1 (development: Version SVN-20120813) and you are stuck at 5.7 (BTW: there is no glibc pass 2).
Quote:

Code:

make[2]: Entering directory `/home/axtroz/source/Smartix/builds/glibc-2.16.0/iconv'
x86_64-smartix-linux-gcc -nostdlib -nostartfiles -o /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconvconfig  -Wl,-dynamic-linker=/home/axtroz/source/Smartix/sysroot/usr/lib/ld-linux-x86-64.so.2  -Wl,-z,combreloc -Wl,-z,relro -Wl,--hash-style=both /home/axtroz/source/Smartix/builds/glibc-build/csu/crt1.o /home/axtroz/source/Smartix/builds/glibc-build/csu/crti.o `x86_64-smartix-linux-gcc  --print-file-name=crtbegin.o` /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconvconfig.o /home/axtroz/source/Smartix/builds/glibc-build/iconv/strtab.o /home/axtroz/source/Smartix/builds/glibc-build/iconv/xmalloc.o /home/axtroz/source/Smartix/builds/glibc-build/iconv/hash-string.o  -Wl,-rpath-link=/home/axtroz/source/Smartix/builds/glibc-build:/home/axtroz/source/Smartix/builds/glibc-build/math:/home/axtroz/source/Smartix/builds/glibc-build/elf:/home/axtroz/source/Smartix/builds/glibc-build/dlfcn:/home/axtroz/source/Smartix/builds/glibc-build/nss:/home/axtroz/source/Smartix/builds/glibc-build/nis:/home/axtroz/source/Smartix/builds/glibc-build/rt:/home/axtroz/source/Smartix/builds/glibc-build/resolv:/home/axtroz/source/Smartix/builds/glibc-build/crypt:/home/axtroz/source/Smartix/builds/glibc-build/nptl /home/axtroz/source/Smartix/builds/glibc-build/libc.so.6 /home/axtroz/source/Smartix/builds/glibc-build/libc_nonshared.a -Wl,--as-needed /home/axtroz/source/Smartix/builds/glibc-build/elf/ld.so -Wl,--no-as-needed -Wl,--as-needed _s  -Wl,--no-as-needed `x86_64-smartix-linux-gcc  --print-file-name=crtend.o` /home/axtroz/source/Smartix/builds/glibc-build/csu/crtn.o
x86_64-smartix-linux-gcc iconv_prog.c -c -std=gnu99 -fgnu89-inline  -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -frounding-math -g -Wstrict-prototypes  -I../locale/programs      -I../include -I/home/axtroz/source/Smartix/builds/glibc-build/iconv -I/home/axtroz/source/Smartix/builds/glibc-build -I../sysdeps/unix/sysv/linux/x86_64/64/nptl -I../sysdeps/unix/sysv/linux/x86_64/64 -I../nptl/sysdeps/unix/sysv/linux/x86_64 -I../nptl/sysdeps/unix/sysv/linux/x86 -I../sysdeps/unix/sysv/linux/x86 -I../sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/x86_64 -I../nptl/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../nptl/sysdeps/x86_64/64 -I../sysdeps/x86_64/64 -I../sysdeps/x86_64/fpu/multiarch -I../sysdeps/x86_64/fpu -I../sysdeps/x86/fpu -I../sysdeps/x86_64/multiarch -I../nptl/sysdeps/x86_64 -I../sysdeps/x86_64 -I../sysdeps/x86 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64/wordsize-64 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/wordsize-64 -I../sysdeps/ieee754 -I../sysdeps/generic -I../nptl  -I.. -I../libio -I. -nostdinc -isystem /home/axtroz/source/Smartix/sysroot/usr/lib/gcc/x86_64-smartix-linux/4.7.1/include -isystem /home/axtroz/source/Smartix/sysroot/usr/lib/gcc/x86_64-smartix-linux/4.7.1/include-fixed -isystem /home/axtroz/source/Smartix/sysroot/usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DNOT_IN_libc=1  -DNOT_IN_libc -o /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconv_prog.o -MD -MP -MF /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconv_prog.o.dt -MT /home/axtroz/source/Smartix/builds/glibc-build/iconv/iconv_prog.o
x86_64-smartix-linux-gcc: error: _s: No such file or directory
make[2]: *** [/home/axtroz/source/Smartix/builds/glibc-build/iconv/iconvconfig] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/home/axtroz/source/Smartix/builds/glibc-2.16.0/iconv'
make[1]: *** [iconv/others] Error 2                                                                                                                                   
make[1]: Leaving directory `/home/axtroz/source/Smartix/builds/glibc-2.16.0'                                                                                           
make: *** [all] Error 2

The configure switch:
Code:


      ../glibc-2.16.0/configure                      \
      --prefix=$PREFIX                                \
      --host=$TARGET
                                  \
      --build=$(../glibc-2.16.0/scripts/config.guess) \
      --disable-profile                              \
      --enable-add-ons                                \
      --enable-kernel=3.4.0                          \
      --with-headers=$PREFIX/include                  \
      libc_cv_forced_unwind=yes                      \
      libc_cv_ctors_header=yes                        \
      libc_cv_c_cleanup=yes

Thanks!
I do see a few things worth mentioning:
- The red part: Are you using compiler flags other then mentioned in the book?
- The brown parts (there are more then I highlighted): Why aren't you using the /mnt/lfs convention? Not a show stopper, but it could make things hard to troubleshoot.
- The blue parts: What's with all the changes? Use what is mentioned in the book, especially if this is your first LFS build.
- The green part: That is plain wrong. Use what is in the book: 2.6.25.

Some extra info might be handy: What host are you using and is it made compliant?


All times are GMT -5. The time now is 08:11 AM.