LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 12-04-2012, 05:22 AM   #1
Veena_Gecw
LQ Newbie
 
Registered: Oct 2012
Posts: 13

Rep: Reputation: Disabled
"File not found" Error on booting LFS 7.2


I completed doing LFS 7.2 as per the book. (Host system : Ubuntu 12.04)


For creating the configuration file ,I edited the /boot/grub/grub.cfg:


---------------------------------
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
set have_grubenv=true
load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 9287144e-03d3-42c0-8126-c5810f5532e7
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=auto
load_video
insmod gfxterm
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 9287144e-03d3-42c0-8126-c5810f5532e7
set locale_dir=($root)/boot/grub/locale
set lang=en_IN
insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
set gfxpayload="$1"
if [ "$1" = "keep" ]; then
set vt_handoff=vt.handoff=7
else
set vt_handoff=
fi
}
if [ ${recordfail} != 1 ]; then
if [ -e ${prefix}/gfxblacklist.txt ]; then
if hwmatch ${prefix}/gfxblacklist.txt 3; then
if [ ${match} = 0 ]; then
set linux_gfx_mode=keep
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=keep
fi
else
set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Ubuntu, with Linux 3.2.0-23-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
gfxmode $linux_gfx_mode
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 9287144e-03d3-42c0-8126-c5810f5532e7
linux /boot/vmlinuz-3.2.0-23-generic-pae root=UUID=9287144e-03d3-42c0-8126-c5810f5532e7 ro quiet splash $vt_handoff
initrd /boot/initrd.img-3.2.0-23-generic-pae
}
menuentry 'Ubuntu, with Linux 3.2.0-23-generic-pae (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 9287144e-03d3-42c0-8126-c5810f5532e7
echo 'Loading Linux 3.2.0-23-generic-pae ...'
linux /boot/vmlinuz-3.2.0-23-generic-pae root=UUID=9287144e-03d3-42c0-8126-c5810f5532e7 ro recovery nomodeset
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.2.0-23-generic-pae
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 9287144e-03d3-42c0-8126-c5810f5532e7
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set=root 9287144e-03d3-42c0-8126-c5810f5532e7
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root 4204FF7C04FF7171
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
menuentry "GNU/Linux, Linux 3.5.2-lfs-7.2" {
linux /boot/vmlinuz-3.5.2-lfs-7.2 root=/dev/sda4 ro
}
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###






Then I restarted the system. The GRUB had option for LFS 7.2, along with the old ones, ubuntu and windows7.


On selecting LFS7.2, I get the error "File not found".
 
Old 12-04-2012, 05:29 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
If I understand you correctly then you added the lfs entry yourself.

Try, from your Ubuntu host as root user, to execute the update-grub command. This should find lfs and create an appropriate entry in grub.cfg. You might want to remove the entry you manually added first.
 
1 members found this post helpful.
Old 12-05-2012, 12:24 AM   #3
Veena_Gecw
LQ Newbie
 
Registered: Oct 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
Thanks.. I configured grub using update-grub. Now i restarted and selected the option for lfs from the grub menu. Then i got a black screen with the following error messages.

/proc /sys /devmount: unknown filesystem type 'devtmps'
cp: cannot create directory '/dev/pts':Read-only file system
ln: failed to create symbolic link '/dev/shm':Read-only file system

checking file system...fsck.ext3:No such file or directory while trying to open /dev/sda4
 
Old 12-05-2012, 01:12 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Quote:
Originally Posted by Veena_Gecw View Post
Thanks.. I configured grub using update-grub. Now i restarted and selected the option for lfs from the grub menu. Then i got a black screen with the following error messages.

/proc /sys /devmount: unknown filesystem type 'devtmps'
cp: cannot create directory '/dev/pts':Read-only file system
ln: failed to create symbolic link '/dev/shm':Read-only file system

checking file system...fsck.ext3:No such file or directory while trying to open /dev/sda4
More info is needed to trouble-shoot this.

- The first error (unknown filesystem type 'devtmps') could point to a missing kernel setting. Did you check/set the appropriate kernel options?
- Are there any, earlier, message during boot indicating that partitions are mounted read-only?
- From your host: What does the grub entry for LFS look like?
- From your host: What is the output of fdisk -l and please point out which partition(s) you used to build LFS.
- From LFS: Post the content of /etc/fstab

BTW: Please put your script/data inside [code] ... [/code] tags. If you don't know how: LQ - BB Code List.
 
Old 12-05-2012, 03:40 AM   #5
Veena_Gecw
LQ Newbie
 
Registered: Oct 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
Menu entry for lfs
------------------

Code:
### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
	insmod part_msdos
	insmod ntfs
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root 4204FF7C04FF7171
	chainloader +1
}
menuentry "unknown Linux distribution (on /dev/sda4)" --class gnu-linux --class gnu --class os {
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos4)'
	search --no-floppy --fs-uuid --set=root be774218-c523-4ed4-8e1d-ecb3fe8bc6dc
	linux /boot/vmlinuz-3.5.2-lfs-7.2 root=/dev/sda4
}
### END /etc/grub.d/30_os-prober ###


Output of fdisk -l from host
----------------------------
Code:
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00085804

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   205006847   102400000    7  HPFS/NTFS/exFAT
/dev/sda3       205008894   251881471    23436289    5  Extended
Partition 3 does not start on physical sector boundary.
/dev/sda4       251883135   290937149    19527007+  83  Linux
Partition 4 does not start on physical sector boundary.
/dev/sda5       205008896   244068351    19529728   83  Linux
/dev/sda6       244070400   251881471     3905536   82  Linux swap / Solaris

sda4 is used for lfs.


/etc/fstab from lfs
-------------------
[code]
# Begin /etc/fstab
# file system mount-point type options dump fsck
# order
/dev/sda4 / ext3 defaults 1 1
/dev/sda6 swap swap pri=1 0 0
proc /proc proc nosuid,noexec,nodev 0 0
sysfs /sys sysfs nosuid,noexec,nodev 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /run tmpfs defaults 0 0
devtmpfs /dev devtmpfs mode=0755,nosuid 0 0
# End /etc/fstab
[/code/

No other errors indicating partitions are read only were found.
How can i check whether i set kernel options appropriately?
 
Old 12-05-2012, 03:54 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
The posted output seems to be OK.

Quote:
Originally Posted by Veena_Gecw
How can i check whether i set kernel options appropriately?
The tmpfs setting can be found here:
--> File systems --> Pseudo filesystems --> Tmpfs entries

Also have a look at this (the Note): 8.3. Linux-3.5.2
 
Old 12-05-2012, 04:49 AM   #7
Veena_Gecw
LQ Newbie
 
Registered: Oct 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
i cant find pseudo filesystems inside file systems.
 
Old 12-05-2012, 05:16 AM   #8
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Quote:
Originally Posted by Veena_Gecw View Post
i cant find pseudo filesystems inside file systems.
Where are you looking?
Code:
cd /path/to/linux-3.5.2
make menuconfig

File systems --> Pseudo filesystems --> Tmpfs entries
The entries are there, I double checked.

If these entries are not set then you need to rebuild the kernel as explained in chapter 8.3.1
 
Old 12-05-2012, 05:55 AM   #9
Veena_Gecw
LQ Newbie
 
Registered: Oct 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
I checked for pseudo filesystem inside both ubuntu file system and lfs.

Can u give me the exact path.
 
Old 12-05-2012, 06:16 AM   #10
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Quote:
Originally Posted by Veena_Gecw View Post
I checked for pseudo filesystem inside both ubuntu file system and lfs.

Can u give me the exact path.
This is kernel specific and LFS specific (no need to check your host).

(Re)do the steps in this chapter: 8.3. Linux-3.5.2

After executing the make menuconfig step you are presented with a menu. That's where you need to look.

BTW: How did you create your initial kernel? I do hope you did do 8.3. Linux-3.5.2 and you did not copy a kernel from your host (which will _not_ work!!).
 
Old 12-05-2012, 10:15 PM   #11
Veena_Gecw
LQ Newbie
 
Registered: Oct 2012
Posts: 13

Original Poster
Rep: Reputation: Disabled
Do i need to do anything before re doing chapter 8.3??
 
Old 12-06-2012, 01:07 AM   #12
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Quote:
Originally Posted by Veena_Gecw View Post
Do i need to do anything before re doing chapter 8.3??
Only the steps you normally do when restarting/continuing with the build after a shutdown. Described here: chapter 6.65

- Section 6.2.2, “Mounting and Populating /dev”,
- Section 6.2.3, “Mounting Virtual Kernel File Systems”,
- enter the chroot environment (as shown in 6.65).

Now you are ready to redo 8.3.1
 
  


Reply

Tags
grub, kernel, lfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS 6.4 (Stable LFS) - error: "No such file or directory", linuxiso Linux - Newbie 1 08-03-2009 10:55 PM
LFS6.3 livecd "ls : command not found" error after "su - lfs" rotu Linux From Scratch 2 06-19-2008 03:59 PM
LFS-6.1 error in File-4.13, "cannot find zlib.h" Dhaval Motghare Linux From Scratch 1 11-15-2005 05:14 AM
LFS 6.0 error: glibc fails check with "g++: command not found" peristaltic Linux From Scratch 1 03-15-2005 07:52 PM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 03:31 PM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration