LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Eth0 and Usb notification niggles (http://www.linuxquestions.org/questions/linux-from-scratch-13/eth0-and-usb-notification-niggles-4175434449/)

spiky0011 10-28-2012 04:47 AM

Eth0 and Usb notification niggles
 
Hi

I have 2 little niggles I would like to clear up. LFS-7.2 built chapter 4 complete BLFS-svn
1st when the eth0 cable is connected I get a notification that it has been connected/disconnected I then press enter returns to prompt

2nd similar when I insert usb drive it notifies me, I again have to press enter to return to prompt. I would also lke the usb to auto mount when inserted, I tied entering a line in fstab but made no difference

druuna 10-28-2012 05:04 AM

Quote:

Originally Posted by spiky0011 (Post 4816581)
I have 2 little niggles I would like to clear up. LFS-7.2 built chapter 4 complete BLFS-svn
1st when the eth0 cable is connected I get a notification that it has been connected/disconnected I then press enter returns to prompt

2nd similar when I insert usb drive it notifies me, I again have to press enter to return to prompt.

I do believe it is klogd that sends these messages to the console.

I've got this line in my /etc/rc.d/init.d/sysklogd:
Code:

log_info_msg "Starting kernel log daemon..."
      start_daemon /sbin/klogd -c 3
      evaluate_retval

From the klogd man page:
Quote:

-c n Sets the default log level of console messages to n.
A while ago this was posted. Might go beyond what you asked, but I'll include it just in case: Clean up your LFS boot-time console messages

Quote:

Originally Posted by spiky0011 (Post 4816581)
I would also lke the usb to auto mount when inserted, I tied entering a line in fstab but made no difference

Different question, but have you looked at this: autofs-5.0.7?

spiky0011 10-28-2012 05:20 AM

Hi

Yes the change to /etc/rc.d/init.d/sysklogd: fixed both the problems thks

I had looked at stoats post a few times, but I dont have "/etc/sysctl.conf..." 7.2 uses grub2.00

It looks like autofs is what I was looking for

druuna 10-28-2012 06:06 AM

Quote:

Originally Posted by spiky0011 (Post 4816600)
I had looked at stoats post a few times, but I dont have "/etc/sysctl.conf..." 7.2 uses grub2.00

Those 2 (/etc/sysctl.conf and grub) are unrelated.

With sysctl you can configure kernel parameters. You can either do this dynamically ("from the prompt") or at boot (using /etc/sysctl.conf as input).

Have a look at these links:
- sysctl
- sysctl.conf
- sysctl (wiki)
- sysctl.conf example and links

A word of advise: If you are going to experiment with sysctl, do make sure you know what you are doing. Do an extensive search on the net and/or ask the LQ community to help if you are unsure.

Although you can tune many, many kernel parameters you do have to know what you are doing. Setting the wrong values can have a big negative impact on your system.

spiky0011 10-28-2012 06:14 AM

Think I,ll leave it alone lol thks for your time, although I like to modify how grub looks but cant seem to find anything it all points to production distros not basic grub.


All times are GMT -5. The time now is 01:18 PM.