LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 12-02-2011, 03:58 PM   #1
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,614
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
error no /lib/lsb/init_params?


I have just been installing gpm on lfs7 I dont see any errors running make. or even make install section. When I rebooted I get an error /lib/lsb/init_params no such file/dir. I checked the config.log in gpm there is an error (gcc error unrecognised option -V)(gcc fatal error no input files). Ok back to missing init_params IT IS,nt THERE, found this http://comments.gmane.org/gmane.linux.lfs.devel/11343 Any ideas on fixing.
 
Old 12-02-2011, 04:18 PM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Maybe try comment the line : . /lib/lsb/init_params

in /etc/rc.d/init.d/functions

If you look at LFS doc :
7.0: http://www.linuxfromscratch.org/lfs/...ts/apds03.html
SVN: http://www.linuxfromscratch.org/lfs/...ts/apds03.html
it seems this line was removed in SVN

Last edited by Cedrik; 12-02-2011 at 04:21 PM.
 
Old 12-02-2011, 04:27 PM   #3
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,614
Blog Entries: 1

Original Poster
Rep: Reputation: 226Reputation: 226Reputation: 226
Yes that has already been done.

Ok fixed it I just deleted the line out. Ref an old thread (I knew I had seen this problem before )

Last edited by spiky0011; 12-02-2011 at 04:39 PM.
 
Old 12-03-2011, 02:53 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
Hi,
Quote:
Originally Posted by spiky0011 View Post
Ok fixed it I just deleted the line out. Ref an old thread (I knew I had seen this problem before )
You've seen it here: LFS - LFS Errata and here: LQ - GPM posts 12 to 17
 
  


Reply

Tags
init_parms, lfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OPENNMS INSTALLATION ERROR -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 4 07-11-2011 12:06 PM
opennms installation error -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 2 07-08-2011 10:51 AM
[SOLVED] I want to build "ELF 64-bit LSB shared object", not "ELF 64-bit LSB executable" matschr Red Hat 2 11-15-2010 11:55 AM
Building LSB compatible application with LSB SDK - lsbappchk fails gkiagia Programming 0 01-12-2007 05:00 AM


All times are GMT -5. The time now is 05:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration