LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 03-02-2012, 12:16 AM   #1
HeadOnAPike
LQ Newbie
 
Registered: Mar 2012
Posts: 3

Rep: Reputation: Disabled
Error in part 5.4.1 of the book, editing the binutils configure file


First of all, I was confused by this:

Quote:
The Binutils documentation recommends building Binutils outside of the source directory in a dedicated build
directory:
mkdir -v ../binutils-build
cd ../binutils-build
I wasn't sure where I was supposed to put that, so I just put it in the /mnt/lfs/sources directory and then put the uncompressed binutils folder in that directory, so it looked like this:

/mnt/lfs/sources/binutils-build/binutils-2.21.1

seemed kinda redundant, I feel like I'm missing something. Anyway, I ran this part:

Quote:
../binutils-2.21.1/configure \
--target=$LFS_TGT --prefix=/tools \
--disable-nls --disable-werror
and got the following output:

Quote:
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... Invalid configuration 'i686-lfs-linux-gun': machine 'i686-lfs-linux' not recognized
configure: error: /bin/bash binutils-2.21.1/config.sub i686-lfs-linux-gun failed
Not sure what this means and am afraid to continue.
 
Old 03-02-2012, 12:45 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

All the commands given in the book assume you have untarred the specific package and are standing in the newly created directory (General Instructions. Second important box).

In case of binutils:
Code:
cd $LFS/sources
tar xf binutils-2.21.1a.tar.bz2
cd binutils-2.21.1
mkdir -v ../binutils-build
cd ../binutils-build
../binutils-2.21.1/configure \
    --target=$LFS_TGT --prefix=/tools \
    --disable-nls --disable-werror
.
.
Hope this helps.

Last edited by druuna; 03-02-2012 at 06:39 AM. Reason: fixed URI
 
Old 03-02-2012, 03:03 AM   #3
HeadOnAPike
LQ Newbie
 
Registered: Mar 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
I ran that exact code and still got the same error.
 
Old 03-02-2012, 06:44 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,
Quote:
Originally Posted by HeadOnAPike View Post
I ran that exact code and still got the same error.
Did you fully remove the previous attempt and start with a clean sheet?

You always need to remove the package directory (and possibly build directory), freshly untar the package.

I also see this: checking target system type... Invalid configuration 'i686-lfs-linux-gun': machine 'i686-lfs-linux' not recognized. That should be gnu, not gun.
Could you have made a typo?

Hope this helps.
 
Old 03-02-2012, 04:49 PM   #5
HeadOnAPike
LQ Newbie
 
Registered: Mar 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Yup, I fully removed the previous attempt and reextracted the tar file. No, it's not a typo:

http://i.imgur.com/3q3hY.jpg
 
Old 03-02-2012, 09:18 PM   #6
stoat
Member
 
Registered: May 2007
Distribution: LFS
Posts: 467

Rep: Reputation: 133Reputation: 133
Quote:
Originally Posted by HeadOnAPike

No, it's not a typo...
It's a typo. And it's probably the LFS_TGT environment variable in your ~/.bashrc file. Go back to section 4.4. (Setting Up the Environment) and double-check your ~/.bashrc.
 
Old 05-25-2013, 07:49 AM   #7
basava
LQ Newbie
 
Registered: Jul 2010
Location: Bangalore
Distribution: Slackware 12.2
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by druuna View Post
Hi,
Did you fully remove the previous attempt and start with a clean sheet?

You always need to remove the package directory (and possibly build directory), freshly untar the package.

I also see this: checking target system type... Invalid configuration 'i686-lfs-linux-gun': machine 'i686-lfs-linux' not recognized. That should be gnu, not gun.
Could you have made a typo?

Hope this helps.
Are you trying to build LFS using VMWARE???
 
Old 05-25-2013, 08:21 AM   #8
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
@basava: ????

This thread is over a year old and the OP hasn't logged in for a year.

You also quoted a reply to the original question.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error on checking binutils - 6.13 of LFS book jimmy_page_89 Linux From Scratch 3 11-17-2011 02:38 AM
[SOLVED] ../binutils-2.21/configure \ file not found mich04 Linux From Scratch 2 10-25-2011 06:00 AM
[SOLVED] lfs 6.7 book ch 5.4 binutils 2.20.1 pass 1 error:error: ppl_c.h: No such file or directory frank zhu Linux From Scratch 6 03-04-2011 11:23 AM
binutils configure error soumajit Linux From Scratch 1 12-07-2009 07:58 AM
-bash: ../binutils-2.15.94.0.2.2/configure: No such file ordirectory satimis Linux From Scratch 10 07-19-2005 09:06 AM


All times are GMT -5. The time now is 09:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration