LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Error building GCC (http://www.linuxquestions.org/questions/linux-from-scratch-13/error-building-gcc-404839/)

Lunar_Lamp 01-18-2006 04:39 AM

Error building GCC
 
Hi there

Decided, on a whim really, to try LSF. Anyway, all was progressing nicely and I was learning as I went (I'm fairly new to the Linux World). However, when trying to sort out GCC in chapter 5 of the LS book, I get the following error:

lfs@Ed-Suse-MEGA180:/mnt/lfs/sources/gcc-build> ../gcc-3.4.3/configure --prefix=/tools \ --libexecdir=/tools/lib --with-local-prefix=/tools \ --disable-nls --enable-shared --enable-languages=c
configure: warning: --libexecdir=/tools/lib: invalid host type
configure: error: can only configure for one host and one target at a time

I'd really appreciate if someone could point me in the right direction. I also note that the book does notgive an explanation of the --libexecdir option, which would interest me!

Build system, in case it is of import, is SuSE 10.0. I have not deviated from the book, as this is my first time at LSF, and so I have followed the advice to follow the book exactly!

Thanks.

Edit - I have realised that SuSE 10.0 uses GCC 4.0, which it appears elsewhere is not recommended - could this be where my problem lies? Just to clarify, this is pass 1 at GCC, in chapter 5.

freegianghu 01-18-2006 05:30 AM

Try to remove all "\"

Code:

lfs@Ed-Suse-MEGA180:/mnt/lfs/sources/gcc-build> ../gcc-3.4.3/configure --prefix=/tools \ --libexecdir=/tools/lib --with-local-prefix=/tools \ --disable-nls --enable-shared --enable-languages=c


All times are GMT -5. The time now is 08:10 AM.