LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   e2fsck error while booting lfs (http://www.linuxquestions.org/questions/linux-from-scratch-13/e2fsck-error-while-booting-lfs-313167/)

EPM_Students 04-14-2005 10:11 AM

e2fsck error while booting lfs
 
I just got grub to boot properly, but when i try to boot the newly added lfs, it will stop in:
checking file systems...
fsck.ext2: Filesystem has unsupported feature(s) (/dev/hda4)
e2fsck: Get a newer version of e2fsck!

does anyone know how can i repair this so that i can boot lfs?

whansard 04-15-2005 03:14 AM

change the fstab line for that partition at the end from1s to 0s. Then the filesystem shouldn't check.

chakkaradeepcc 05-13-2005 02:26 PM

Re: e2fsck error while booting lfs
 
Quote:

Originally posted by EPM_Students
I just got grub to boot properly, but when i try to boot the newly added lfs, it will stop in:
checking file systems...
fsck.ext2: Filesystem has unsupported feature(s) (/dev/hda4)
e2fsck: Get a newer version of e2fsck!

does anyone know how can i repair this so that i can boot lfs?

I too got the same error and later changed the fstab file.........but why actually we are getting this error?....

with regards,
C.C.Chakkaradeep

freakyg 05-14-2005 03:15 AM

I too had this problem when I built LFS 5.0 over a year ago, my /boot dir kept disappearing and would end up in the lost and found dir along with various filesystem errors---I don't advise anyone else trying this unless you know what you are doing, cause it could cause data loss

---I ended up fixing it like this.........

I put in CD#2 from Slackware 9.1 and booted it--
I mounted both LFS partitions and ran e2fsck.......
I KNOW YOU ARE NOT SUPPOSED TO DO THIS, but.........it did fix the problem!!! :)

chakkaradeepcc 05-15-2005 01:30 AM

Quote:

Originally posted by freakyg
---I ended up fixing it like this.........

I put in CD#2 from Slackware 9.1 and booted it--
I mounted both LFS partitions and ran e2fsck.......
I KNOW YOU ARE NOT SUPPOSED TO DO THIS, but.........it did fix the problem!!! :)

but the error it displays is that,

the e2fsck program installed doesnt support new features,please install a newer version of e2fsck.

then how come if u run e2fsck from Slackware solves the problem??

with regards,
C.C.Chakkaradeep

cooljinp 06-27-2005 06:38 PM

I had exact same issue and this is caused by creating partition using different distro/version of "fdisk" utility than the OS you have installed.

I.E. If your OS is Red Hat 8.0, you can't use Fedora Core3's fdisk utility to create partition. You must use Red Hat 8.0's fdisk or compatible.

The reason why freakyg fixed by using slackware is because his linux partition was originally created using slackware 9.1's fdisk or compatible version.

Hope this helps...
-Jin

WoodenRobot 07-29-2005 02:33 AM

You need to edit the fstab.conf file so that the numbers in the sixth column are all 0.

This column tells e2fsck to check the file system - and that's what's causing the problem, so it needs to be turned off.


All times are GMT -5. The time now is 07:45 AM.