LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 04-09-2002, 09:08 PM   #1
rsbecker007
Member
 
Registered: Dec 2001
Location: South Bend, IN
Distribution: Debian, Red Hat, LFS
Posts: 39

Rep: Reputation: 15
Unhappy disable logging


I am using LFS-3.1, and although I had this same problem previously, I didn't think much about it until when I switched over to LFS. Basically I have given up on getting my ethernet cards (LNE100TX s) to work properly. Whenever I "ifconfig eth0 up" or "ifconfig eth1 up" they produce many many errors, but they operate just fine. As a short term solution to this I would like to disable logging either entirely, or if possible just for those errors, I tried not starting up the sysklogd script at startup, but the errors are still logged and printed to the console.

I would like to know how or if I can get it to either not log/display those errors in particular, or disable all logging.

P.S. when I brought up the eth0 without syslogd running something called keventd showed increased activity when the errors were being produced.

As usual ANY suggestion, solutions, comments or questions are welcomed.
 
Old 04-09-2002, 09:17 PM   #2
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
Re: disable logging

Quote:
Originally posted by rsbecker007
I am using LFS-3.1, and although I had this same problem previously, I didn't think much about it until when I switched over to LFS. Basically I have given up on getting my ethernet cards (LNE100TX s) to work properly. Whenever I "ifconfig eth0 up" or "ifconfig eth1 up" they produce many many errors, but they operate just fine. As a short term solution to this I would like to disable logging either entirely, or if possible just for those errors, I tried not starting up the sysklogd script at startup, but the errors are still logged and printed to the console.

I would like to know how or if I can get it to either not log/display those errors in particular, or disable all logging.

P.S. when I brought up the eth0 without syslogd running something called keventd showed increased activity when the errors were being produced.

As usual ANY suggestion, solutions, comments or questions are welcomed.
Use the 'dmesg' program to set the level of kernel messages you want to receive on the console. By increasing the level, only that level or higher kind of messages will be printed. Experiment a bit which level will turn off the messages from your network card. It's probably level 3 or 4 that will do the trick.
 
Old 04-09-2002, 09:58 PM   #3
rsbecker007
Member
 
Registered: Dec 2001
Location: South Bend, IN
Distribution: Debian, Red Hat, LFS
Posts: 39

Original Poster
Rep: Reputation: 15
Talking thanks!

That worked quite well. I used dmesg -n 3 to get it to stop, and with syslodgd disabled, my log files don't baloon with errors anymore. I will still try to get things straightened out correctly.

One thing I noticed though, was that dmesg shows that the errors are still being generated, and from according to top whenever I bring up the cards, % of memory used by system goes from 0.1% up to 11.8%, which I don't think should be happening, but that worries me much less than my / filling up. Thanks again, and as usual I am open to suggestions from anyone on getting it fixed the right way, but for now at least I am quite happy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable console logging (Debian Sarge) retiem Linux - Networking 8 06-14-2013 06:23 AM
Postfix disable logging? lennard Linux - Software 3 12-08-2010 10:00 AM
Disable logging RH 7.3 qmail-apache etc DropHit Red Hat 3 04-13-2005 04:44 AM
what are the services i can disable, also disable ads, banners in konqueror? greythorne Suse/Novell 3 03-16-2005 08:30 AM
Disable all Apache 2.x logging hakcenter Linux - Networking 2 12-05-2003 12:34 AM


All times are GMT -5. The time now is 05:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration