LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 11-16-2011, 03:50 PM   #106
devilboy09
Member
 
Registered: Nov 2011
Location: Iran
Distribution: Debian, CentOS, LFS
Posts: 351

Original Poster
Rep: Reputation: 7

sorry!!!
i just change id:3:initdefault to id:1:initdefault and i could login ?!?!?!?!?
 
Old 11-16-2011, 03:56 PM   #107
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Quote:
Originally Posted by druuna View Post
Hi,

Either:
- There's another kernel option that is incorrect (I focussed on drives, not other stuff).
- Something is wrong with your /etc/inttab file.

But without knowing what has scrolled off-screen I cannot be sure. We probably need to see that info as well.

If I look at the /etc/inittab file you posted in post #29 (_if_ that one is still relevant!!): It does look OK.
+1, I don't think agetty has a --noclear option
 
Old 11-16-2011, 04:02 PM   #108
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Quote:
Originally Posted by devilboy09 View Post
i just change id:3:initdefault to id:1:initdefault and i could login ?!?!?!?!?
If that is the case then your kernel is probably OK the way it is.

Possible culprits that come to mind:
- Some entries in the inittab file might not be correct (re-check them all),
- LFS-Bootscripts are not/incorrectly installed (re-visit 7.6. LFS-Bootscripts-20111017),
- /sbin/agetty might not be functioning correctly.

Focus on the first 2, the third is a long shot.

BTW: Do the checking from the chrooted environment, runlevel 1 might not be flexible enough.

Hope this helps.

Last edited by druuna; 11-16-2011 at 04:24 PM. Reason: spelling
 
1 members found this post helpful.
Old 11-16-2011, 04:04 PM   #109
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi Cedrik,
Quote:
Originally Posted by Cedrik View Post
+1, I don't think agetty has a --noclear option
Yes it does 7.7.1. Configuring Sysvinit
 
Old 11-16-2011, 04:07 PM   #110
devilboy09
Member
 
Registered: Nov 2011
Location: Iran
Distribution: Debian, CentOS, LFS
Posts: 351

Original Poster
Rep: Reputation: 7
there was a mistake in inittab and i fixed that.thank you very much for your help.
 
Old 11-16-2011, 04:09 PM   #111
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,
Quote:
Originally Posted by devilboy09 View Post
there was a mistake in inittab and i fixed that.thank you very much for your help.
It took a while but I'm glad to see you got this boot problem sorted out

BTW: Can you put up the [SOLVED] tag.
first post -> Thread Tools -> Mark this thread as solved
 
Old 11-16-2011, 04:10 PM   #112
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Quote:
Originally Posted by druuna View Post
Hi Cedrik,
Yes it does 7.7.1. Configuring Sysvinit
Ah ! Sorry, didn't see this option in the manual
 
Old 11-16-2011, 06:54 PM   #113
Roken
Member
 
Registered: Oct 2011
Location: Bolton, UK
Distribution: Arch local, Debian on VPS
Posts: 252

Rep: Reputation: 40
Glad you finally got there - kernels can be a nuisance. You may want to save a copy of .config somewhere well away from your LFS build in case you need to rebuild at some point, simply to make things easier.
 
  


Reply

Tags
grub, kernel, lfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Good but sorta easy guide to Kernel compiling/Re-Compiling? linus72 Linux - General 1 07-13-2009 01:37 PM
Compiling a module separately without compiling entire kernel kushalkoolwal Linux - Kernel 8 08-06-2008 01:45 AM
compiling kernel problem --- Kernel panic: unable to mount root fs ........ anthonymts123 Linux - General 5 07-31-2006 02:29 AM
Kernel compiling and module compiling tarballed Linux - General 1 12-22-2002 05:31 PM


All times are GMT -5. The time now is 04:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration