LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 02-14-2010, 08:41 PM   #1
appzer0
LQ Newbie
 
Registered: Nov 2008
Location: France
Distribution: 0Linux, Slackware
Posts: 13

Rep: Reputation: 0
CLFS multilib: Xorg spits a black screen, no keyboard, no error message no more TTY


Hello,

I'm building my system with method from LFS and CLFS multilib (32/64bit), along with "SlackBuilds" scripts to automatically rebuild packages (as in Slackware). It's working pretty good (compiling, scripting, editing or executing, everything runs just fine).

However, Xorg is a real problem. Everything has been compiled/installed fine for Xorg (drivers, apps, fonts, libs, xorg-server, xkeyboard-config) along with udev, HAL, etc.

I'm using the 'nv' driver. 'Xorg -verbose' does not show any other thing that a black screen, seems frozen, and my keyboard does not react anymore (the NumLock LED doesn't work). Even by redirecting output to logs or insvestigating Xorg.0.log, I see no error messages, no warnings, nothing. Good to know : Xorg is patched to draw a black screen (and not the ugly grey one we're used to watch at startup).

I don't use a xorg.conf file as X is able to not use one to work.

I expect X to launch twm. My xinitrc file points to xinitrc.twm, which is :
Code:
#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/lib/X11/xinit/.Xresources
sysmodmap=/usr/lib/X11/xinit/.Xmodmap

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

/usr/bin/twm &
/usr/bin/xclock -geometry 50x50-1+1 &
/usr/bin/xterm -geometry 80x50+494+51 &
/usr/bin/xterm -geometry 80x20+494-0 &
exec /usr/bin/xterm -geometry 80x66+0+0 -name login
(an yes, xterm is installed)

My tty does not respawn so I'm bound to push the "reset" button

Xorg.0.log, from X's verbose output:

Code:
X.Org X Server 1.7.4
Release Date: 2010-01-08
X Protocol Version 11, Revision 0
Build Operating System: frenchslack 
Current Operating System: Linux pingouin 2.6.32.7 #1 SMP PREEMPT Sun Feb 14 02:12:02 Local time zone must be set-- x86_64
Kernel command line: BOOT_IMAGE=frenchslack ro root=804 vt.default_utf8=1
Build Date: 15 February 2010  01:52:02AM
 
Current version of pixman: 0.17.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 15 01:59:25 2010
(II) Loader magic: 0x7bf760
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:2:0:0) 10de:0640:10b0:1401 rev 161, Mem @ 0xfa000000/16777216, 0xd0000000/268435456, 0xf8000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/524288
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
    Section "Device"
        Identifier    "Builtin Default nv Device 0"
        Driver    "nv"
    EndSection
    Section "Screen"
        Identifier    "Builtin Default nv Screen 0"
        Device    "Builtin Default nv Device 0"
    EndSection
    Section "Device"
        Identifier    "Builtin Default vesa Device 0"
        Driver    "vesa"
    EndSection
    Section "Screen"
        Identifier    "Builtin Default vesa Screen 0"
        Device    "Builtin Default vesa Device 0"
    EndSection
    Section "Device"
        Identifier    "Builtin Default fbdev Device 0"
        Driver    "fbdev"
    EndSection
    Section "Screen"
        Identifier    "Builtin Default fbdev Screen 0"
        Device    "Builtin Default fbdev Device 0"
    EndSection
    Section "ServerLayout"
        Identifier    "Builtin Default Layout"
        Screen    "Builtin Default nv Screen 0"
        Screen    "Builtin Default vesa Screen 0"
        Screen    "Builtin Default fbdev Screen 0"
    EndSection
(==) --- End of built-in configuration ---
(==) ServerLayout "Builtin Default Layout"
(**) |-->Screen "Builtin Default nv Screen 0" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default nv Device 0"
(==) No monitor specified for screen "Builtin Default nv Screen 0".
    Using a default monitor configuration.
(**) |-->Screen "Builtin Default vesa Screen 0" (1)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default vesa Device 0"
(==) No monitor specified for screen "Builtin Default vesa Screen 0".
    Using a default monitor configuration.
(**) |-->Screen "Builtin Default fbdev Screen 0" (2)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default fbdev Device 0"
(==) No monitor specified for screen "Builtin Default fbdev Screen 0".
    Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/OTF,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/
(==) ModulePath set to "/usr/lib64/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
    If no devices become available, reconfigure HAL or disable AutoAddDevices.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nv"
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 2.1.16
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 2.3.0
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 0.4.1
    ABI class: X.Org Video Driver, version 6.0
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
    Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
    Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
    GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
    GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
    Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
    GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
    GeForce4 420 Go 32M, GeForce4 460 Go, Quadro4 550 XGL,
    GeForce4 440 Go 64M, Quadro NVS, Quadro4 500 GoGL,
    GeForce4 410 Go 16M, GeForce4 MX 440 with AGP8X,
    GeForce4 MX 440SE with AGP8X, GeForce4 MX 420 with AGP8X,
    GeForce4 MX 4000, GeForce4 448 Go, GeForce4 488 Go, Quadro4 580 XGL,
    Quadro4 NVS 280 SD, Quadro4 380 XGL, Quadro NVS 50 PCI,
    GeForce4 448 Go, GeForce4 MX Integrated GPU, GeForce3,
    GeForce3 Ti 200, GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600,
    GeForce4 Ti 4400, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
    Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
    GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
    Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
    GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
    GeForce FX 5600 Ultra, GeForce FX 5600, GeForce FX 5600XT,
    GeForce FX Go5600, GeForce FX Go5650, Quadro FX Go700,
    GeForce FX 5200, GeForce FX 5200 Ultra, GeForce FX 5200,
    GeForce FX 5200LE, GeForce FX Go5200, GeForce FX Go5250,
    GeForce FX 5500, GeForce FX 5100, GeForce FX Go5200 32M/64M,
    Quadro NVS 55/280 PCI, Quadro FX 500/600 PCI,
    GeForce FX Go53xx Series, GeForce FX Go5100, GeForce FX 5900 Ultra,
    GeForce FX 5900, GeForce FX 5900XT, GeForce FX 5950 Ultra,
    GeForce FX 5900ZT, Quadro FX 3000, Quadro FX 700,
    GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
    GeForce FX 5700VE, GeForce FX Go5700, GeForce FX Go5700,
    Quadro FX Go1000, Quadro FX 1100, GeForce 6800 Ultra, GeForce 6800,
    GeForce 6800 LE, GeForce 6800 XE, GeForce 6800 XT, GeForce 6800 GT,
    GeForce 6800 GT, GeForce 6800 GS, GeForce 6800 XT, Quadro FX 4000,
    GeForce 6800 GS, GeForce 6800, GeForce 6800 LE, GeForce 6800 XT,
    GeForce Go 6800, GeForce Go 6800 Ultra, Quadro FX Go1400,
    Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
    GeForce 6600, GeForce 6600 LE, GeForce 6600 VE, GeForce Go 6600,
    GeForce 6610 XL, GeForce Go 6600 TE/6200 TE, GeForce 6700 XL,
    GeForce Go 6600, GeForce Go 6600 GT, Quadro NVS 440, Quadro FX 550,
    Quadro FX 550, Quadro FX 540, GeForce 6200, GeForce 6500,
    GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
    GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
    GeForce Go 6200, GeForce Go 6400, GeForce 6250, GeForce 7100 GS,
    GeForce 6800, GeForce 6800 LE, GeForce 6800 GT, GeForce 6800 XT,
    GeForce 6200, GeForce 6200 A-LE, GeForce 7800 GTX, GeForce 7800 GTX,
    GeForce 7800 GT, GeForce 7800 GS, GeForce 7800 SLI, GeForce Go 7800,
    GeForce Go 7800 GTX, Quadro FX 4500, GeForce 7350 LE,
    GeForce 7300 LE, GeForce 7300 SE, GeForce Go 7200, GeForce Go 7300,
    GeForce Go 7400, GeForce Go 7400 GS, Quadro NVS 110M,
    Quadro NVS 120M, Quadro FX 350M, GeForce 7500 LE, Quadro FX 350,
    GeForce 7300 GS, GeForce 7650 GS, GeForce 7600 GT, GeForce 7600 GS,
    GeForce 7300 GT, GeForce 7600 LE, GeForce 7300 GT, GeForce Go 7700,
    GeForce Go 7600, GeForce Go 7600 GT, Quadro NVS 300M,
    GeForce Go 7900 SE, Quadro FX 550M, Quadro FX 560, GeForce 7900 GTX,
    GeForce 7900 GT, GeForce 7900 GS, GeForce 7950 GX2, GeForce 7950 GX2,
    GeForce 7950 GT, GeForce Go 7950 GTX, GeForce Go 7900 GS,
    GeForce Go 7900 GTX, Quadro FX 2500M, Quadro FX 1500M,
    Quadro FX 5500, Quadro FX 3500, Quadro FX 1500, Quadro FX 4500 X2,
    GeForce 6150, GeForce 6150 LE, GeForce 6100, GeForce Go 6150,
    Quadro NVS 210S / NVIDIA GeForce 6150LE, GeForce Go 6100,
    GeForce 6150SE, GeForce 6100 nForce 405, GeForce 6100 nForce 400,
    GeForce 6100 nForce 420, GeForce 8800 GTX, GeForce 8800 GTS,
    GeForce 8800 Ultra, Quadro FX 5600, Quadro FX 4600, GeForce 8600 GTS,
    GeForce 8600 GT, GeForce 8600 GT, GeForce 8600 GS, GeForce 8400 GS,
    GeForce 9500M GS, GeForce 8600M GT, GeForce 9650M GS,
    GeForce 8700M GT, Quadro FX 370, Quadro NVS 320M, Quadro FX 570M,
    Quadro FX 1600M, Quadro FX 570, Quadro FX 1700, GeForce 8400 SE,
    GeForce 8500 GT, GeForce 8400 GS, GeForce 8300 GS, GeForce 8400 GS,
    GeForce 8600M GS, GeForce 8400M GT, GeForce 8400M GS,
    GeForce 8400M G, Quadro NVS 140M, Quadro NVS 130M, Quadro NVS 135M,
    GeForce 9400 GT, Quadro FX 360M, GeForce 9300M G, Quadro NVS 290,
    GeForce GTX 295, GeForce GTX 280, GeForce GTX 260, GeForce GTX 285,
    GeForce GTX 275, GeForce GTX 295, Quadro CX, Quadro FX 5800,
    Quadro FX 4800, Quadro FX 3800, GeForce 8800 GTS 512,
    GeForce 9800 GT, GeForce 8800 GT, GeForce 9800 GX2, GeForce 9800 GT,
    GeForce 8800 GS, GeForce GTS 240, GeForce 9800M GTX,
    GeForce 8800M GTS, GeForce GTX 280M, GeForce 9800M GT,
    GeForce 8800M GTX, GeForce 8800 GS, GeForce 9600 GSO,
    GeForce 8800 GT, GeForce 9800 GTX, GeForce 9800 GTX+,
    GeForce 9800 GT, GeForce GTS 250, GeForce 9800M GTX,
    GeForce GTX 260M, Quadro FX 3700, Quadro FX 3600M, Quadro FX 2800M,
    Quadro FX 3700M, Quadro FX 3800M, GeForce 9600 GT, GeForce 9600 GS,
    GeForce 9600 GSO 512, GeForce GT 130, GeForce GT 140,
    GeForce 9800M GTS, GeForce 9700M GTS, GeForce 9800M GS,
    GeForce 9800M GTS, Quadro FX 1800, Quadro FX 2700M, GeForce 9500 GT,
    GeForce 9400 GT, GeForce 9500 GT, GeForce 9500 GS, GeForce GT 120,
    GeForce 9600M GT, GeForce 9600M GS, GeForce 9600M GT,
    GeForce 9700M GT, GeForce 9500M G, GeForce 9650M GT, GeForce GT 130M,
    GeForce 9500 GT, Quadro FX 380, Quadro FX 580, Quadro FX 1700M,
    Quadro FX 770M, GeForce 9300 GE, GeForce 9300 GS, GeForce 8400 GS,
    GeForce 9300M GS, GeForce G100, GeForce 9200M GS, GeForce 9300M GS,
    Quadro NVS 150M, Quadro NVS 160M, GeForce G 105M, GeForce G 103M,
    Quadro NVS 420, Quadro FX 370 LP, Quadro NVS 450, Quadro NVS 295,
    GeForce GT 220, GeForce 210, GeForce GT 230M, GeForce GT 240M,
    GeForce G210, GeForce 205, GeForce 310, GeForce 210, GeForce 310,
    GeForce G210M, Quadro FX 380 LP, GeForce GT 240, GeForce GTS 260M,
    GeForce GTS 250M
(II) VESA: driver for VESA chipsets: vesa
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 02@00:00:0
(--) NV: Found NVIDIA GeForce 9500 GT at 02@00:00:0
(WW) Falling back to old probe method for vesa
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib64/xorg/modules/linux/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 0.0.2
    ABI class: X.Org Video Driver, version 6.0
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/lib64/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.0.0
    ABI class: X.Org Video Driver, version 6.0
(II) NV(0): Initializing int10
(II) NV(0): Primary V_BIOS segment is: 0xc000
(--) NV(0): Console is VGA mode 0x105
(II) NV(0): Creating default Display subsection in Screen section
    "Builtin Default nv Screen 0" for depth/fbbpp 24/32
(==) NV(0): Depth 24, (--) framebuffer bpp 32
(==) NV(0): RGB weight 888
(==) NV(0): Default visual is TrueColor
(==) NV(0): Using hardware cursor
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): MMIO registers mapped at 0x7f69128fd000
(--) NV(0): Total video RAM: 1024.0 MB
(--) NV(0):       BAR1 size: 256.0 MB
(--) NV(0):   Mapped memory: 256.0 MB
(II) NV(0): Linear framebuffer mapped at 0x7f68f28fd000
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Module "i2c" already built-in
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(--) NV(0): Connector map:
(--) NV(0):   Bus 0 -> DAC1
(--) NV(0):   Bus 0 -> SOR2
(--) NV(0):   Bus 1 -> DAC2
(--) NV(0):   Bus 2 -> SOR1
(--) NV(0): Load detection: 506
(II) NV(0): I2C bus "I2C0" initialized.
(II) NV(0): Output VGA1 has no monitor section
(II) NV(0): Output DVI2 has no monitor section
(II) NV(0): I2C bus "I2C1" initialized.
(II) NV(0): Output VGA2 has no monitor section
(II) NV(0): I2C bus "I2C2" initialized.
(II) NV(0): Output DVI1 has no monitor section
(II) NV(0): Probing for EDID on I2C bus 0...
(II) NV(0): I2C device "I2C0:ddc2" registered at address 0xA0.
(II) NV(0):   ... none found
(--) NV(0): Trying load detection on VGA1 ... nothing.
(II) NV(0): Probing for EDID on I2C bus 1...
(II) NV(0): I2C device "I2C1:ddc2" registered at address 0xA0.
(--) NV(0): DDC detected a CRT:
(II) NV(0): Manufacturer: HWP  Model: 2616  Serial#: 16843009
(II) NV(0): Year: 2003  Week: 52
(II) NV(0): EDID Version: 1.3
(II) NV(0): Analog Display Input,  Input Voltage Level: 0.700/0.700 V
(II) NV(0): Sync:  Separate
(II) NV(0): Max Image Size [cm]: horiz.: 32  vert.: 24
(II) NV(0): Gamma: 2.88
(II) NV(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) NV(0): First detailed timing is preferred mode
(II) NV(0): redX: 0.631 redY: 0.329   greenX: 0.276 greenY: 0.600
(II) NV(0): blueX: 0.143 blueY: 0.057   whiteX: 0.283 whiteY: 0.298
(II) NV(0): Supported established timings:
(II) NV(0): 720x400@70Hz
(II) NV(0): 640x480@60Hz
(II) NV(0): 640x480@75Hz
(II) NV(0): 800x600@75Hz
(II) NV(0): 1024x768@75Hz
(II) NV(0): Manufacturer's mask: 0
(II) NV(0): Supported standard timings:
(II) NV(0): #0: hsize: 640  vsize 480  refresh: 85  vid: 22833
(II) NV(0): #1: hsize: 800  vsize 600  refresh: 85  vid: 22853
(II) NV(0): #2: hsize: 1024  vsize 768  refresh: 85  vid: 22881
(II) NV(0): #3: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
(II) NV(0): Supported detailed timing:
(II) NV(0): clock: 94.5 MHz   Image Size:  312 x 234 mm
(II) NV(0): h_active: 1024  h_sync: 1072  h_sync_end 1168 h_blank_end 1376 h_border: 0
(II) NV(0): v_active: 768  v_sync: 769  v_sync_end 772 v_blanking: 808 v_border: 0
(II) NV(0): Ranges: V min: 50 V max: 140 Hz, H min: 30 H max: 70 kHz, PixClock max 110 MHz
(II) NV(0): Monitor name: hp v72
(II) NV(0): Serial No: CNN3521BT3
(II) NV(0): EDID (in hex):
(II) NV(0):     00ffffffffffff0022f0162601010101
(II) NV(0):     340d0103682018bcea9ea9a154469924
(II) NV(0):     0e484ca4420031594559615981800101
(II) NV(0):     010101010101ea240060410028303060
(II) NV(0):     130038ea1000001e000000fd00328c1e
(II) NV(0):     460b000a202020202020000000fc0068
(II) NV(0):     70207637320a202020202020000000ff
(II) NV(0):     00434e4e333532314254330a20200030
(--) NV(0): Trying load detection on VGA2 ... found one!
(II) NV(0): EDID vendor "HWP", prod id 9750
(II) NV(0): Probing for EDID on I2C bus 2...
(II) NV(0): I2C device "I2C2:ddc2" registered at address 0xA0.
(II) NV(0):   ... none found
(II) NV(0): Output VGA1 disconnected
(II) NV(0): Output DVI2 disconnected
(II) NV(0): Output VGA2 connected
(II) NV(0): Output DVI1 disconnected
(II) NV(0): Using exact sizes for initial modes
(II) NV(0): Output VGA2 using initial mode 1024x768
(II) NV(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
(--) NV(0): Virtual size is 1280x1280 (pitch 1280)
(**) NV(0):  Driver mode "1024x768": 94.5 MHz (scaled from 0.0 MHz), 68.7 kHz, 85.0 Hz
(II) NV(0): Modeline "1024x768"x85.0   94.50  1024 1072 1168 1376  768 769 772 808 +hsync +vsync (68.7 kHz)
(**) NV(0):  Driver mode "1280x1024": 108.0 MHz (scaled from 0.0 MHz), 64.0 kHz, 60.0 Hz
(II) NV(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(**) NV(0):  Driver mode "1024x768": 78.8 MHz (scaled from 0.0 MHz), 60.0 kHz, 75.0 Hz
(II) NV(0): Modeline "1024x768"x75.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
(**) NV(0):  Driver mode "800x600": 56.2 MHz (scaled from 0.0 MHz), 53.7 kHz, 85.1 Hz
(II) NV(0): Modeline "800x600"x85.1   56.25  800 832 896 1048  600 601 604 631 +hsync +vsync (53.7 kHz)
(**) NV(0):  Driver mode "800x600": 49.5 MHz (scaled from 0.0 MHz), 46.9 kHz, 75.0 Hz
(II) NV(0): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(**) NV(0):  Driver mode "640x480": 36.0 MHz (scaled from 0.0 MHz), 43.3 kHz, 85.0 Hz
(II) NV(0): Modeline "640x480"x85.0   36.00  640 696 752 832  480 481 484 509 -hsync -vsync (43.3 kHz)
(**) NV(0):  Driver mode "640x480": 31.5 MHz (scaled from 0.0 MHz), 37.5 kHz, 75.0 Hz
(II) NV(0): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(**) NV(0):  Driver mode "640x480": 25.2 MHz (scaled from 0.0 MHz), 31.5 kHz, 59.9 Hz
(II) NV(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(**) NV(0):  Driver mode "720x400": 28.3 MHz (scaled from 0.0 MHz), 31.5 kHz, 70.1 Hz
(II) NV(0): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(==) NV(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/lib64/xorg/modules/libxaa.so
(II) Module xaa: vendor="X.Org Foundation"
    compiled for 1.7.4, module version = 1.2.1
    ABI class: X.Org Video Driver, version 6.0
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) UnloadModule: "vesa"
(II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
(II) UnloadModule: "fbdev"
(II) Unloading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/lib64/xorg/modules/linux/libfbdevhw.so
(--) Depth 24 pixmap format is 32 bpp
(--) NV(0): 153.75 MB available for offscreen pixmaps
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
    Screen to screen bit blits
    Solid filled rectangles
    8x8 mono pattern filled rectangles
    Indirect CPU to Screen color expansion
    Solid Lines
    Scanline Image Writes
    Setting up tile and stipple cache:
        32 128x128 slots
        32 256x256 slots
        16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(==) NV(0): DPMS enabled
(II) NV(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) AIGLX: Screen 0 is not DRI2 capable
(II) AIGLX: Screen 0 is not DRI capable
(II) AIGLX: Loaded and initialized /usr/lib64/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0
(II) NV(0): Setting screen physical size to 270 x 203
I'd be glad to have a hint. I can give more info as I'm pretty much stuck at the moment :-\

TIA, sorry for my english.
 
Old 02-15-2010, 04:08 AM   #2
appzer0
LQ Newbie
 
Registered: Nov 2008
Location: France
Distribution: 0Linux, Slackware
Posts: 13

Original Poster
Rep: Reputation: 0
Hi again,

Problem is solved. HAL had to be executed not to block the keyboard initialization process when lauching Xorg!... Sorry for the noise.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After update i get black screen in xorg Bojevnik Suse/Novell 6 07-28-2009 08:36 AM
CLFS SVN-20080921-x86_64-Multilib Part 10 binutils chokes on install ChrisMP1 Linux From Scratch 0 09-23-2008 09:11 PM
nvidia xorg: Black screen after 15min frenchn00b Debian 2 02-09-2008 01:16 AM
Nividia Fx5500, Black Screen, xorg.conf lizard_king825 Linux - Hardware 1 08-29-2006 09:10 PM
nVidia in Xorg=black screen FXRS Slackware 13 07-01-2004 02:55 AM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration