LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 10-10-2002, 01:52 AM   #1
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Chapter 6 Glibc error in configure


Code:
running configure fragment for ../glibc-2.2.5/sysdeps/unix/sysv/linux
checking installed Linux kernel header files... 2.0.10 or later
*** On GNU/Linux systems it is normal to compile GNU libc with the
*** `linuxthreads' add-on.  Without that, the library will be
*** incompatible with normal GNU/Linux systems.
*** If you really mean to not use this add-on, run configure again
*** using the extra parameter `--disable-sanity-checks'.
I have no name!:/usr/src/sources/glibc-build#
I am guessing that it's actually referring to me installing the kernel wrong, but I followed the directions exactly in both. Just to make sure again, I highlighted and pasted them, same error message.

Any ideas?

Thanks
 
Old 10-10-2002, 12:10 PM   #2
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
you need to unpack the linuxthreads package inside the glibc-2.2.5 directory

seems you forgot to do it, or unpacked it in the wrong location.
 
Old 10-10-2002, 08:11 PM   #3
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Original Poster
Rep: Reputation: 64
Thank you very much, I must have clicked through the page too fast

Thanks Gerard.
 
Old 10-27-2002, 12:47 PM   #4
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
Gah!
This one had me foxed for a while too. I started fiddling with the compile switches before I noticed it couldn't see linuxthreads. *Note to self - must look here sooner*.

Cheers.
Bert
 
Old 07-16-2003, 07:41 AM   #5
robert999
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
i had the same problem as masterc so i unpacked linux threads in the glibc directory
when i run the configure script
i now get

configuring in linuxthreads
running /bin/sh ../../glibc-2.3.1/linuxthreads/configure --prefix=/usr --disable-profile --enable-add-ons --libexecdir=/usr/bin --cache-file=.././config.cache --srcdir=../../glibc-2.3.1/linuxthreads

i assume its done this part of compiling is done correctly now so i type make and get

make[1]: *** [/usr/src/glibc-build/sysd-dirs] Error 127
make[1]: Leaving directory `/usr/src/glibc-2.3.1'
make: *** [all] Error 2

im following the lfs book and dont no what to do to get glibc to complie correctly
can anyone help
 
Old 07-16-2003, 07:43 AM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Original Poster
Rep: Reputation: 64
Welcome to LQ

Can you post up more of the error message, like maybe the last 10 lines or so?

Cool
 
Old 07-17-2003, 02:17 PM   #7
robert999
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
make -r PARALLELMFLAGS="" CVSOPTS="" -C ../glibc-2.3.1 objdir=`pwd` all
make[1]: Entering directory `/usr/src/glibc-2.3.1'
'BEGIN { subdirs = ""; inhibit = "" }; \
/^#/ { next }; \
/^[^-]/ { subdirs = subdirs " " $0 }; \
/^-/ { inhibit = inhibit " " substr($0, 2) }; \
END { printf "sysdep-subdirs =%s\n", subdirs; \
printf "sysdep-inhibit-subdirs =%s\n", inhibit; \
print "sysd-dirs-done = t" }' \
/dev/null linuxthreads/sysdeps/pthread/Subdirs sysdeps/unix/inet/Subdirs sysdeps/unix/Subdirs > /usr/src/glibc-build/sysd-dirs-tmp
/bin/sh: BEGIN { subdirs = ""; inhibit = "" }; /^#/ { next }; /^[^-]/ { subdirs = subdirs " " $0 }; /^-/ { inhibit = inhibit " " substr($0, 2) }; END { printf "sysdep-subdirs =%s\n", subdirs; printf "sysdep-inhibit-subdirs =%s\n", inhibit; print "sysd-dirs-done = t" }: No such file or directory
make[1]: *** [/usr/src/glibc-build/sysd-dirs] Error 127
make[1]: Leaving directory `/usr/src/glibc-2.3.1'
make: *** [all] Error 2

this is what it says when i try to make it
ive got a feeling that it might be to do with my version of gcc
as when i was staticaly compiling gcc earler in the chapter i used version 3.3

Last edited by robert999; 07-17-2003 at 02:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS 6, chapter 6.11; Glibc 'make check' error Zamochit Linux From Scratch 5 05-31-2005 01:54 PM
Error cross-compiling glibc, chapter 5 donbellioni Linux From Scratch 2 09-17-2004 03:12 PM
glibc-2.3.3 in chapter 6 error znif Linux From Scratch 11 06-28-2004 08:15 AM
Chapter 6, Glibc: configure fails while testing CPP Electrode Linux From Scratch 9 08-31-2003 03:38 PM
LFS 3.3 - chapter 6 - glibc error fend88 Linux From Scratch 5 04-29-2002 12:06 AM


All times are GMT -5. The time now is 03:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration