LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Chapter 6.8.2 - mount does not work (http://www.linuxquestions.org/questions/linux-from-scratch-13/chapter-6-8-2-mount-does-not-work-418904/)

Demogorgon 02-23-2006 07:38 PM

Chapter 6.8.2 - mount does not work
 
It's my first LFS and I'm running the LFS live CD 6.1.1-4.

When I came to chapter 6.8.2, it said that libblkid.so.1 was missing when I tried to do the mount.
So I reinstalled Util-linux-2.12q in chapter 5.31 and that solved that, but now instead it can't find the mount command at all.

root:/# mount -nvt tmpfs none /dev
bash: tools/bin/mount: No such file or directory

I have tried to reinstall Util-linux-2.12q, i have checked tools/bin/ and mount is there.

Anyone who can help me?

macemoneta 02-23-2006 09:54 PM

Is the file marked executable?

chmod +x tools/bin/mount

Demogorgon 02-24-2006 12:56 AM

Yes it is. It doesn't work anyway.

FinalFantasy 02-24-2006 04:10 PM

ldd /tools/bin/mount

If it showed /lib/ld-linux.so.2, it means you did NOT do the adjusting correctly(5.7 adjusting the toolchain.)

Demogorgon 02-24-2006 04:25 PM

When I do the command: ldd /tools/bin/mount
I get the reply: /tools/bin/ldd: line 124: /tools/bin/mount: No such file or directory

Is that also the toolchain in 5.7?

Demogorgon 02-25-2006 06:10 AM

When I run the command: readelf -l /tools/bin/mount | grep interpreter
I get the reply: [Requesting program interpreter: /lib/ld-linux.so.2]

But shouldn't that be: [Requesting program interpreter: /tools/lib/ld-linux.so.2]

How do I correct this?

FinalFantasy 02-25-2006 10:30 AM

It is the problem in toolchain adjusting in 5.7.

Do the adjusting again. but for the ld you should use the first one you compiled.(before the make -C ld clean) If you do not have it, compile the binutils again.


All times are GMT -5. The time now is 03:59 AM.