LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 04-13-2011, 04:42 AM   #31
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374

Quote:
Originally Posted by janakiramulu View Post
see pageno-189
Which chapter, I use the on-line version of the book, which does not have page numbers.

You are probably talking about chapter 6.60 and this is what the book says:
Quote:
Documentation for other available options can be obtained by running the following command:
Code:
vim -c ':options'
What is not clear about this?
 
Old 04-13-2011, 05:01 AM   #32
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Quote:
Originally Posted by janakiramulu View Post
root:/logout
output is
there are stopped jobs
The bold part could be a problem, but without knowing which job(s) I cannot help you on that (and I don't know how to find out which job(s) the message is talking about)

Quote:
next i re enter to chroot
.
.
output is
chroot:cannot change root directory t /tools/bin/env:not a directory(there is no directory with name)
Does /tools/bin/env exist? (ls -l /tools/bin/env). If it does not exist you probably removed something you should not have removed.

Is LFS set (echo $LFS), if not: it should be.
 
Old 04-13-2011, 05:29 AM   #33
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
hi druuna
1)
i redo chapter 6.60. Vim-7.3
while running
root:/sources# make test (6.60.1. Installation of Vim)
is giving error in red colour (highlighted bold letters) moving fast(scrolling)
but at the end of make test result no error messages are appearing
------------------------------------------------------------------------------------------------------------

2)post no 29
yes this -6.60.2. Configuring Vim(pageno-189) ,here i will give very clear
when i issue this----root:/sources/vim73#vim -c 'ptions'
result is in diff colors text and options as red colour like 1,2,3........25
option window [while bar on that black letters with this name )
-
-
-
-
[no name]
then i press from keyboard(cntl+c)
following message showing
type:i quit(<enter> for quit)
then i press from keyboard(cntl+z)
output mesage is [1]:stopped

here i have to do nothing right(do i simply quit from this)when i issue this command 'vim -c 'ptions'
is it k.
------------------------------------------------------------------------
3)post 32
i am talking about 6.62. Stripping Again

root:/sources/vim73#logout
output is
there are stopped jobs(not bold letter)
---------------------------------------------------------
4)here i checked LFS set with following
root:/sources/:echo $LFS
result nothing
i need to set $LFS with export right
--------------------------------------------
5) where i have to perform this 6.60.2. Configuring Vim(,in vim source directory)
 
Old 04-13-2011, 05:36 AM   #34
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
6)i check
ls -l /tools/bin/env
doent exist env dir in /tools/bin
 
Old 04-13-2011, 05:47 AM   #35
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

If you have been building (parts of) chapter 6 without LFS being set, you need to start again from the beginning of chapter 6. You've been told the importance of the LFS variable again and again in the book........

You still do not follow the book and still don't have a clue what it is you are doing. I don't think it is wise for you to continue until you have a better understanding of linux in general and know how to follow the instructions in the book.

This also means that I will not be answering your questions any more until I see a significant improvement.
 
Old 04-13-2011, 05:51 AM   #36
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
which i am asking above questions are conflict,i would have mention(above questions) as in the book
(but i followed the book as they mention)
 
Old 04-15-2011, 12:51 AM   #37
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
hi druuna
1)i have small doubt (echo $LFS)because of this i am not moving further
first i exit from lfs usr
then
root[ ~ ]#chown -R root:root $LFS/tools
root[ ~ ]#echo $ LFS
result is /mn/lfs (this result till chapter 6.23)

2)but
6.4. Entering the Chroot Environment (page no-79)
---------------------------------
see third paragaph
From this point on, there is no need to use the LFS variable anymore, because all work will be restricted to the LFS
file system. This is because the Bash shell is told that $LFS is now the root (/) directory.
------------------------------------------------------------------------------------------------
root[ ~ [#chroot "$LFS" /tools/bin/env -i \
HOME=/root TERM="$TERM" PS1='\u:\w\$ ' \
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin \
/tools/bin/bash --login +h
result is I have no name!:/# this is right according to book

I have no name!:/#echo $LFS
no (any) output
this is continuing till end of chapter 6,you are saying that it should set (echo $LFS))

how can i set the variable
this is the problem(exact) ,what to do i am going to be mad(with this)
plz help me
 
Old 04-15-2011, 01:59 AM   #38
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
5.33. Changing Ownership(page no-73)
Note
The commands in the remainder of this book must be performed while logged in as user root and no
longer as user lfs. Also, double check that $LFS is set in root's environment.
------------------------------------
i set with the $LFS to root with export command
ie
export LFS=/

----------------
then i moved to further
i checked echo $LFS
giving /
this is right according to book(check that $LFS is set in root's environment)
is this right
 
Old 04-15-2011, 06:00 AM   #39
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Read post #35.
 
Old 04-15-2011, 11:38 PM   #40
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
hi druuna
just give me clue before moving to chapter6 and till end of lfs build
if i check(any time) echo $LFS,what would be the result
 
Old 04-20-2011, 05:54 AM   #41
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
hi druuna
this time i skip this (commands)step 5.32
5.33. Changing Ownership
1)i have gotten echo $LFS result is '/mnt/lfs' after issuing this command root:/#chown -R root:root $LFS/tools
----------------------------------------------------------------------------------
2)but after this
6.4. Entering the Chroot Environment
root [ ~ ]#chroot "$LFS" /tools/bin/env -i \
HOME=/root TERM="$TERM" PS1='\u:\w\$ ' \
PATH=/bin:/usr/bin:/sbin:/usr/
sbin:/tools/bin \
/tools/bin/bash --login +h

result is
i have no name!:/# (as per book is right)
i have no name!:/#echo $LFS
nothing result
-----------------------------------
3)i moved further till 6.16. GCC-4.5.1(pageno-103) )ie ulimit -s 16384
(Test the results, but do not stop at errors
but
root:/sources/gcc-build#make -k check
giving errors
make[2]:***[check] error 127
make[1]:***[check-fxincludes] error2
i moved further(but do not stop at errors
-----------------------------------------------------------------
4)and
6.49. Make-3.82 (pageno-167)
root[:/sources/make-3.82#make
result is full of errors
i tred hole chapter 6(till 6.49),echo $LFS
ITS NOT GIVING ANY result

what i am doing mistake
plz tell me

Last edited by janakiramulu; 04-20-2011 at 05:57 AM.
 
Old 04-29-2011, 05:19 AM   #42
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
7.8. The Bash Shell Startup Files

hi druuna
i learned little,i back with success of chapter 6
now @ 7.8. The Bash Shell Startup Files

cat > /etc/profile << "EOF"
# Begin /etc/profile
export LANG=<ll>_<CC>.<charmap><@modifiers>
# End /etc/profile
EOF
-------------------------------------
what i have to use(mine is country' india',language 'english',what about charmap and modifier in my case)

<ll> below with the two-letter code for the desired language (e.g., “en”) and
<CC> with the two-letter code for the appropriate country (e.g., “GB”).
<charmap> should be replaced with the canonical charmap for your chosen locale.
Optional modifiers such as “@euro” may also be present.

is it necessary to use exact our country code and other things
if i use defaultanything ,can we cnange later
does it effect on anything further
(if you need i will ouput of locale -a )

Last edited by janakiramulu; 04-29-2011 at 05:24 AM.
 
Old 04-29-2011, 05:31 AM   #43
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
i am attaching below locale -a result
and
my system is all
hp-Hewlett-Packard INDIAN COMPANY (desktop,keyboard,everything)
Attached Files
File Type: txt locale result.txt (7.5 KB, 2 views)
 
Old 04-29-2011, 08:17 AM   #44
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,
I do believe India has more then one possible locale setting. These came up (there might be more):
Quote:
hi_IN - Hindi is the official languages of the Indian Union Government and of many states in India.
mr_IN - Marathi language spoken by the Marathi people of western and central India.
en_IN - English (default) spoken and used by the Government and Business in India.
If you want to set your local locale you probably need one of those.

Examples:
Code:
export LANG=hi_IN.utf8

export LANG=en_IN
You can omit this step, English (or more precise POSIX) will then be used. It is possible to change this at a later point.

Do read the part in the book about using UTF-8!

Hope this helps.

Last edited by druuna; 04-29-2011 at 02:39 PM.
 
Old 04-29-2011, 11:38 PM   #45
janakiramulu
Member
 
Registered: Jan 2011
Location: mangalore
Distribution: ubuntu
Posts: 167

Original Poster
Rep: Reputation: 0
hi druuna
thanks for reply
i done following
root:/sources# LC_ALL=en_IN.utf8 locale charmap
UTF-8
root:/sources# LC_ALL=en_IN.utf8 locale language
English
root:/sources# LC_ALL=en_IN.utf8 locale charmap
UTF-8
root:/sources# LC_ALL=en_IN.utf8 locale int_curr_symbol
INR
root:/sources# LC_ALL=en_IN.utf8 locale int_prefix
91
---------------------
root:/sources# cat > /etc/profile << "EOF"
> # Begin /etc/profile
>
> export LANG=en_IN.utf8 INR
> # End /etc/profile
> EOF

(there LC_ALL output is in all capital letters,but in above cat command i used small is it fine)
i am giving above what i got on terminal ,while doing above steps
 
  


Reply

Tags
lfs, permission, user


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] chown: changing ownership of `<file>': Operation not permitted schuurs Linux - General 14 06-26-2013 05:15 PM
5.32. Changing Ownership - Operation not permitted basheer Linux From Scratch 6 05-17-2012 04:57 AM
changing ownership of 'file name' : operation not permitted Virgil B Linux - Newbie 9 10-15-2010 05:16 PM
chmod: changing permissions of `public_html': Operation not permitted painterj Linux - Newbie 11 04-09-2010 09:40 PM
failed to preserve ownership operation not permitted yogks Linux - Software 1 11-27-2008 04:54 PM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration