LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 01-11-2005, 11:38 PM   #1
himm
LQ Newbie
 
Registered: Sep 2004
Posts: 21

Rep: Reputation: 15
can't find my /dev/hda* partitions...


Hi, I've just done a LFS 6.0 stable installation. There were no apparent errors. However, when I reboot and start the LFS system, it doesn't find my swap and home partitions!

swapon: cannot stat /dev/hda2 : no such file or directory
mount: special device /dev/hda3 does not exist
[....]
Setting lfs as hostname <hangs here>

My partitioning scheme:
hda1 vfat /windows
hda2 swap swap
hda3 reiserfs /home
hda5 reiserfs /suse (my host)
hda6 reiserfs /

My fstab:
/dev/hda6 / reiserfs defaults 0 0
/dev/hda2 swap swap pri=42 0 0
/dev/hda3 /home reiserfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devpts /dev/pts devpts gid=4,mode=620 0 0
shm /dev/shm tmpfs defaults 0 0

My SUSE fstab, which works in SUSE:
/dev/hda5 / reiserfs acl,user_xattr 0 0
/dev/hda6 /mnt/lfs auto defaults 0 0
/dev/hda3 /home reiserfs acl,user_xattr 0 0
/dev/hda1 /windows/C vfat users,gid=users,umask=0002 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/samsungcdr subfs user,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/cdrecorder11 /media/hpdvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Grub:
kernel (hd0,5)/boot/lfskernel root=/dev/hda6

So I logged back into SUSE, chrooted and looked in LFS's /dev folder. There was nothing except for /dev/null and /dev/console. So I mknod'ed hda1-6. Mounting under the chrooted environment works fine now and is automatic.

However, it still doesn't work under the real LFS system.

I've tried the option devfs=nomount and it does nothing. I don't remember enabling devfs in the kernel. I certainly do have udev programs installed. My IDE drivers are not modules, and I made sure to compile the reiserfs drivers into the kernel (not as modules). What could I be doing wrong?

Where exactly in the kernel make menuconfig is the devfs/udev enable/disable option? I might not have disabled devfs properly. However, I don't seem to have /dev/tty/ et al on the / partition and wonder if devfs is actually the problem here.

Also, LFS *does* detect my / (/dev/hda6) partition automatically. The terminal spits out the normal messages: that the system found reiserfs format "3.6" with standard journal, using ordered data mode, etc. But it does not detect my /home partition, which is also reiser.

Help appreciated.
 
Old 01-12-2005, 01:20 AM   #2
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
sounds like devfs didnt compile right or isnt started right. /dev should be full of block devices including tty* and hd*
 
Old 01-12-2005, 02:48 AM   #3
himm
LQ Newbie
 
Registered: Sep 2004
Posts: 21

Original Poster
Rep: Reputation: 15
So I should reinstall udev? How do I populate the /dev folder again?
 
Old 01-12-2005, 02:53 AM   #4
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
/dev is initially built during the install of the OS after that the /dev is mounted during the init with mount devfs

So I think you should reinstall it and make sure you reformat the partitions to make sure nothing is left from the old.
 
Old 01-12-2005, 06:33 PM   #5
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Quote:
Originally posted by himm
So I should reinstall udev? How do I populate the /dev folder again?
That may help. Udev creates the nodes the kernel needs in /dev automatically during the boot process. Are you sure you compiled support for reiserfs into your kernel? And did you do the sed on the kernel source before you compiled it?
Code:
sed -i 's@/sbin/hotplug@/bin/true@' kernel/kmod.c
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/hda under lilo.conf even thoug my HD is under /dev/hdb Basel Slackware 8 10-27-2005 06:00 PM
Cannot find DVD-Burner (/dev/hda) logosys Linux - Hardware 6 07-24-2005 08:14 PM
Suse 9.1 Won't Find scsi partitions (/dev/s*) yourexhalekiss Suse/Novell 1 05-08-2005 10:06 AM
How can I boot either one of my hard drives /dev/hda or /dev/hdb, I have RH9 and FC2 omogunkristi Linux - General 1 06-21-2004 05:11 AM
fdisk returns "unable to find /dev/hda" cfdisk crashes. cirofren Linux - Newbie 2 11-06-2003 12:03 AM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration