Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 07-17-2011, 02:28 AM   #1
LQ Newbie
Registered: Apr 2006
Location: Belgium, Antwerp City
Distribution: Slackware 10.2
Posts: 6

Rep: Reputation: 0
Boot Msg : Setting up Linux console... [ FAIL ]

(Using lfslivecd-x86-6.3-r2160)

As the title says, I've got a small problem at boot, however the system continues to boot normally without any further problems, I end up with a wrong keyboard layout ( querty instead of azerty ).
I've been trying to look what went wrong, but can't seem to get it solved.

Here are some parts of the my configuration values:

KEYMAP="be-latin1 euro2"
FONT="lat0-16 -m 8859-15"

# I also quicklly tried these, tough I always used the above in the past with succes
FONT="lat0-16 -m 8859-15"
export LANG=nl_BE@euro
(Chapter 8.3) linux- kernel compiled with :
export LANG=nl_BE@euro
make LANG=$LANG LC_ALL=POSIX menuconfig
# tough I'm not sure I did set LC_ALL=POSIX in the past, 
# could be I left this one blank before.
btw, I use LC_ALL=POSIX to surpress the translations,
( try searching for solutions in none-english, good luck ).

This has always worked in the past, but not now, does someone know what the problem could be and if there is a solution to 'quick-fix' this issue,
( this is being build on a system with a 400mhz cpu, so it would be very time consuming to start again from... scratch )

Thanks at front,
Old 08-01-2011, 01:59 PM   #2
LQ Newbie
Registered: Jul 2011
Location: Germany
Distribution: W2k, LFS
Posts: 17

Rep: Reputation: 2
Looking at the title
Originally Posted by R3D
Setting up Linux console... [ FAIL ]
it seems, something goes wrong while your system
is running /etc/rc.d/init.d/console.

So you could put some debugging code there, to find out what is happening in more detail.
(And remove it, once you solved the problem.)

I believe echo will work nicely there.
Old 08-02-2011, 01:23 AM   #3
LQ Newbie
Registered: Jul 2011
Location: South Carolina, USA
Distribution: LFS
Posts: 6

Rep: Reputation: Disabled
Chapter 6.47 has a note for installing Kbd-1.12

For some languages (e.g., Belarusian) the Kbd package doesn't provide a useful keymap where the stock “by” keymap assumes the ISO-8859-5 encoding, and the CP1251 keymap is normally used. Users of such languages have to download working keymaps separately.
Not sure if this applies to you or not, if it does you might not of installed your keymap, because it was not included by default.

Hope this helps.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
I cannot boot up ubuntu..i get a weird msg(pic of the msg included) please help :( debz480 Linux - Newbie 3 09-12-2010 01:45 AM
I Fail At Setting Up A Boot Loader electronblue019 Linux - Software 3 02-16-2006 12:03 PM
random msg in gnome-console maginotjr Slackware 1 07-07-2005 03:14 PM
setting console boot resolution Gill Bates Linux - Newbie 2 09-10-2003 03:54 PM

All times are GMT -5. The time now is 02:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration