LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Book 6.8 -6.42- Installing Gettext (http://www.linuxquestions.org/questions/linux-from-scratch-13/book-6-8-6-42-installing-gettext-905315/)

mreff555 09-27-2011 07:30 PM

Book 6.8 -6.42- Installing Gettext
 
I'm getting this error during the make check.

PHP Code:

/bin/sh ../libtool  --tag=CC   --mode=link gcc -std=gnu99  --O2   -o msgcmp msgcmp-msgcmp.o msgcmp-msgl-fsearch.o libgettextsrc.la  -lm  
libtool
linkcannot find the library `/mnt/lfs/sources/gettext-0.18.1.1/gettext-tools/gnulib-lib/libgettextlib.la' or unhandled argument `/mnt/lfs/sources/gettext-0.18.1.1/gettext-tools/gnulib-lib/libgettextlib.la'
make[3]: *** [msgcmp] Error 1
make[3]: Leaving directory `/sources/gettext-0.18.1.1/gettext-tools/src'
make[2]: *** [checkError 2
make
[2]: Leaving directory `/sources/gettext-0.18.1.1/gettext-tools/src'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory 
`/sources/gettext-0.18.1.1/gettext-tools'
make: *** [check-recursive] Error 1
root:/sources/gettext-0.18.1.1# ^C
root:/sources/gettext-0.18.1.1# 


Of course I already check to make sure the actual file is there. Any ideas?

druuna 09-28-2011 12:43 AM

Hi,

You say you are doing chapter 6.42, but I do see the following: /mnt/lfs/sources/gettext-0.18.1.1/gettext-tools/gnulib-lib/libgettextlib.la.

$LFS (/mnt/lfs) isn't used any more once you start chapter 6 (from 6.4 - Entering the Chroot Environment onward) .

I'm not sure how that got in there and why it shows up this far into chapter 6, but that is the problem you need to solve.

Hope this helps.

mreff555 09-28-2011 06:25 AM

really? thats odd.

well then I guess I'll just skip it and move on.

druuna 09-28-2011 06:34 AM

Hi,
Quote:

Originally Posted by mreff555 (Post 4484334)
well then I guess I'll just skip it and move on.

Skip it? Don't you want to fix the problem?

mreff555 09-29-2011 06:38 AM

I guess I'm misunderstanding the previous post. I thought it wasn't used anymore.

druuna 09-29-2011 07:06 AM

Hi,

I was talking about $LFS. It ($LFS) is used up to chapter 6.4. In chapter 6.4 you enter the chrooted environment, which eliminates the /mnt/lfs part.

Although I don't know how, I'm guessing you provided it yourself somewhere down the line. You either set and used LFS or provided /mnt/lfs by hand.

Hope this helps.

mreff555 09-29-2011 04:13 PM

Whoops, my bad I must have configured it in the wrong terminal.

regardless I started get again from scratch. I'm still getting one error

PHP Code:

SKIPxgettext-glade-1
Skipping test
xgettext was built without Glade support
SKIP
xgettext-glade-2
Skipping test
xgettext was built without Glade support
SKIP
xgettext-glade-3
xgettext
Language "glade" is not supportedxgettext relies on expat.
          
This version was built without expat.
FAILxgettext-glade-

I installed expat and I still run in to the same problems. I just did the default config for expat. Do I need to specify where the libraries are?

mreff555 09-29-2011 09:40 PM

Arrrrggggg.....

So the expat libraries are in /usr/local/lib
Code:

root:/sources/gettext-0.18# ls /usr/local/lib/
libexpat.a  libexpat.la  libexpat.so  libexpat.so.1  libexpat.so.1.5.2

I removed the build directory completely, re-extracted and used the following syntax for the config.

Code:

./configure --prefix=/usr --docdir=/usr/share/doc/gettext-0.18.1.1 --with-libexpat-prefix=/usr/local/lib
and I'm still getting the exact same error.

Code:

Skipping test: xgettext was built without Glade support
SKIP: xgettext-glade-1
Skipping test: xgettext was built without Glade support
SKIP: xgettext-glade-2
Skipping test: xgettext was built without Glade support
SKIP: xgettext-glade-3
xgettext: Language "glade" is not supported. xgettext relies on expat.
          This version was built without expat.
FAIL: xgettext-glade-4

Any suggestions?

Thanks

druuna 09-30-2011 01:00 AM

Hi,

Quote:

I installed expat and I still run in to the same problems. I just did the default config for expat.
Expat isn't build in LFS. It is part of BLFS, but you do not need it to build LFS. Why did you decide to build it and how did you build it?

I never encountered this error myself while building LFS 6.8 (yes, I do run the tests). Are you sure you didn't make any typo's/mistakes in any of the previous steps/chapters?

Although I'm not sure what else you added/changed: If the expat/glade test error is the only error you get I would continue.

BTW: If you need to add/change the options given in the book then something is wrong. Either the package you are currently building didn't go as planned or on of the previous packages didn't.
Adding/changing stuff might solve the problem at hand, but it might also get you into trouble later on during the build!

Hope this helps.

Jon Wilder 07-31-2015 11:43 PM

I realize this is an old thread, but I happened to stumble upon it while I was looking for a solution to the same issue. Here's a quick and dirty fix to get around this error.

On the LFS system you should have no directories inside of the main /mnt directory. Since the compiler is looking for the path /mnt/lfs for some reason, we can fake that path via a symlink.

Execute -

Code:

root /sources/gettext-0.19.4# ln -sv / /mnt/lfs
This will create the symlink /mnt/lfs, which will point to the LFS system's actual root directory, which is what it is really expecting to find. I just tried this on my system and gettext is now happily compiling.

Keith Hedger 08-01-2015 05:23 PM

not only is this thread 4 years old no one should be using version 6.8 of the book.

mreff555 08-03-2015 08:13 AM

While this issue was never solved, the thread is far too old to be relevant and not a lot of good information was captured. If you have a similar problem, start a new thread.


All times are GMT -5. The time now is 04:51 PM.