LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 04-21-2005, 04:05 AM   #1
vmlinuz101
Member
 
Registered: Mar 2005
Location: Ireland
Distribution: LFS, SuSE, Debian, gentoo
Posts: 93

Rep: Reputation: 15
BLFS Xorg problem


Hello there. I'm having serious trouble with Xorg 6.8.1 in BLFS-6.0. The package built fine, but when I ran Xorg -configure I had 2 problems.
The first deals with an NVIDIA module. I had installed the latest NVIDIA driver and it built itself as a kernel module. Now I can't remove it, even though I recompiled. Xorg complains that this module can not be found

(EE) NVIDIA(0): Failed to load the NVIDIA kernel module

The second problem refers to the mouse.

Xorg complains that it was unable to detect the mouse. I tried amending xorg.conf to set the input device to /dev/input/mice or to /dev/input/psaux or to /dev/input/mouse0 but every time I redid Xorg -configure the xorg.conf file changes back to normal.

I since switched to using xorgconf, which did work after I used nearly all default values. I was presented with a default X screen with 2 xterm windows, etc. I then tried to build the TTF fonts like it says in the X Window Configuration chapter. To no avail. Running glxgears reports errors loading the display. I am now aware that I need an extra su - to make install under X. I had, at this point, already built KDE 3.4.0 and even got to the stage where it let you configure KDE for language, screen settings, etc., and got the spash screen. Then nothing. Completely frozen in an X window.

I am sorry about the length of the post, but I thought maybe to explain myself fully. Has anyone noticed anything similiar, and would anyone know what I should do now?

Thanks in advance,

Donal
 
Old 04-21-2005, 09:50 AM   #2
TruckStuff
Member
 
Registered: Apr 2002
Posts: 498

Rep: Reputation: 30
OK, lets KISS. You are all over the place with this, so simplify things and address one issue at a time. I'll try and wade through the mass of information, so please correct me if I have missed something. It sounds like you have at least four different problems here:

1) Nvidia driver not working correctly (just got done fixing this myself)
2) Mouse not working
3) X not installing
4) TTF fonts not working

Quote:
I am now aware that I need an extra su - to make install under X.
So does this mean that you do or do not have X installed correctly? If you do NOT have X installed correctly, you need to start here. Make sure you follow the BLFS instructions EXACTLY.
Quote:
Xorg complains that it was unable to detect the mouse. I tried amending xorg.conf to set the input device to /dev/input/mice or to /dev/input/psaux or to /dev/input/mouse0 but every time I redid Xorg -configure the xorg.conf file changes back to normal.
So is your mouse working or not? If it is not, what kind of mouse is it? That usually determines where the mouse input should be coming from. A good idea would be to look at the xorg.conf file on the host system that you used to build your LFS install and use that as a guide to editing your xorg.conf file on the BLFS system.
Quote:
I then tried to build the TTF fonts like it says in the X Window Configuration chapter. To no avail.
What does this mean? What happened when you installed X? Have you installed Freetype1/2? Did they install correctly? Do you actually have TTF fonts installed? How do you know TTF fonts aren't working?
Quote:
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module
Look in your /var/log/Xorg.0.log file. That will give you more details as to exactly what is going on with this. However, this is the *last* of your worries right now.

IMHO, you need to address the issues in the following order:

1) Get X installed.
2) Get your mouse working.
3) Get TTF fonts working
4) Get the Nvidia driver working.
 
Old 04-21-2005, 10:38 AM   #3
vmlinuz101
Member
 
Registered: Mar 2005
Location: Ireland
Distribution: LFS, SuSE, Debian, gentoo
Posts: 93

Original Poster
Rep: Reputation: 15
Thanks for the reply, TruckStuff. X works and so does the mouse after I did xorgconfig. In xorgconfig, the nv driver was used. Everything was grand at this point. I just did startx and up popped an X screen with 2 xterm windows. I can even run Opera perfectly from here, and my mouse is fine too, configured with /dev/input/mice as the input device. However, when I tried to start KDE, I got as far as the spash screen (starting interprocess communications, ..., up as far as the 'loading the desktop' and then I took the bullet) I was advised to make sure that I'd correctly installed the TTF fonts.

I thought I had at least. I got freetype and also the freefonts and installed them. Now, doing a glxgears command says the display cant be loaded. Is this why KDE isn't working, or is there some other fundamental proble (besides what's between the chair and the keyboard)?
 
Old 04-21-2005, 10:53 AM   #4
TruckStuff
Member
 
Registered: Apr 2002
Posts: 498

Rep: Reputation: 30
glxgears is completely unrelated to TTF. glxgears is for checking your 3D performance with the video card. If you have questions about whether or not TTF is working, you probably need to reinstall X. Also FWIW, this is more likely a KDE issue than an X issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BLFS][xffm-4.2.2] problem compiling. mr_demilord Linux From Scratch 10 10-24-2005 06:42 AM
[BLFS] Problem installing GConf-2.10.0 mr_demilord Linux From Scratch 1 10-15-2005 11:17 PM
BLFS 6.1 Xorg-6.8.2 creating 'host.def' help needed. kagashe Linux From Scratch 2 10-06-2005 12:58 AM
problem in blfs sharmashikha Linux From Scratch 1 08-08-2005 12:37 AM
kde problem after finishing BLFS. Axion Linux From Scratch 2 06-12-2004 02:52 AM


All times are GMT -5. The time now is 12:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration