LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices



Reply
 
Search this Thread
Old 03-10-2013, 04:21 AM   #1
aashayshah
Member
 
Registered: Sep 2012
Location: India
Distribution: Linux Mint 13 (Maya)
Posts: 53

Rep: Reputation: 1
BLFS ,error: xproto package not found while compiling makedepend-1.0.4


I have started with X windowing system , i have installed util-macros and xorg protocol headers .

I went further to install makedepend-1.0.4 but i see the following error:

Package xorg-macros was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-macros.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-macros' found
checking return type of signal handlers... void
checking for rename... yes
checking for fchmod... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for X... configure: error: Package requirements (xproto) were not met:

No package 'xproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables X_CFLAGS
and X_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
 
Old 03-10-2013, 04:49 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
This seems to be a PKG_CONFIG_PATH problem.

The Introduction to Xorg-7.7 chapter needs to be done very carefully.

For one: What did you choose as XORG_PREFIX? If you did not choose for /usr, did you also do the extra parts:
Quote:
If you've decided to use the standard /usr prefix, you can omit the remainder of this page. Otherwise, be sure to add $XORG_PREFIX/bin to your PATH environment variable, and $XORG_PREFIX/lib/pkgconfig and $XORG_PREFIX/share/pkgconfig to your PKG_CONFIG_PATH variable. Issue the following commands as the root user
A general tip: Also have a look at the User Notes: that are on the pages. Some of them contain valuable information.
 
Old 03-10-2013, 05:52 AM   #3
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Centos6.3/Debain
Posts: 1,762
Blog Entries: 1

Rep: Reputation: 245Reputation: 245Reputation: 245
Hi


Just a note I been here same prob
Druuna advised
Code:
echo $XORG_PREFIX
 
Old 03-10-2013, 08:25 AM   #4
Keith Hedger
Senior Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 1,000

Rep: Reputation: 218Reputation: 218Reputation: 218
Just an aside the xcb-util download needed by xorg seems to have disappeared I founs another copy here:
http://pkgs.fedoraproject.org/repo/p...-0.3.9.tar.bz2

I fact the Fedora or Slackware repos are always the first place I look for src code if I'm having trouble finding a package.
 
Old 03-10-2013, 08:35 AM   #5
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Another place to look for packages is the lfs site itself:

- ftp.lfs-matrix.net -> blfs

For example, these xcb-util versions are available atm; xcb-util

There's also a lfs section:

- ftp.lfs-matrix.net -> lfs
 
1 members found this post helpful.
Old 03-10-2013, 10:07 AM   #6
aashayshah
Member
 
Registered: Sep 2012
Location: India
Distribution: Linux Mint 13 (Maya)
Posts: 53

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by druuna View Post
This seems to be a PKG_CONFIG_PATH problem.

For one: What did you choose as XORG_PREFIX? If you did not choose for /usr, did you also do the extra parts:

.
there was a problem with XORG_PREFIX and i corrected it . After correcting it i configured util-macros-1.17 but i get a warning :


configure: WARNING: unrecognized options: --disable-static

why such a warning ??
 
Old 03-10-2013, 10:14 AM   #7
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Quote:
Originally Posted by aashayshah View Post
there was a problem with XORG_PREFIX and i corrected it .
What was the problem and how did you fix it?
Quote:
After correcting it i configured util-macros-1.17 but i get a warning :

configure: WARNING: unrecognized options: --disable-static
It shouldn't give the warning, but I cannot tell you why without some extra information.

What is the output of the following commands:
Code:
echo $XORG_PREFIX

# and

echo $XORG_CONFIG

# and

cat /etc/profile.d/xorg.sh
EDIT: See post #8 and #9

Last edited by druuna; 03-10-2013 at 10:20 AM. Reason: Oops......
 
Old 03-10-2013, 10:15 AM   #8
Keith Hedger
Senior Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 1,000

Rep: Reputation: 218Reputation: 218Reputation: 218
Quote:
Originally Posted by aashayshah View Post
...configure: WARNING: unrecognized options: --disable-static...
Just a warning that the configure script does not recognize this option it will be ignored.
 
2 members found this post helpful.
Old 03-10-2013, 10:18 AM   #9
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Keith Hedger is correct. I though this options was part of util-macros, it is not (just checked).

I edited my previous reply to correct my error.
 
Old 03-10-2013, 10:20 AM   #10
aashayshah
Member
 
Registered: Sep 2012
Location: India
Distribution: Linux Mint 13 (Maya)
Posts: 53

Original Poster
Rep: Reputation: 1
for drunna's post #7 ...

Problem was that i did not read the chapter carefully and did not set up variables at all ....

So after setting up variables XORG_PREFIX and XORG_CONFIG I went futher to compile util-macros...

Output for XORG_PREFIX is /usr

Output for XORG_CONFIG is --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static

Output for cat /etc/profile.d/xorg.sh is XORG_PREFIX="/usr"
XORG_CONFIG="--prefix=$XORG_PREFIX \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static"
export XORG_PREFIX XORG_CONFIG
 
Old 03-10-2013, 10:22 AM   #11
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
@aashayshah: Ignore the warning, as stated by Keith Hedger in post #8
 
Old 03-10-2013, 10:25 AM   #12
aashayshah
Member
 
Registered: Sep 2012
Location: India
Distribution: Linux Mint 13 (Maya)
Posts: 53

Original Poster
Rep: Reputation: 1
Again a problem ,

a very short output for .configure $XORG_CONFIG && make

configure: WARNING: unrecognized options: --disable-static
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
configure: creating ./config.status
config.status: creating xorg-macros.pc
config.status: creating Makefile
config.status: creating xorg-macros.m4
configure: WARNING: unrecognized options: --disable-static
make: Nothing to be done for `all'.


Is everything all-right ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"pkg-config not found" error when trying to build makedepend (needed for Xorg). Quon Linux From Scratch 1 11-14-2011 09:27 PM
install libX11 error! (xproto) totallybored Linux - Software 6 11-18-2010 04:46 AM
[SOLVED] Package xproto was not found in the pkg-config search path. shitou Linux - Kernel 1 10-18-2010 11:39 AM
gmake: makedepend: Command not found mflorea Linux - Newbie 3 06-02-2008 04:38 PM
error when compiling vim 6.1 in BLFS NeoAnderson Linux From Scratch 0 06-09-2003 07:39 AM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration