LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   blfs 6.3 grahics (http://www.linuxquestions.org/questions/linux-from-scratch-13/blfs-6-3-grahics-802309/)

aahiqmir 04-15-2010 10:54 PM

blfs 6.3 grahics
 
Hi,guys.

I have a couple of questions.

1. Can I carry on with BLFS6.3 over LFS6.4?
2. IF yes, Then how Can I get Graphical Environment working with min. no of packages to install.
yes of course with mouse support,so that i can browse pdf book.


Please help. That will be greatly appreciated.

thanks

druuna 04-16-2010 01:20 AM

Hi,

Quote:

1. Can I carry on with BLFS6.3 over LFS6.4?
Yes you can. If anything needs to be done differently it will be mentioned in the user notes link provided.

Quote:

2. IF yes, Then how Can I get Graphical Environment working with min. no of packages to install.
As you might have noticed already, BLFS is a collection of software and unlike LFS you decide what is installed and what is not installed.

If you are looking for a specific piece of software you go to that chapter and look what the dependencies are. Some are required and some are optional, the latter is up to you if you need/want them. You also need to check if the dependencies have dependencies.

Example: If you need Tripwire-2.4.1.2 you need to install OpenSSL-0.9.8g first. OpenSSL has an optional dependency: bc-1.06 (it is up to you to [not] install it).

Hope this helps.

aahiqmir 04-19-2010 05:19 AM

Quote:

Originally Posted by druuna (Post 3937220)
Hi,

Yes you can. If anything needs to be done differently it will be mentioned in the user notes link provided.

As you might have noticed already, BLFS is a collection of software and unlike LFS you decide what is installed and what is not installed.

If you are looking for a specific piece of software you go to that chapter and look what the dependencies are. Some are required and some are optional, the latter is up to you if you need/want them. You also need to check if the dependencies have dependencies.

Example: If you need Tripwire-2.4.1.2 you need to install OpenSSL-0.9.8g first. OpenSSL has an optional dependency: bc-1.06 (it is up to you to [not] install it).

Hope this helps.

thanks for Help.

I am not able to install gpm package to have mouse support.

when try to run make i get errors

what can i do?

thanks.

druuna 04-19-2010 07:19 AM

Hi,

Quote:

I am not able to install gpm package to have mouse support.

when try to run make i get errors

what can i do?
Without knowing what the errors are and when these errors showed up it is not possible to answer this question.

- which part of the process failed (configure/make/make install)?
- post the error(s),
- did the patching go ok?
- did you have a look at the User Notes?
- did you deviate from the book in any way?

Please supply the appropriate information so we can possibly help.


All times are GMT -5. The time now is 07:18 PM.