LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   BinUtils: The system has no more ptys. Ask your system administrator to create more. (http://www.linuxquestions.org/questions/linux-from-scratch-13/binutils-the-system-has-no-more-ptys-ask-your-system-administrator-to-create-more-4175433996/)

ArchaicBlues 10-25-2012 06:17 AM

BinUtils: The system has no more ptys. Ask your system administrator to create more.
 
Hallo all,
installation of BinUtils-2.22 within chapter 2.13 failed for me in the chroot environment:

root:/# expect -c "spawn ls"
spawn ls
The system has no more ptys. Ask your system administrator to create more.
while executing
"spawn ls"

When I change to root and later to lfs it seems to be ok:
root@debian:~# expect -c "spawn ls"
spawn ls
root@debian:~# exit
logout
lfs@debian:~$ expect -c "spawn ls"
spawn ls
lfs@debian:~$


I read similar threads, but could not find the problem yet..
Any suggestions are very welcome..
Thanks!

spiky0011 10-25-2012 12:27 PM

Hi

Have a look http://www.linuxfromscratch.org/lfs/faq.html#no-ptys

Keith Hedger 10-25-2012 01:31 PM

Don't forget to add this line to youe /etc/fstab:

devpts /dev/pts devpts gid=4,mode=620 0 0

And create a folder in /lib/udev/devices called pts

Also I have this in my kernel config:

CONFIG_UNIX98_PTYS=y
CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=256

My Kernel version is 3.5.2
And it all seems automatic with this config.

ArchaicBlues 10-27-2012 03:37 AM

Sorry, I meant chapter 6.13...

I went thru http://www.linuxfromscratch.org/lfs/faq.html#no-ptys
and could not find a solution. My kernel version is 2.6.32-5-686
and the two Parameters
CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=256
has not been set. Do I need to recompile the kernel now?

I see, that I messed up with gcc here, so I have to solve that first...


root@debian:~# bash version-check.sh
bash, version 4.2.36(1)-release
/bin/sh -> /bin/bash
Binutils: (GNU Binutils) 2.22
bison (GNU Bison) 2.4.1
/usr/bin/yacc -> /usr/bin/bison.yacc
bzip2, Version 1.0.6, 6-Sept-2010.
Coreutils: 8.19
diff (GNU diffutils) 3.2
find (GNU findutils) 4.4.2
GNU Awk 4.0.1
/usr/bin/awk -> /usr/bin/gawk
gcc (GCC) 4.7.1
(GNU libc) 2.16
grep (GNU grep) 2.14
gzip 1.5
Linux version 2.6.32-5-686 (Debian 2.6.32-41squeeze2) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Mon Mar 26 05:20:33 UTC 2012
m4 (GNU M4) 1.4.16
GNU Make 3.82
patch 2.6.1
Perl version='5.16.1';
GNU sed version 4.2.1
tar (GNU tar) 1.26
Texinfo: makeinfo (GNU texinfo) 4.13
xz (XZ Utils) 5.0.4
/mnt/lfs/tools/bin/../lib/gcc/i686-pc-linux-gnu/4.7.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgcc_s
collect2: error: ld returned 1 exit status
gcc compilation failed

druuna 10-27-2012 03:52 AM

A few things I noticed:

1) Did you run the expect -c "spawn ls" command from within the chrooted environment? You should.

2) I see you use Debian as host, which does not suffer from this problem (I've been using Debian as host for a long time and never ran into this. I did on older Slackware versions).

3) In post #4 you post the output from the version-check.sh script. Is this done from within the chrooted environment or from your host? This version-check.sh script should be run from your host before starting with LFS. There's no point in running it from the chrooted environment. I'm asking because of this:
Code:

/mnt/lfs/tools/bin/../lib/gcc/i686-pc-linux-gnu/4.7.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgcc_s
The bold points to a LFS setting.

4) If, at any point, you stopped and started again: Did you remount the virtual file system and populate /dev again before entering the chrooted environment? (6.2.2 and 6.2.3).

ArchaicBlues 10-27-2012 04:18 AM

Thanks alot!
The problem has been solved, since I didn't remount the virtual file system and populate /dev again before entering the chrooted environment...

druuna 10-27-2012 04:21 AM

You're welcome :)

BTW: Can you put up the [SOLVED] tag.
first post -> Thread Tools -> Mark this thread as solved


All times are GMT -5. The time now is 11:39 AM.