LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Binutils "make " command is running continuously for more than an hour .. (http://www.linuxquestions.org/questions/linux-from-scratch-13/binutils-make-command-is-running-continuously-for-more-than-an-hour-902427/)

dgashu 09-11-2011 07:23 AM

Binutils "make " command is running continuously for more than an hour ..
 
Hi All,
I am installing Binutils on my SUSE Distro.....
The make command which i have given after ./configure command runs continuously .And i have to manually terminate the instruction .....IT IS NOT COMPLETING THE DESIRED ACTION .

1) ./configure command gives the following o/p:-
Code:

checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-lfs-linux-gnu
 
checking whether ln works... yes
checking whether ln -s works... yes
checking for a sed that does not truncate output... /bin/sed
checking for gawk... gawk
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking for gnatbind... no
checking for gnatmake... no
checking whether compiler driver understands Ada... no
checking how to compare bootstrapped objects... cmp --ignore-initial=16 $$f1 $$f2
checking for objdir... .libs
checking for version 0.10 (or later revision) of PPL... no
checking for default BUILD_CONFIG...
checking for bison... no
checking for byacc... no
checking for yacc... no
checking for bison... no
checking for gm4... no
checking for gnum4... no
checking for m4... no
checking for flex... no
checking for lex... no
checking for flex... no
checking for makeinfo... no
checking for expect... no
checking for runtest... no
checking for ar... ar
checking for as... as
checking for dlltool... no
checking for ld... (cached) /usr/lib/gcc/i586-suse-linux/4.5/../../../../i586-suse-linux/bin/ld
checking for lipo... no
checking for nm... nm
checking for ranlib... ranlib
checking for strip... strip
checking for windres... no
checking for windmc... no
checking for objcopy... objcopy
checking for objdump... objdump
checking for i686-lfs-linux-gnu-cc... no
checking for i686-lfs-linux-gnu-gcc... no
checking for i686-lfs-linux-gnu-c++... no
checking for i686-lfs-linux-gnu-g++... no
checking for i686-lfs-linux-gnu-cxx... no
checking for i686-lfs-linux-gnu-gxx... no
checking for i686-lfs-linux-gnu-gcc... no
checking for i686-lfs-linux-gnu-gcj... no
checking for i686-lfs-linux-gnu-gfortran... no
checking for i686-lfs-linux-gnu-ar... no
checking for i686-lfs-linux-gnu-as... no
checking for i686-lfs-linux-gnu-dlltool... no
checking for i686-lfs-linux-gnu-ld... no
checking for i686-lfs-linux-gnu-lipo... no
checking for i686-lfs-linux-gnu-nm... no
checking for i686-lfs-linux-gnu-objdump... no
checking for i686-lfs-linux-gnu-ranlib... no
checking for i686-lfs-linux-gnu-strip... no
checking for i686-lfs-linux-gnu-windres... no
checking for i686-lfs-linux-gnu-windmc... no
checking where to find the target ar... just compiled
checking where to find the target as... just compiled
checking where to find the target cc... pre-installed
checking where to find the target c++... pre-installed
checking where to find the target c++ for libstdc++... pre-installed
checking where to find the target dlltool... just compiled
checking where to find the target gcc... pre-installed
checking where to find the target gcj... pre-installed
checking where to find the target gfortran... pre-installed
checking where to find the target ld... just compiled
checking where to find the target lipo... pre-installed
checking where to find the target nm... just compiled
checking where to find the target objdump... just compiled
checking where to find the target ranlib... just compiled
checking where to find the target strip... just compiled
checking where to find the target windres... just compiled
checking where to find the target windmc... just compiled
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether -fkeep-inline-functions is supported... yes
configure: creating ./config.status
config.status: creating Makefile

SHOULD ./configure command terminate at this line ?
or
there should me more lines ?


b) The make command shows the following O/P ....

Code:

CONFIG_SHELL="/bin/sh" /bin/sh ./config.status --recheck
running CONFIG_SHELL=/bin/sh /bin/sh ../binutils-2.21/configure --target=i686-lfs-linux-gnu --prefix=/tools --disable-nls target_alias=i686-lfs-linux-gnu --no-create --no-recursion
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-lfs-linux-gnu

+

O/P of ./configure command ..........continously


Can you please guide me what is the reason for this behavior ....
Thank You

knudfl 09-11-2011 10:07 AM

Installing binutils in Suse : 1) su 2) zypper in binutils-devel
.. And if you want to build any software : zypper in flex bison gcc-c++


Building an extra "alien binutils" :
Binutils requires a build directory outside the source folder:
tar xvf binutils-2.xx* && mkdir build && cd build/ &&
../binutils-2.xx/configure --prefix=/opt/extra-binutils/

Which version are you trying to build ? ? And why ?

Which Suse version are you using ? ?

..

business_kid 09-11-2011 10:13 AM

I'm guessing you are in a chroot after building chapter 5 and starting on chapter 6 builds.

The SBU lfs use is Static Binutils (build time) Unit. The longest I have ever seen that was 20 minutes. Most of the 'no' answers in your ./configure output should have been 'yeses' and you have a system incapable of building, or unable to find itself. It's running too long.

IIRC Binutils uses a binutils-build directory to do stuff in. So you run 'mkdir ../binutils build' from the binutils top source and 'cd ../binutils-build' and you run your configure from there.
../binutils-x.y.z/configure --blah
rm -rf on the binutils source, exit and reenter the chroot, and start _by_the_book_ from there. Did you mount /proc?

dgashu 09-12-2011 11:25 AM

Hi business kid,

I have just started chapter 5 , i have not reached chroot stage .
I am at BINUTILS pass 1 installation

Code:

The following is the steps i followed:-
1) cd /$LFS/sources (from lfs home )
2) untar the binutils 2.21 package
3) cd to binutils-2.21
4)mkdir ../binutils_build & cd ../binutils-build
5) run the command :-
  ../binutils-2.21/configure \
    --target=$LFS_TGT --prefix=/tools \
    --disable-nls --disable-werror
6) make

Now can u please let me know if i am doing any thing wrong here.....

dgashu 09-12-2011 11:29 AM

Hi knudfl,

Can you just let me know if i am doing any thing wrong , as i have mentioned the steps i followed ......

1) Which version are you trying to build ? ------ Binutils 2.21
2) And why ? ------------------------------------ I am trying to buils LFS 6.8
3) Which Suse version are you using ? ----------- I am using SUSE 11.3

please let me know if you require any other details .....
Thanks

knudfl 09-13-2011 12:06 AM

All "Host System Requirements" must be installed before you can build anything.
http://www.linuxfromscratch.org/lfs/.../hostreqs.html
http://www.linuxfromscratch.org/lfs/...equisites.html


# zypper in flex bison gcc-c++ make automake autoconf binutils-devel texinfo

The remaining basic packages on the list should already be present,
unless you removed something. But better check with the package list :
rpm -qa | sort > installed-packages.txt
( Saves the list in the current directory.)

..

dgashu 09-17-2011 12:03 PM

I have installed all the packages now ( except for the makeinfo in my laptop with suse ........I am yet to get the rpm package for the same ).
But i am still receiving the same error.

Now when i installed in the DESKTOP (with CENTOS ....it installed smoothly )
Manual inspection of ./configure showed me that :-
a) checking for ld... (cached) /usr/lib/gcc/i586-suse-linux/4.5/../../../../i586-suse-linux/bin/ld -----------> IN laptop + SUSE 11.3
checking for ld ..ld --------------------------------------------------------------------------------------------> IN desktop + CENTOS 6

b) checking for makeinfo... no -------------------------------------------------------------------------------------> In laptop + suse 11.3
checking for makeinfo... makeinfo -------------------------------------------------------------------------------> IN desktop + centos 6

Can any one let me know why there is difference in point a) or point a) is proper

Thanks

knudfl 09-17-2011 12:47 PM

/usr/bin/makeinfo/ :

Suse : # zypper in texinfo

CentOS6 : # yum install texinfo

.

dgashu 09-18-2011 01:13 AM

Now the ./configure o/p resembles on both the system.
But the issue with make command o/p remains as it is (Even after installing all the packages)


a) the make command o/p form DESKTOP + CENTOS is similar to :-
Code:

TEST:make
make[1]: Entering directory `/mnt/lfs/sources/binutils-build'
mkdir -p -- ./intl
Configuring in ./intl
configure: creating cache ./config.cache
checking whether make sets $(MAKE)... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether NLS is requested... no
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext

b) the make command o/p from Laptop + Suse is similar to :-
Code:

make: Warning: File `../binutils-2.21/Makefile.in' has modification time 6.9e+06 s in the future

CONFIG_SHELL="/bin/sh" /bin/sh ./config.status --recheck
running CONFIG_SHELL=/bin/sh /bin/sh ../binutils-2.21/configure --target=i686-lfs-linux-gnu --prefix=/tools --disable-nls target_alias=i686-lfs-linux-gnu --no-create --no-recursion
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-lfs-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for a sed that does not truncate output... /bin//sed

Can you please let me know what might be the reason for this behavior ............

knudfl 09-18-2011 08:23 AM

Suggest : Use the 'Report' button, and ask for the thread
to be moved to the LFS Forum.


Then the LFS specialists may read / answer your questions.

dgashu 09-18-2011 09:38 AM

Hi All ( knudfl , business_kid )
Solved the issue . Thanks for your valuable guidance.

So the end result is (The problem was seen due to ):-

a) In suse 11.3 by default following packages are missing so we need to install then first
Code:

    flex
    bison
    gcc-c++
    make
    automake
    autoconf
    binutils-devel

b) My system (Laptop time was not correct) ...hence the error of make command
Code:

  make: Warning: File `../binutils-2.21/Makefile.in' has modification time 6.9e+06 s in the future -------Line
which showed the path

Thanks (LOVE U LINUX ................LOLZ)

archtoad6 09-19-2011 06:06 AM

Moved: This thread is more suitable in Linux - Distributions > Linux From Scratch and has been moved accordingly to help your thread/question get the exposure it deserves.

BTW, good job dgashu, reporting your own thread. :)

archtoad6 09-19-2011 06:25 AM

Please use "Code:" blocks
 
Welcome to LQ, dgashu. I hope your time here helps you as much as mine has helped me.

If you're going to do LFS, then you may be posting a lot code & CLI output, so the following advice is especially important:

Please put code, command line output, config files, etc. inside [CODE] tags, aka "Code:" blocks.
There are 2 ways to generate "Code:" tags:
  1. You can simply type them yourself -- "[code] ... [/code]". (They are not case sensitive.)

  2. You can also click on the '#' icon above the text entry window. If you highlight the code, command line output, config files, etc. before you click the '#' icon, your code will get put inside a "Code:" block. The '#' icon is available when you start your post by clicking the "Post Reply" button or use the "Go Advanced" button under the Quick Reply window; it is not currenetly available in the Quick Reply window itself.

The [CODE] tags will make your posts easier to read, & that will get you more, faster, better answers. -- Help us help you.
BTW, You can edit your post(s) to do this retroactively. Please do so soon.

Thank you, & again, welcome.

druuna 09-19-2011 07:16 AM

Hi dgashu,

You initially double posted this question, one in the LFS forum and one in the Software forum. I was the one that reported those and suggested to close the one in LFS. Why? Because you original post did not mention anything that could be related to LFS and the thread mentioned building binutils on Suse.

Adding to archtoad6's advice: If you post an LFS related question please mention which LFS you are trying to build, which chapter you encounter the error(s). and which host you are using.

BTW: Glad to see you got this fixed!

dgashu 09-20-2011 12:18 AM

Hi ,
Apologetic for the mistake . But i have now corrected them.
Will try not to repeat the same mistake .
Code:

I was trying LFS 6.8 on ( SUSE 11.3 & CentOS 6 ), chapter 5 .
Thanks all for your support ....


All times are GMT -5. The time now is 01:00 AM.