LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   bash woes (http://www.linuxquestions.org/questions/linux-from-scratch-13/bash-woes-22453/)

slack-penguin 06-03-2002 05:38 AM

bash woes
 
Well, just starting on lfs, and I can't really say that I have managed to get far :(

So far I am up to configuring bash, which I am having probs with. I run:
sh configure --enable-static-link --prefix=$LFS/usr \
--bindir=$LFS/bin --with-curses &&

and it spits out:

checking build system type... ./support/config.guess: ./dummy-1401: Permission denied
./support/config.guess: ./dummy-1401: Permission denied
configure: error: cannot guess build type; you must specify one

... and I don't have a clue what to give it.

Also, configure refuses to run (using ./configure) and I have checked the permissions (-rwxr-xr-x) and for #! /bin/sh and it still tells me bad interpreter Grrrrrrr...

Help?

slack-penguin 06-03-2002 05:58 AM

hmmm, interesting...

I found the problem... was the way the lfs partition was being mounted accorting to /etc/fstab :P

rather odd...

lfslinux 06-03-2002 06:18 AM

fstab probably contained the "user" or "users" option (so non-root can mount it). That option implies nodev,nosuid,noexec which pretty much means you can't create device file (such as ones found in /dev) can't create suid files and you cannot execute scripts or anything from it (such as configure scripts).

See the mount man page it's all explained in there.

Two ways around it:

1) remove 'user' or 'users' from /etc/fstab and only have user root do the mounting and umounting.

2) change the 'user' option to 'user,exec,suid,dev' which will allow any user to mount it, while not putting the other restrictions into place.

slack-penguin 06-05-2002 09:21 PM

Thanks for that, I've managed to solve a few other mount issues as well now :)

SmogFighter 06-07-2002 01:26 AM

configure not supported??
 
Sorry, but I am at that spot too and I get "Configure no longer supported"

HELP :confused:


All times are GMT -5. The time now is 11:13 PM.