LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (http://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   -bash: ../binutils-2.15.94.0.2.2/configure: No such file ordirectory (http://www.linuxquestions.org/questions/linux-from-scratch-13/bash-binutils-2-15-94-0-2-2-configure-no-such-file-ordirectory-344244/)

satimis 07-18-2005 07:38 AM

-bash: ../binutils-2.15.94.0.2.2/configure: No such file or directory
 
Hi folks,

LFS 6.1
FC3 Host

Continued on
5.3. Binutils-2.15.94.0.2.2 - Pass 1
http://www.linuxfromscratch.org/lfs/...ils-pass1.html

Fresh starting PC
[satimis@localhost ~]$ su -
Password:
[root@localhost ~]# export LFS=/mnt/lfs
[root@localhost ~]# mount /dev/hda6 $LFS
[root@localhost ~]# echo $LFS
/mnt/lfs
[root@localhost ~]# chown lfs $LFS/tools
[root@localhost ~]# chown lfs $LFS/sources
[root@localhost ~]# su - lfs
lfs:~$ mkdir ../binutils-build
mkdir: cannot create directory `../binutils-build': Permission denied

Here I was not allowed to proceed further because as 'user' of LFS. If ran either "su" or "su -" it only worked with the root password of FC3 Host and login as root of FC3 Host.

I tried follows;

[root@localhost ~]# cd /mnt/lfs/sources/
after extracting the relevant tarball
[root@localhost sources]# mkdir ../binutils-build
[root@localhost sources]# cd ../binutils-build
[root@localhost binutils-build]# ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls
-bash: ../binutils-2.15.94.0.2.2/configure: No such file ordirectory
[root@localhost binutils-build]#

However "/binutils-2.15.94.0.2.2/configure" was there. What will be the correct syntax? OR how to login as root of LFS

TIA

B.R.
satimis

kjordan 07-18-2005 07:47 AM

Well, it was meant to be run in the extracted binutils folder.

[lfs@localhost ~]# cd /mnt/lfs/sources
[lfs@localhost sources]# tar xvjf binutils-2.15.94.0.2.2.tar.bz2
[lfs@localhost sources]# cd binutils-2.15.94.0.2.2
[lfs@localhost binutils-2.15.94.0.2.2]# mkdir ../binutils-build
[lfs@localhost binutils-2.15.94.0.2.2]# cd ../binutils-build
[lfs@localhost binutils-build]# ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls

satimis 07-18-2005 10:37 AM

Hi kjordan,

Quote:

[lfs@localhost ~]# cd /mnt/lfs/sources
[lfs@localhost sources]# tar xvjf binutils-2.15.94.0.2.2.tar.bz2
[lfs@localhost sources]# cd binutils-2.15.94.0.2.2
[lfs@localhost binutils-2.15.94.0.2.2]# mkdir ../binutils-build
[lfs@localhost binutils-2.15.94.0.2.2]# cd ../binutils-build
[lfs@localhost binutils-build]# ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls

That were the steps I made on LFS 6.0

On LFS 6.1 I did following steps according to its book;
Code:

[satimis@localhost ~]$ su -
Password:
[root@localhost ~]# export LFS=/mnt/lfs
[root@localhost ~]# mount /dev/hda6 $LFS
[root@localhost ~]# mkdir -p $LFS
[root@localhost ~]# mkdir $LFS/sources
[root@localhost ~]# chmod a+wt $LFS/sources
[root@localhost ~]# chown lfs $LFS/sources
[root@localhost ~]# su - lfs
lfs:~$ cd /mnt/lfs/sources/
lfs:/mnt/lfs/sources$ tar jxvf binutils-2.15.94.0.2.2.tar.bz2 
lfs:/mnt/lfs/sources$ mkdir ../binutils-build
mkdir: cannot create directory `../binutils-build': Permission denied
lfs:/mnt/lfs/sources$ su -
Password:
[root@localhost ~]# cd /mnt/lfs/sources/
[root@localhost sources]# mkdir ../binutils-build
[root@localhost sources]# cd ../binutils-build
[root@localhost binutils-build]# ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls
-bash: ../binutils-2.15.94.0.2.2/configure: No such file ordirectory

B.R.
satimis

kjordan 07-18-2005 12:20 PM

Every set of instructions in LFS assumes you have untarred the source and have changed directories into the source directory. So the "mkdir ../binutils-build" should be executed from the binutils-2.15.w.x.y.z directory.

ParticleHunter 07-18-2005 02:16 PM

Hi,

the correct order for the commands should be the following:

[after su - lfs]

cd $LFS/sources
tar xjf binutils-2.15.94.0.2.2.tar.bz2
(no need for the v except in the case you want the command to be executed with verbosity, that's... text output for every file extracted from the tarball)
cd binutils-2.15.94.0.2.2
mkdir ../binutils-build
cd ../binutils-build


and from this step you can perform the configure step as you're in the correct location and you will find the configure script with no problem ;)

hope this helps,

Julio

satimis 07-18-2005 08:01 PM

Hi ParticleHunter,

Tks for your advice.

Quote:

[b][after su - lfs

cd $LFS/sources
Performed following test;

[satimis@localhost ~]$ su -
Password:
[root@localhost ~]# export LFS=/mnt/lfs
[root@localhost ~]# mount /dev/hda6 $LFS
[root@localhost ~]# echo $LFS
/mnt/lfs
[root@localhost ~]# chown lfs $LFS/tools
[root@localhost ~]# chown lfs $LFS/sources
[root@localhost ~]# su - lfs
lfs:~$
(here it changed back to 'user')

Continued
lfs:~$ cd $LFS/sources
lfs:/mnt/lfs/sources$ tar xjf binutils-2.15.94.0.2.2.tar.bz2
lfs:/mnt/lfs/sources$ mkdir ../binutils-build
mkdir: cannot create directory `../binutils-build': Permission denied
lfs:/mnt/lfs/sources$

As user I was not allowed to create direcftory on /sources

Continued, "su -"
Remark: LFS root password did not work. It worked here only with FC3 Host password.

lfs:/mnt/lfs/sources$ su -
Password: (LFS password)
su: incorrect password
lfs:/mnt/lfs/sources$ su -
Password: (FC3 Host password)
[root@localhost ~]# mkdir ../binutils-build
[root@localhost ~]# cd ../binutils-build/
[root@localhost binutils-build]# ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls
-bash: ../binutils-2.15.94.0.2.2/configure: No such file or directory

I came back to the same situation.

B.R.
satimis

kjordan 07-18-2005 08:06 PM

lfs:~$ cd $LFS/sources
lfs:/mnt/lfs/sources$ tar xjf binutils-2.15.94.0.2.2.tar.bz2
lfs:/mnt/lfs/sources$ mkdir ../binutils-build
mkdir: cannot create directory `../binutils-build': Permission denied
lfs:/mnt/lfs/sources$

There you are in sources, when you should cd into the untarred binutils directory. Or just do "mkdir binutils-build" from /mnt/lfs/sources and "cd binutils-build".

[root@localhost ~]# mkdir ../binutils-build
[root@localhost ~]# cd ../binutils-build/
[root@localhost binutils-build]# ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls
-bash: ../binutils-2.15.94.0.2.2/configure: No such file or directory

You were in your root users home directory when you did that, so you're still in the wrong place.

satimis 07-18-2005 08:35 PM

Hi kjordan,

Quote:

There you are in sources, when you should cd into the untarred binutils directory. Or just do "mkdir binutils-build" from /mnt/lfs/sources and "cd binutils-build"
Your advice works here. Tks,

Steps performed as follows;

[root@localhost ~]# su - lfs
lfs:~$ cd $LFS/sources
lfs:/mnt/lfs/sources$ mkdir binutils-build
lfs:/mnt/lfs/sources$ cd binutils-build/
lfs:/mnt/lfs/sources/binutils-build$ ../binutils-2.15.94.0.2.2/configure --prefix=/tools --disable-nls
Code:

creating cache ./config.cache
checking host system type... i686-pc-linux-gnu
.......
updating cache ./config.cache
creating ./config.status
creating Makefile
lfs:/mnt/lfs/sources/binutils-build$

lfs:/mnt/lfs/sources/binutils-build$ make
lfs:/mnt/lfs/sources/binutils-build$ make install
lfs:/mnt/lfs/sources/binutils-build$ make -C ld clean
lfs:/mnt/lfs/sources/binutils-build$ make -C ld LIB_PATH=/tools/lib

All went through

The book in the section is not all correct
http://www.linuxfromscratch.org/lfs/...ils-pass1.html

B.R.
satimis

kjordan 07-19-2005 12:15 AM

It's correct, just not complete in the explanation. I don't remember if it says it somewhere, but each section assumes you have done a "tar xjf source-version.tar.bz2" and "cd source-version".

satimis 07-19-2005 05:56 AM

Hi kjordan,

Tks for your advice.

Quote:

each section assumes you have done a "tar xjf source-version.tar.bz2" and "cd source-version".
Yes, I learnt it on building LFS 6.0. But I failed to discover where it has been mentioned.

I don't know why the book suggesting to run;
Code:

# mkdir ../binutils-build
# cd ../binutils-build/

It goes to the Root environment of FC3, the Host not LFS. I'll keep it in mind. On the sebsequent sections if the book suggests to run;
Code:

mkdir ../package-build
cd ../package-build/

I'll run
Code:

mkdir package-build
cd package-build/

instead.

B.R.
satimis

ParticleHunter 07-19-2005 09:06 AM

Hi,

yes, instead of entering directly the source directory and making the build directory it's also effective, I suppose the practice of entering the source, leaving it to enter the build directory and then configuring and compiling the package is, in a certain way, intented for you not to forget to do the practice of unpacking-and-entering-the-source-dir ;)

Julio


All times are GMT -5. The time now is 02:00 AM.