LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 04-21-2006, 05:34 AM   #1
thomas55
LQ Newbie
 
Registered: Nov 2005
Posts: 16

Rep: Reputation: 0
5.4. GCC-3.4.3 - Pass 1 invalid host type problem


i have took a screenshot of this can someone help the screenshot is at http://img162.imageshack.us/img162/3...eenshot0gk.jpg
 
Old 04-28-2006, 05:28 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
--libexecdir=/lib/tools: invalid host type
make sure you have unset any relevant variables, such as CFLAGS and CXXFLAGS (this is actually mentioned in the book)... the book also recommends that you DO NOT build GCC build in it's source directory, BTW...
 
Old 04-29-2006, 02:24 AM   #3
thomas55
LQ Newbie
 
Registered: Nov 2005
Posts: 16

Original Poster
Rep: Reputation: 0
how do i build it out of the source directory? ive already made a directory called gcc-build how do i tell gcc to compile in gcc build?
 
Old 04-29-2006, 03:00 AM   #4
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by thomas55
how do i build it out of the source directory? ive already made a directory called gcc-build how do i tell gcc to compile in gcc build?
by following the instructions maybe??? hehe...

basically you just cd into the empty gcc-build directory and then from there you execute the configure script (by specifying the path to it) and then the make, etc...

the instructions/examples in the book a pretty straight-forward:
Code:
# This assumes you are currently in the GCC source dir.
mkdir -v ../gcc-build
cd ../gcc-build
Code:
../gcc-3.4.3/configure --prefix=/tools \
    --libexecdir=/tools/lib --with-local-prefix=/tools \
    --disable-nls --enable-shared --enable-languages=c
Code:
make bootstrap

Last edited by win32sux; 04-29-2006 at 03:06 AM.
 
Old 04-29-2006, 03:29 AM   #5
thomas55
LQ Newbie
 
Registered: Nov 2005
Posts: 16

Original Poster
Rep: Reputation: 0
i dident think it was that easy thanks anyway
 
Old 04-29-2006, 04:46 AM   #6
thomas55
LQ Newbie
 
Registered: Nov 2005
Posts: 16

Original Poster
Rep: Reputation: 0
still getting the same error even when i build out of the source directory i dont think cflags or cxxflags are on as i havent turned them on theres another screenshot here can anyone help me? also im using the live cd as my host distrobution http://img134.imageshack.us/img134/598/shot9uj.jpg

Last edited by thomas55; 04-29-2006 at 08:08 AM.
 
Old 04-30-2006, 06:05 AM   #7
thomas55
LQ Newbie
 
Registered: Nov 2005
Posts: 16

Original Poster
Rep: Reputation: 0
are cflags and cxxflags enabled by default? if so how do i disable them?
 
Old 04-30-2006, 04:59 PM   #8
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
just echo them to see if they are set:
Code:
echo $CFLAGS
echo $CXXFLAGS
if they are set, then just unset them:
Code:
unset CFLAGS
unset CXXFLAGS
either way, i don't think this is what's causing your problem...
 
Old 05-01-2006, 12:24 PM   #9
thomas55
LQ Newbie
 
Registered: Nov 2005
Posts: 16

Original Poster
Rep: Reputation: 0
i was putting \ in the wrong places i might get some more experience with linux befroe i continue
 
Old 05-01-2006, 03:21 PM   #10
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by thomas55
i was putting \ in the wrong places i might get some more experience with linux befroe i continue
now that you mention it, i just noticed that in your screenshot indeed... good catch...

BTW, the backslash lets you keep typing a command on the following line... so you'd hit ENTER after using a backslash, and then you could continue typing on a new line without the command getting executed yet (until you hit ENTER *without* a backslash)... if you're okay typing the whole command continuously then there isn't any need for the backslash at all... in this case, it's mainly for cosmetic purpouses...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS-5.0 GCC problem with binutils-2.14 pass 1 NCappaZoo Linux From Scratch 6 06-14-2009 03:47 AM
questions on GCC-3.4.3 - Pass 2 and Binutils-2.15.94.0.2.2 - Pass 2 satimis Linux From Scratch 7 12-26-2005 09:23 PM
Solved Problem Second GCC-Pass(or gettext sanity check problem) hoes Linux From Scratch 0 09-04-2005 10:20 AM
odd problem with GCC pass 1... :scratch: ParticleHunter Linux From Scratch 15 12-05-2004 10:21 PM
Arch linux Help Cannot Type Pass bigbossandy Linux - Newbie 1 12-20-2003 10:11 AM


All times are GMT -5. The time now is 09:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration