LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Enterprise (http://www.linuxquestions.org/questions/linux-enterprise-47/)
-   -   VirtualBox PXE Boot CentOs 64bit Client install hangs after Dquot-cache (http://www.linuxquestions.org/questions/linux-enterprise-47/virtualbox-pxe-boot-centos-64bit-client-install-hangs-after-dquot-cache-834187/)

spook2 09-24-2010 03:17 AM

VirtualBox PXE Boot CentOs 64bit Client install hangs after Dquot-cache
 
VirtualBox latest version is installed on my Win7 Pro x86_64 laptop.
Residing in the VirtualBox environment are :

CentOS 64bit (DHCP, TFTP, FTP) Server. Network set ot "intnet"
(IDE drive type as when installing it didn't like the laptops SATA controller!)

CentOS 64bit empty client - disk created but not formatted. Network set to "intnet" also with an IDE controller\drive.

On starting the prospective CentOS client :

The DHCP address is retreived :)
The TFTP server is contacted and the pxeimage.0 downloaded - blootloader runs :)
The FTP server supplies the vmlinuz.... and starts the install :)

But
when the following line has appeared the client hangs (no error):scratch:

Dquot-cache hash table entries: 512 (order 0, 4096 bytes)

I presume all of the PXE portion is completed by this stage?
Initial guess would involve the FTP image being corrupt but it is the same image ISO I used to install the first VirtualBox server (CentOS 64bit (DHCP, TFTP, FTP))
mounting the ISO directly - (mount -o loop...)

Anyone have any ideas as to why this hangs?
or failing that what it might be hanging on -
is it the Dquot-cache (disk related?)
or the command that is due after that? - I'm not sure what that would be.....

Any help or pointers would be greatly appreciated.

Many Thanks

Luke

carltm 09-25-2010 08:05 AM

Just want to make sure I understand this. In VirtualBox language you
have a Windows host, a CentOS guest that runs the pxe services, and
a second guest which is having problems installing CentOS. Right?

I don't know what the Dquot-cache error means, but I know that the
pxe boot process completed. My suggestion would be to boot from a
live cd iso (such as knoppix) just to verify that the virtual hardware
is good.

Also I don't understand what you are using for the hard drives on
the guest. It sounds like you tried to use a partition on the host's
hard drive, but that didn't work. So I'm guessing that you created
a virtual hard drive. What options did you use for that?

spook2 09-27-2010 04:47 AM

Yes that's about it... Laptop with windows 7 64bit.
Virtualbox 3.2.8 (latest) installed on that.
CentOs 4.8 as a guest on virtual box with IDE virtual drive and PXE services

Then another virtual Guest CentOS 4.8 set with boot order to network only. Storage is a virtual IDE 20gb expandable drive running on a IDE ICH6 virtual controller (this is exactly the same setup as the virtual PXE server setup)

Thanks for the tip so far... I was pretty sure the PXE part was complete but nice to hear it from another source.

I've got hold of the latest CentOS (5.5) and so will try to PXE off that and see if it does the same... if so i'll try the live cd...

I'll post how I get on...

thanks...

silvertip257 05-12-2011 07:37 PM

spook2,

Have you found anything out?

I've got a similar 'server' setup hosting DHCP, TFTP, but NFS instead of FTP.
I can boot Debian/Ubuntu OSes with the netboot and nfsroot init parameters, but I'm not having much luck finding a RedHat/Fedora/CentOS solution.

Thanks for any information.

PS: I hope to avoid the livecd-iso-to-pxeboot process in creating a huge initrd.

tmpname 02-19-2012 11:52 PM

Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
 
Linux guest (RHEL 4.8 in my case) hangs during boot from installation media.

Last line in the VirtualBox window:
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)

This is because (in my case) IOAPIC is off.
After turning it on

VBoxManage modifyvm RHEL48 --ioapic on

Linux starts without the hang.

carltm 02-20-2012 06:46 AM

tmpname, thanks for the update.


All times are GMT -5. The time now is 07:20 PM.