LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices



Reply
 
Search this Thread
Old 12-07-2007, 12:16 AM   #1
rockjr
Member
 
Registered: Dec 2007
Posts: 30

Rep: Reputation: 15
setting up telnet on redhat enterprise linux 5


i want to practice from work and i have a server at home that i just set up so can anyone tell me how to set up telnet on my red hat????
 
Old 12-07-2007, 03:17 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
don't use telnet, use ssh instead, it'll already be fully working in terms of the machine itself, but you'll presumably be needing to do some port forwarding on a home router and such to reach it... http://portforward.com.
 
Old 12-07-2007, 07:13 AM   #3
rockjr
Member
 
Registered: Dec 2007
Posts: 30

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by acid_kewpie View Post
don't use telnet, use ssh instead, it'll already be fully working in terms of the machine itself, but you'll presumably be needing to do some port forwarding on a home router and such to reach it... http://portforward.com.
i already did port forwarding using my virture server selection in my router.... i looked into service config on the linux r.h.e box and it said sshd is running but when i try to log in using putty it still doesnt work. Can anyone tell me step by step how to config the r.h.e 5 server box
 
Old 12-07-2007, 08:24 AM   #4
Aaronk
LQ Newbie
 
Registered: Nov 2002
Location: Morris Plains, NJ
Distribution: FC 3-8, RH3-4
Posts: 17

Rep: Reputation: 0
first test it from within your home network, (google "putty" first thing that pops up is one of the more popular of hundreds of ssh clients available - download it to a windows or other box on the same LAN as your home server) open putty or another SSH client, and simply put in the LOCAL (non-routeable) IP of the home server. I have yet to see an RH / Fedora build that doesn't have an SSH daemon running post (typical) install. For this excesize we'll assume you went with a somewhat normal install. If that doesn't work go back and check your firewall and SELinux settings on the RH box. Firewall settings can easily be accessed by typing "setup" from a root prompt. You're going to need to make sure its either turned off or have TCP port 22 allowed. Do a google search for SELinux, but I would recommend just disabling it until you have SSH functioning, then go back and update it appropriately. After changing SELinux you'll have to reboot. Next, retest - you should definately be able to SSH to your home server from within your LAN at this point. Next you'll have to mess with your main router / firewall. It will be easiest to activate remote administration temporarily for your router. Check and make sure you have TCP 22 forwarded to whatever the local ip is for your RH server. Go to work, test. if it still fails log into your router and double check your work. If it all seems correct but youre' still failing, go to a friends house and check from there. Its entirely possible your corporate IT dept is blocking outgoing SSH requests.
 
Old 12-07-2007, 06:32 PM   #5
rockjr
Member
 
Registered: Dec 2007
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Aaronk View Post
first test it from within your home network, (google "putty" first thing that pops up is one of the more popular of hundreds of ssh clients available - download it to a windows or other box on the same LAN as your home server) open putty or another SSH client, and simply put in the LOCAL (non-routeable) IP of the home server. I have yet to see an RH / Fedora build that doesn't have an SSH daemon running post (typical) install. For this excesize we'll assume you went with a somewhat normal install. If that doesn't work go back and check your firewall and SELinux settings on the RH box. Firewall settings can easily be accessed by typing "setup" from a root prompt. You're going to need to make sure its either turned off or have TCP port 22 allowed. Do a google search for SELinux, but I would recommend just disabling it until you have SSH functioning, then go back and update it appropriately. After changing SELinux you'll have to reboot. Next, retest - you should definately be able to SSH to your home server from within your LAN at this point. Next you'll have to mess with your main router / firewall. It will be easiest to activate remote administration temporarily for your router. Check and make sure you have TCP 22 forwarded to whatever the local ip is for your RH server. Go to work, test. if it still fails log into your router and double check your work. If it all seems correct but youre' still failing, go to a friends house and check from there. Its entirely possible your corporate IT dept is blocking outgoing SSH requests.

ok my router is set to port 23.... do i need to use 22 or does it not matter
 
Old 12-07-2007, 07:13 PM   #6
rockjr
Member
 
Registered: Dec 2007
Posts: 30

Original Poster
Rep: Reputation: 15
Question

ok, in putty i switched it to ssh (whats the dif between that and telnet) and cant log into it outside the router or inside the network either... i did make sure that ssh was cut on... and i switch the router from port 23 to 22 but its still not working
 
Old 12-07-2007, 09:48 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Telnet's default port is 23
Telnet sends EVERYTHING including your username and password in PLAIN TEXT so anyone can read it..

You should only use telnet if the box you are connecting to cannot do SSH and you have absolutely no other possible secure options available. Never is a good time to use telnet..


SSH default port is 22
SSH Encrypts your connection including your username and password.



When using putty select SSH

Your Router should be set to forward Port 22 to your RHEL box..

Provided your sshd is configured to accept connections on port 22 (netstat -alnp | grep ::22) and there is no firewall on your RHEL box (iptables -L) that is blocking port 22, or the firewall is configured to accept connections on port 22.. then you should be able to connect..

Last edited by farslayer; 12-07-2007 at 09:49 PM.
 
Old 12-08-2007, 06:25 PM   #8
rockjr
Member
 
Registered: Dec 2007
Posts: 30

Original Poster
Rep: Reputation: 15
Question

Well i have a dlink gaming router ... forgot model number

right now i am trying from inside the network first

have ip hard coded in box which is 192.168.0.155

ssh is activated but firewall is not

rhl box can get on the internet itself

i am using putty (is this the best ssh/telnet software out there)

it keeps freezing up if i use ssh or when i try to use telnet it trys to connect and then blows away
 
Old 12-08-2007, 07:51 PM   #9
rockjr
Member
 
Registered: Dec 2007
Posts: 30

Original Poster
Rep: Reputation: 15
Question

ok... got that part figured out.... it was supposed to be imputted as so .... whatevertheacctnameis@84.34.44.4 .....

so i got it now... i am able to log in from internally and externally.... thanks for all the help guys.... i am a rookie on this trying to get my linux+ sometime early next year so wish me luck

ps. whats the best ssh software out there that i can use on my computer and one for my pocketpc device????

Last edited by rockjr; 12-08-2007 at 07:59 PM.
 
Old 12-09-2007, 07:58 AM   #10
Aaronk
LQ Newbie
 
Registered: Nov 2002
Location: Morris Plains, NJ
Distribution: FC 3-8, RH3-4
Posts: 17

Rep: Reputation: 0
From a windows environment I use Putty (http://www.chiark.greenend.org.uk/~s.../download.html). From my Linux environments I use open source SSH client that comes with the OS from the command line
.
 
Old 12-10-2007, 02:38 PM   #11
dmarti
LQ Newbie
 
Registered: Aug 2006
Location: Alameda, California
Distribution: debian, ubuntu
Posts: 4

Rep: Reputation: 0
Rick Moen's ssh client list

Check Rick Moen's list at: http://linuxmafia.com/ssh/ to find an ssh client you can use from your other machines, whatever OS they run.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat 9.0 Firwall setting to enable telnet/ftp sathishc Linux - Networking 1 04-26-2004 01:00 PM
help: Setting up telnet service in linux tejpatil Linux - Newbie 3 02-09-2004 11:38 PM
Help me: setting up telnet service in rehat linux 7.1 tejpatil Linux - Newbie 0 02-09-2004 08:50 PM
RedHat enterprise Linux Help sarika_ni Red Hat 2 12-20-2003 01:48 PM
enablind ftp and telnet in SUSE Linux Enterprise Server 8.0 mbhenry Linux - General 1 11-03-2003 01:42 PM


All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration